Changes

From Dynomotion

Jump to: navigation, search

Kanalog Hardware Info

96 bytes added, 18:25, 28 July 2018
fix font
==Initial Setup/Testing for Analog Amplifiers==
<div style="color: #000000; font-size: 13px; font-family: tahoma, 'new york', times, serif; background-color: transparent; font-style: normal;">There is a starting configuration for KFLOP+Kanalog called KanalogInitialPID.mot in the \KMotion\Motors folder.  Load it into an axis channel from the KMotion Configuration Screen.</div><div style="color: #000000; font-size: 13px; font-family: tahoma, 'new york', times, serif; background-color: transparent; font-style: normal;">  The basic first steps are to verify the hardware:</div># check the encoder counts correctly# check that the DACs can command the Amplifier to control motor speed.  Test Console commands like DAC0=200  (with the axis disabled)# Enable the Servo using the Step Response Screen.  Zero, Enable 
# check the encoder counts correctly as shown on the KMotion Axis Screen Position (a KFLOP Axis must be configured as Encoder Input with the Input Channel0 set to the channel where the encoder is physically connected)
# check that the DACs can command the Amplifier to control motor speed.  Test Console commands like DAC0=200 to Output ~ -1V (with the axis disabled - if any axis is enabled and continuously writing to the DAC any Console Command will be overwritten)
# If steps #1 and #2 above work correctly, enable the Servo using the Step Response Screen.  Zero, Enable.  The motor should then attempt to weakly hold position.
==Configuring DAC and Encoder Channels==