extra uncompensated steps

Moderators: TomKerekes, dynomotion

Post Reply
Vato Kattanen
Posts: 3
Joined: Thu Feb 07, 2019 7:26 am

extra uncompensated steps

Post by Vato Kattanen » Thu Feb 07, 2019 8:18 am

Good day. I have kflop v1.2, KMotion & KMotionCNC v4.34.
Сonnected to it 4 servopack SGDM-04-ada in step/dir mode, 2 servo as axis X (X1, X2), 1 as axisY, 1 as axis Z.
I have problem in G-code program cantaining G2, G3 codes (example attached). Position axis X1, X2, Y exceeds destination for different meanings (example screen attached). And only in mode CLStep. In mode Step Dir all ok.
I tried next options:
1) Connect Servopack as open collector, LVTTL, Puls-Sign, CW-CCW, quadrature - no result.
2) Redused velociti, accel, jerk - - no result.
If I test axis in CLStep mode in step response - all axis go from 0 to 0 every time... i'm dont understand how its may be...
How can it be after the eng G-code pogram Dest axis 3 = 90315 and Pasition axis 3 = 90421?
Help mi please. Config axis in attachment.
You do not have the required permissions to view the files attached to this post.

User avatar
TomKerekes
Posts: 273
Joined: Mon Dec 04, 2017 1:49 am

Re: extra uncompensated steps

Post by TomKerekes » Thu Feb 07, 2019 5:54 pm

Hi Vato,

You must be loosing steps or counts.

What are your KMotionCNC Trajectory Planner Settings?

It isn't clear what velocity you are testing (Plot velocity and attach raw data).

What IIR Filters do you have?
Regards,

Tom Kerekes
Dynomotion, Inc.

Vato Kattanen
Posts: 3
Joined: Thu Feb 07, 2019 7:26 am

Re: extra uncompensated steps

Post by Vato Kattanen » Fri Feb 08, 2019 6:52 am

Today I turned off all filters, and change PID to: P=0, I=0.05(0.03 for x1 and x2), D=0, feed forvard V=0, A=0. Its +- correct error for mi.
After this i'm testing system ang all axis go from 0 to 0.
I'm testing my g-code program run 5 times and always correct.
IIR not using, traecory planer in attachment.
Now I will work on the current working settings. Do I need an IIR if I use a servopack step-dir, and there is no drift and oscillation?

For today the question remains - how is it possible that does not return the axis, seeing at the same time that the encoder axis has moved forward ...
You do not have the required permissions to view the files attached to this post.

User avatar
TomKerekes
Posts: 273
Joined: Mon Dec 04, 2017 1:49 am

Re: extra uncompensated steps

Post by TomKerekes » Fri Feb 08, 2019 3:56 pm

Hi Vato,
Today I turned off all filters, and change PID to: P=0, I=0.05(0.03 for x1 and x2), D=0, feed forvard V=0, A=0. Its +- correct error for mi.
After this i'm testing system ang all axis go from 0 to 0.
I'm testing my g-code program run 5 times and always correct.
It seems it is now working ok?
Do I need an IIR if I use a servopack step-dir, and there is no drift and oscillation?
Probably not. Adding a low pass filter may make it possible to use higher Gains to make corrections more quickly.
traecory planer in attachment.
Those Trajectory Parameters look reasonable. Possibly the acceleration is very low:

2 in/sec2 x 1G/384in/sec2 = 0.005G

High speed machines are often 10X or more higher.
For today the question remains - how is it possible that does not return the axis, seeing at the same time that the encoder axis has moved forward ...
I'm not sure I understand the question. But KFLOP will only correct for loss Steps by the amount you allow. Max Limit Output and Max Limit Integrator will limit the correction. Previously you had limits of 2048 steps. So for example if 3048 steps were missed then there would still be an error of 1000 steps.

It is usually best tune the system better (as you did) to avoid introducing stalls or loss of steps rather than trying to correct them. Then use Max Following Error to disable and stop if large errors ever occur.

HTH
Regards,

Tom Kerekes
Dynomotion, Inc.

Vato Kattanen
Posts: 3
Joined: Thu Feb 07, 2019 7:26 am

Re: extra uncompensated steps

Post by Vato Kattanen » Sat Feb 09, 2019 11:15 am

OK, thenk you. Now its working correct. I will study the theory more deeply and try to adjust more well.

Post Reply