Page 1 of 1

Config doesn't find all axes

Posted: Tue Dec 10, 2019 9:31 pm
by ZooBDoo
I created an init C program that sets up three axes in Snap Amps with appropriate gains etc. Two brushless servos and one microstepper. All the axes operate when I run the init program but when I go to the config screen and do an "UPload All" it only finds 2 of the three axes. Is there a certain "layout" of the axes required in the init program for it to find all of them? I have them all sequentially set up, but not in axis numerical order.
HomeBrushlessCGI_0_2b.c
3 axis init file
(8.27 KiB) Downloaded 16 times

Re: Config doesn't find all axes

Posted: Wed Dec 11, 2019 12:02 am
by TomKerekes
Hi ZoobDoo,

Import/Export basically searches for a continuous block of lines that all begin with a channel reference ie. 'ch0->'. I see you inserted a comment line in the middle of channel 0. If you delete the comment or move it to the end of a valid line it should then work. The Axis channels may be specified in any order.

Re: Config doesn't find all axes

Posted: Thu Dec 12, 2019 11:44 pm
by ZooBDoo
That fixed it!
Thanks.
AZ