Snap Amp Channels

Moderators: TomKerekes, dynomotion

Post Reply
ZooBDoo
Posts: 15
Joined: Tue May 07, 2019 4:35 pm

Snap Amp Channels

Post by ZooBDoo » Sun Nov 24, 2019 9:12 pm

Hello,
I'm a bit confused about the Snap Amp Channel configurations.

Update: I figured this out with a little reasoning and testing.

The tutorial chart on "Channels" doesn't seem to cover SnapAmp configurations unless I'm missing something.

Looking at the SnapAmp output connector diagram Out #0 thru Out #7:

Depending on the motor type, the Axis number on the SnapAmp connector picture changes so it's not clear what to define in the config screen and the C init programs for the KCNC axis designators. (X,Y, Z, handwheel, spindle ) etc. It looks like If I use two steppers I can only use Axis 0 and Axis 2 designators per the Snap Amp connector/PWM channel layout picture. Or am I looking at this wrong?



Thank you.

User avatar
TomKerekes
Posts: 665
Joined: Mon Dec 04, 2017 1:49 am

Re: Snap Amp Channels

Post by TomKerekes » Mon Nov 25, 2019 8:19 pm

Hi ZooBDoo,

I think you are confusing Axis Channels with Full Bridge Output Channels and Encoder Channels. You might read this from the wiki.

I'd suggest using:
Axis 0 for X axis
Axis 1 for Z axis
Axis 2 for Spindle
Axis 3 for handwheel encoder input

Configure each axis's Input and Output Channels for the devices used.

Then configure GCode Coordinate System to use the X and Z axes with:

DefineCoordSystem(0,-1,1,-1); // define X as Axis 0 and Z as Axis 1

HTH
Regards,

Tom Kerekes
Dynomotion, Inc.

ZooBDoo
Posts: 15
Joined: Tue May 07, 2019 4:35 pm

Re: Snap Amp Channels

Post by ZooBDoo » Wed Nov 27, 2019 8:31 pm

Thanks for the reply.

I did read the wiki before but that's where some of the confusion happened because the connector and pin numbers and encoder channel numbers in that diagram didn't follow Snap Amp connections. For example, the Channels diagram shows the encoder channel inputs as JP7 and JP5 and number encoder input channels 0 - 7. These don't correspond to the SnapAmp encoder inputs which are on different pins and are channels 8 - 15. The pinout designations on the SnapAmp 50 pin connector also don't show the encoder channel numbers (8 thru 15) to be used in the configuration screen. This information was found in various other places.

The biggest AHA! for me was to realize that the channel number at the top of each configuration dialog was the "axis channel" number used in the C programs and the G code coordinate system. Also, that the Snap Amp output channels number 8-15, NOT 0 - 7 and the Step-Direction and PWM channels and connections in the "Channels" diagram are not used in a typical Snap Amp configuration.

Once I got the various channel numbers to make sense the configuration was a piece of baklava.

Thanks again.
AZ

Post Reply