USB driver not working

Moderators: TomKerekes, dynomotion

Bernie
Posts: 10
Joined: Thu Jan 03, 2019 5:36 pm

USB driver not working

Post by Bernie » Sat Jan 19, 2019 3:37 am

I am unable to get the USB driver working with KFLOP in Windows 10. When I connect KFLOP to a USB port after uninstalling the non functioning driver, Windows tells me "we're setting up KFLOP motion controller" and then, after a second or two, "KFLOP motion controller is set up and ready to go". When I then go to the Device Manager, I see the KFLOP motion controller under "other devices" with a yellow caution sign.
When I click on properties I am told "drivers for this device are not installed (code 28)". Going through the driver update routine does not work either.
I also disabled the Windows driver signature enforcement to no avail. Clicking on Dynoport.inf and then "install" makes no difference.
My Windows has the latest updates. I have spent an afternoon on this and can't think of anything else to do.

User avatar
TomKerekes
Posts: 982
Joined: Mon Dec 04, 2017 1:49 am

Re: USB driver not working

Post by TomKerekes » Sat Jan 19, 2019 6:30 pm

Hi Bernie,

What Version of KMotion are you using?

Are you following all the steps toward the end of this article to remove/install the Drivers?
Regards,

Tom Kerekes
Dynomotion, Inc.

Bernie
Posts: 10
Joined: Thu Jan 03, 2019 5:36 pm

Re: USB driver not working

Post by Bernie » Sat Jan 19, 2019 6:58 pm

Hi Tom,
Yes, I am following those instructions. This may not have anything to do with my driver problems: I just received the board 2 days ago. Does it have the latest firmware on it? I downloaded KMotion just about two weeks ago. How do I find out what version I have?
Bernie

User avatar
TomKerekes
Posts: 982
Joined: Mon Dec 04, 2017 1:49 am

Re: USB driver not working

Post by TomKerekes » Sat Jan 19, 2019 7:26 pm

Hi Bernie,

Recent boards are shipped with Latest Released Version 4.34.

The Firmware Version in KFLOP shouldn't have anything to do with the Software/Driver Versions on the PC.

To check the Software Version loaded on the PC run KMotion.exe then Help | About

To check the Firmware Version in KFLOP enter "Version" on the Console Screen (obviously the Windows/USB Drivers must be properly installed for this to work).

You might post Screen Shots of each Step you are doing so we can verify how you are removing/updating the Drivers and what messages you receive from Windows.
Regards,

Tom Kerekes
Dynomotion, Inc.

Bernie
Posts: 10
Joined: Thu Jan 03, 2019 5:36 pm

Re: USB driver not working

Post by Bernie » Sat Jan 19, 2019 9:17 pm

Hi Tom,
Here are some screen shots.
devman1.png
devman2.png
devman2.png (7.14 KiB) Viewed 1656 times
I then click uninstall, unplug the USB and plug it back in.
After KFLOP stops blinking windows tells me "that it is setting up the KFLOP Motion Controller,
and then, " device is ready - KFLOP Motion Controller is set up and ready to go"
Then it doesn't work.
Sorry to see you working on weekends.
Bernie

User avatar
TomKerekes
Posts: 982
Joined: Mon Dec 04, 2017 1:49 am

Re: USB driver not working

Post by TomKerekes » Sun Jan 20, 2019 1:11 am

Hi Bernie,

What Version of KMotion is installed?

You will need to Update Drivers and direct Windows to use our our Drivers in the "USB Driver" folder.

Do you have administrator privileges?

Please post screen shots of your Update Driver process.
Regards,

Tom Kerekes
Dynomotion, Inc.

Bernie
Posts: 10
Joined: Thu Jan 03, 2019 5:36 pm

Re: USB driver not working

Post by Bernie » Sun Jan 20, 2019 1:54 am

Thanks Tom,
My KMotion is version 4.34 and I do have administrator privileges.
Bernie

User avatar
TomKerekes
Posts: 982
Joined: Mon Dec 04, 2017 1:49 am

Re: USB driver not working

Post by TomKerekes » Sun Jan 20, 2019 2:14 am

Hi Bernie,

Please post screen shots of your Update Driver process.
Regards,

Tom Kerekes
Dynomotion, Inc.

Bernie
Posts: 10
Joined: Thu Jan 03, 2019 5:36 pm

Re: USB driver not working

Post by Bernie » Sun Jan 20, 2019 4:28 am

Hi Tom,
Here are some screen shots.
devman3.png
devman5.png
When I click on the i386 folder no .inf file becomes visible.
When I use file explorer to look at the contents of the i386 folder I do see dynoport.inf.
When I right-click on dynoport.inf and then on "install", it gets installed but does't work.
You just gota love windows.
Thanks
Bernie

User avatar
TomKerekes
Posts: 982
Joined: Mon Dec 04, 2017 1:49 am

Re: USB driver not working

Post by TomKerekes » Sun Jan 20, 2019 10:26 am

Hi Bernie,

Please select the “USB Driver” folder not the “USB Driver\i386” directory. You may need to check include subfolders. I386 is for 32-bit Windows. Is your OS 32-bits or 64-Bits?
Regards,

Tom Kerekes
Dynomotion, Inc.

Post Reply