cannot read config file

Moderators: TomKerekes, dynomotion

Post Reply
Winch
Posts: 2
Joined: Thu Mar 28, 2019 9:59 am

cannot read config file

Post by Winch » Tue May 25, 2021 6:46 pm

I few years ago I modified a mill with a Kflop, Kstep, and 2 snap amps running under Mach3. It has developed a problem where I get a message saying X, Y or both axis are disabled when switched on. If you keep trying usually, eventually it will start ok and then all functions work fine. I thought the problem might be noise on the end stops or e stops so went to open K motion to look at the digital i/o lamps to see if any were flickering. However I got a pop up message saying, 'previous configuration file. C:\KMotion433q\KMotion\Data\persist.ini could not be read. Continuing will cause a loss of all settings. Are you sure you would like to continue? Naturally I said no. What has gone wrong? Would this explain the disabled axis issue? What is the way forward?
Your help would be appreciated.
Thanks

User avatar
TomKerekes
Posts: 1515
Joined: Mon Dec 04, 2017 1:49 am

Re: cannot read config file

Post by TomKerekes » Tue May 25, 2021 8:23 pm

Hi Winch,

That indicates that file was somehow corrupted. This can be caused by turning off the PC without doing a shut down first.

If you have a backup you can restore that file.

That particular configuration file for KMotion.exe is not extremely critical. It just persists the previous screen positions, Console Commands last entered and such if you continue it should set everything to defaults.

This is probably unrelated to the axis disabled issue. Check for messages on the KMotion.exe Console screen. Not sure what you mean by "switched on". But it isn't usually a good idea to have servo axes enabled with the amplifiers switched off. This is because if there is any small error the servo will try to correct it and apply an ever increasing output until at maximum. So then when power is supplied there can be a violent jump.
Regards,

Tom Kerekes
Dynomotion, Inc.

Winch
Posts: 2
Joined: Thu Mar 28, 2019 9:59 am

Re: cannot read config file

Post by Winch » Wed May 26, 2021 12:48 pm

Hi Tom
Thanks for your speedy reply. I will say yes to the pop up and hopefully open KMotion and look at the console info. I was just concerned I might loose all the configuration data.
Switched on is not a good term! The servos are not enabled before the amplifiers.
The machine is on a different site to me and currently running a job, having got it to start up without any axis disabled I told them not to switch it off.
When the job is finished I will visit and report back if I can determine why the axis are sometimes disabled.
Thanks.

User avatar
TomKerekes
Posts: 1515
Joined: Mon Dec 04, 2017 1:49 am

Re: cannot read config file

Post by TomKerekes » Wed May 26, 2021 3:48 pm

Hi Winch,

Another issue may be how the axes are being enabled. If Enabling with a different destination than where the axis is there may be a big initial error and a jerk or fault. EnableAxis(XX); Reads the current Position and sets the Destination to that position to avoid this.
Regards,

Tom Kerekes
Dynomotion, Inc.

Post Reply