IOs status mismatch between hardware and software.

Moderators: TomKerekes, dynomotion

Post Reply
gui_marchioro
Posts: 59
Joined: Sun Aug 21, 2022 11:22 pm

IOs status mismatch between hardware and software.

Post by gui_marchioro » Tue Oct 18, 2022 1:54 am

Hi there,

I’m having some issues with Konnect boards. In the video linked below, it can be seen that the status of the inputs of board 0 is not matching between the board and the KMotion software. These problems are occurring sometimes when an output coil is turned off.

Does anyone have experienced this kind of problems?

Thanks in advance for the replies :)

[youtube]https://youtube.com/shorts/RMBniZf2-o0[/youtube]

User avatar
TomKerekes
Posts: 2604
Joined: Mon Dec 04, 2017 1:49 am

Re: IOs status mismatch between hardware and software.

Post by TomKerekes » Tue Oct 18, 2022 4:03 pm

Hi marchioro,

Are there any messages on the Console Screen?

If noise corrupts the signature data from any Konnect then KFLOP will stop servicing the Konnects and display an error message.

You might shorten the ribbon cable to the Konnects to be as short as possible and/or move other noisy signals away from it.

Do you coils have reverse diodes across them?

Is an isolated supply used for the coils?
Regards,

Tom Kerekes
Dynomotion, Inc.

gui_marchioro
Posts: 59
Joined: Sun Aug 21, 2022 11:22 pm

Re: IOs status mismatch between hardware and software.

Post by gui_marchioro » Sat Oct 22, 2022 10:08 pm

Hello Tom, thank you for the reply
Are there any messages on the Console Screen?
I did not remembered to check the console screen to see if there was any message at that moment.
Do you coils have reverse diodes across them?
Yes, there are diodes in parallel to each one of the coils.
Is an isolated supply used for the coils?
The same supply was being utilized for the boards and the coils.
The problem seems to be solved by adding a new supply only for the boards and some sensors in the machine.

gui_marchioro
Posts: 59
Joined: Sun Aug 21, 2022 11:22 pm

Re: IOs status mismatch between hardware and software.

Post by gui_marchioro » Mon Nov 14, 2022 1:45 pm

Hello,

I am still getting some problems related to this. It is not occurring deterministically, but the probability gets higher if more than 2 Konnect boards are being used.

This time I checked the KMotion console, which outputs that a comm signature error happened.

Is there any recommendation on how to solve this kind of problem?

Sincerely,
Guilherme

User avatar
TomKerekes
Posts: 2604
Joined: Mon Dec 04, 2017 1:49 am

Re: IOs status mismatch between hardware and software.

Post by TomKerekes » Mon Nov 14, 2022 8:37 pm

Hi Guilherme,

That would indicate noise being introduced into the KFLOP - Konnect cable. Are they as short as possible? Are they away from noisy signals? Do you have an oscilloscope to check for noise?

Or it could be noise on GND. Are your noise producing signals using a separate isolated ground?

You might read this.
Regards,

Tom Kerekes
Dynomotion, Inc.

gui_marchioro
Posts: 59
Joined: Sun Aug 21, 2022 11:22 pm

Re: IOs status mismatch between hardware and software.

Post by gui_marchioro » Mon Dec 05, 2022 10:59 am

Hello,

I have reduced the distance between Kflop and Konnect boards, and the problem does not happen anymore.

Thanks for helping me out.

Sincerely,
Guilherme

Post Reply