"Bad request" exception

Moderators: TomKerekes, dynomotion

Post Reply
togidor
Posts: 2
Joined: Mon Mar 15, 2021 1:48 pm

"Bad request" exception

Post by togidor » Mon Mar 15, 2021 2:46 pm

Hi,

I have a "KLOP" and a "KONNECT" connected to it via "JP6 #AUX1" . My program runs the c file whose content is as follows.

Code: Select all

#include "KMotionDef.h"
main()
{
	InitAux();
	AddKonnect(2,&VirtualBits,VirtualBitsEx);
}



And i am reading inputs succesfuly every 100 ms. But Kmotiondotnet.dll sometimes throws "Bad Request" exception during ".GetDigitalValue()".
I couldn't understand.I'm waiting for your help.

Thanks

User avatar
TomKerekes
Posts: 1515
Joined: Mon Dec 04, 2017 1:49 am

Re: "Bad request" exception

Post by TomKerekes » Mon Mar 15, 2021 3:49 pm

Hi Togidor,

I'm not aware of any such issue and I don't see a way GetDigitalValue() could throw such an exception.

Are you sure that is the error you are receiving? Bad Request is commonly associated with http server requests.

Can you send a small code fragment that demonstrates the problem?

What Version are you using?

What language is your App written in?

What else is your App doing?

Can you set breakpoints in GetDigitalValue() to see what is wrong?

Sorry for no simple answer.
Regards,

Tom Kerekes
Dynomotion, Inc.

togidor
Posts: 2
Joined: Mon Mar 15, 2021 1:48 pm

Re: "Bad request" exception

Post by togidor » Tue Mar 16, 2021 1:42 pm

Sorry. The error should have been "Bad return value", not "Bad request". I typed it wrong.
The problem was noises. Our cable was not suitable for high speed communication. Everything's ok.
Thanks for your time.

Post Reply