Search found 38 matches

by ZooBDoo
Tue Dec 10, 2019 9:31 pm
Forum: Configuration Issues
Topic: Config doesn't find all axes
Replies: 2
Views: 368

Config doesn't find all axes

I created an init C program that sets up three axes in Snap Amps with appropriate gains etc. Two brushless servos and one microstepper. All the axes operate when I run the init program but when I go to the config screen and do an "UPload All" it only finds 2 of the three axes. Is there a certain "la...
by ZooBDoo
Tue Dec 10, 2019 8:48 pm
Forum: Configuration Issues
Topic: axis resolution
Replies: 1
Views: 318

axis resolution

I'm a bit confused about the configuration page relating to axis resolution and velocity and how the C program motion, Step response, KCNC trajectory planner and jog speeds interplay. Are they consistent with each other?

AZ
by ZooBDoo
Wed Nov 27, 2019 8:31 pm
Forum: Configuration Issues
Topic: Snap Amp Channels
Replies: 2
Views: 453

Re: Snap Amp Channels

Thanks for the reply. I did read the wiki before but that's where some of the confusion happened because the connector and pin numbers and encoder channel numbers in that diagram didn't follow Snap Amp connections. For example, the Channels diagram shows the encoder channel inputs as JP7 and JP5 and...
by ZooBDoo
Mon Nov 25, 2019 5:21 am
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: Bigger Buttons?
Replies: 1
Views: 419

Bigger Buttons?

Have there been any posts of Kmotion CNC operator screens with bigger buttons and smaller G code display area? I have a lathe application so It's only 2 axes with a spindle. I have a laptop with high resolution display and the KCNC buttons are pretty small for an operator to use. I tried reducing th...
by ZooBDoo
Mon Nov 25, 2019 5:03 am
Forum: Noise, Grounding, Shielding Issues
Topic: Snap Amp Noise affecting USB connection
Replies: 18
Views: 1701

Snap Amp Noise affecting USB connection

Is the Snap Amp PWM on all the output channels synchronized. i.e. do all the PWM positive pulses on all the bridges activate at the same time? I realize that the pulse widths would be different for each bridge so they would turn off at different times. I'm having noise issues with a couple of brushl...
by ZooBDoo
Sun Nov 24, 2019 9:12 pm
Forum: Configuration Issues
Topic: Snap Amp Channels
Replies: 2
Views: 453

Snap Amp Channels

Hello, I'm a bit confused about the Snap Amp Channel configurations. Update: I figured this out with a little reasoning and testing. The tutorial chart on "Channels" doesn't seem to cover SnapAmp configurations unless I'm missing something. Looking at the SnapAmp output connector diagram Out #0 thru...
by ZooBDoo
Tue May 07, 2019 11:52 pm
Forum: Configuration Issues
Topic: microstepping resolution
Replies: 7
Views: 1808

Re: microstepping resolution

Thanks for the quick reply. In typical microstepping lingo it looks like the resolution for a 2.5 amp stepper motor would be 22428 microsteps per revolution. That's phenomenal! Even for a 1 amp motor it's 8971 ppr. How is the motor current set? Is this done with the amplitude setting? Is this settin...
by ZooBDoo
Tue May 07, 2019 8:11 pm
Forum: Configuration Issues
Topic: microstepping resolution
Replies: 7
Views: 1808

microstepping resolution

How do I calculate and set the microstepping resolution with a SnapAmp setup? i.e. steps per revolution on a 200 ppr full step motor? Also, is there a maximum theoretical speed ( control limit not motor limit) for microstepping? What is the control repeatability in microstepping between the motor po...