Search found 50 matches

by tmday7
Sat Jun 08, 2019 2:30 am
Forum: Configuration Issues
Topic: CSS on Lathe
Replies: 6
Views: 537

Re: CSS on Lathe

Hi Tom,
On a note unrelated to your problem I believe the KMotionCNC | Tool Setup | Trajectory Planner | Threading | Spindle axis is incorrectly set to 3 instead of 7.
So its not were i have the encoder connected to on the Kanalog board?

Troy
by tmday7
Fri Jun 07, 2019 10:24 pm
Forum: Configuration Issues
Topic: CSS on Lathe
Replies: 6
Views: 537

Re: CSS on Lathe

Hi Tom, Been trying to get this to work with no change in issue of spindle RPM not changing. So i opened the CSSjogs.c program and enabled the print out. Then did a compile to check it and i got a "CSSJog.c:22: 'persist' undeclared". I get the same persist undeclared when i disable the print out. I ...
by tmday7
Sun Jun 02, 2019 12:12 pm
Forum: Configuration Issues
Topic: CSS on Lathe
Replies: 6
Views: 537

Re: CSS on Lathe

I found one issue, in the MySpindleDefs header file. I had the wrong axis. Had 3 because i was thinking of the spindle encoder is connected to axis 3 inputs. :roll: I changed it to 7 which is the output for spindle, but nothing has changed, still does same thing i described in previous post.

Troy
by tmday7
Sat Jun 01, 2019 11:50 pm
Forum: Configuration Issues
Topic: CSS on Lathe
Replies: 6
Views: 537

CSS on Lathe

Hay Tom, So now iam opening a new can of worms on my lathe. :) And trying to configure for constant surface speed. I have looked at the example...https://dynomotion.com/Help/KMotionCNC/SpindleControl.htm. Altered and added the MySpindleDefs.h to directories DSP_KFLOP and DSP_Kmotion. Below is the al...
by tmday7
Sat Jun 01, 2019 1:23 am
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: Lathe Tool Z offset
Replies: 13
Views: 910

Re: Lathe Tool Z offset

Hi Tom, Well, did some trouble shooting threw the week with no results. So i just tried the good old sanity check and all seems to be working good now:) Step works correctly and so does the M6 pop up code. I think something may have got corrupted when i changed PCs at beginning of retrofit and copie...
by tmday7
Mon May 27, 2019 3:27 pm
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: Lathe Tool Z offset
Replies: 13
Views: 910

Re: Lathe Tool Z offset

Hi Tom, No worries about delay. :) Yes it is still an issue. Currently i have a work around. Iam replacing the M6 with a M0 and executing my M0 c code that does an MDI "M0". Obviously there is no pop up message but at least this way the Gcode will stop for a tool change. Tried your updated ccode and...
by tmday7
Fri May 24, 2019 11:28 pm
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: G83 Lathe
Replies: 1
Views: 244

G83 Lathe

Hello, I am trying to do run a simple spot drill G83 program on my lathe. For some reason iam getting a pop up window when trying to run gcode that states"Y value unspecified in xz plane canned cycle". I have ran this same program a few times a couple days ago with no problems but now it gives me po...
by tmday7
Mon May 20, 2019 8:56 pm
Forum: New Feature Request
Topic: Linux Support
Replies: 5
Views: 763

Re: Linux Support

.... Sorry we don't have the resources to also support Linux. How much would you be willing to pay for a Linux Version? .... Hi Tom, Just some feedback here....If Dynomotion was to make a Linux version, I for one, as an end user for my own machines, would be willing to pay the amount that a license...
by tmday7
Mon May 20, 2019 1:41 am
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: Lathe Tool Z offset
Replies: 13
Views: 910

Re: Lathe Tool Z offset

Hi Tom, Here is screenshots of my ToolSetUp. My main init code and ManualToolChange code. Note that i dont have CSS in my init yet as i have not figured it out yet. The reason for another CycleStart after clicking the OK button is so user does not have to go from keyboard or mouse to machine buttons...
by tmday7
Sun May 19, 2019 3:58 pm
Forum: KMotionCNC, G Code Files, Offsets, Post Process
Topic: Lathe Tool Z offset
Replies: 13
Views: 910

Re: Lathe Tool Z offset

Hi Tom, Using v4.34. M0 had no action set. Here is Gcode ... (1001) (1UPPERROLLERFACE_TURNOP2) N1 G18 N2 G90 N3 G20 (FACE1) N4 G53 G0 X0. N5 T1 M6 N6 G43 H1 M0 N7 G54 N9 G97S400 M4 N10 G94 N11 G90 G0 X5.175 Z0.35 G01X2F10. G0X5.175 G97 S500 M4 G01X2F10. G0X5.175 M05 G53X0Z0 M30 Something else i noti...