Search found 2610 matches

by TomKerekes
Tue Jul 23, 2024 4:47 pm
Forum: Hardware Interface Issues
Topic: Is it possible to use both KStep with SnapAmp
Replies: 10
Views: 167

Re: Is it possible to use both KStep with SnapAmp

Hi William, I assume you have a Halt Action defined to turn the Spindle off. Please post it with any included files. I think the issue might be the Resume | Start Spindle: Resume.png which performs an M3 which is expected to turn on and go to the last commanded speed. But then if the Halt Action res...
by TomKerekes
Mon Jul 22, 2024 7:31 pm
Forum: Configuration Issues
Topic: SETTING UP KFLOP, KANALOG FOR NEW CNC ROUTER RETROFIT
Replies: 290
Views: 18978

Re: SETTING UP KFLOP, KANALOG FOR NEW CNC ROUTER RETROFIT

Hi Noel, Actions to be associated with those buttons can be assigned in the Tool Setup. See here . However the Stop action is performed after disabling the Axes so a "Controlled Stop" would not be possible. The idea is that the Stop Button should only be used in an emergency where a controlled stop ...
by TomKerekes
Fri Jul 19, 2024 8:45 pm
Forum: Hardware Interface Issues
Topic: Is it possible to use both KStep with SnapAmp
Replies: 10
Views: 167

Re: Is it possible to use both KStep with SnapAmp

Hi William,

Are you pushing the Move button on the Step Response Screen?

Are the peak current settings in SnapAmp set?

Are the settings in the KMotion screens all the same as the Init Program? To be sure you might import them. What are the settings?
by TomKerekes
Thu Jul 18, 2024 4:52 pm
Forum: Hardware Interface Issues
Topic: Is it possible to use both KStep with SnapAmp
Replies: 10
Views: 167

Re: Is it possible to use both KStep with SnapAmp

Thank you Tom, that is good information to know. I will give this some more thought and decide what will work best for my setup. I'll let you know. btw another approach might be to use the closest motor pole as a type of, and instead of, the index mark. That would probably be as accurate as anythin...
by TomKerekes
Wed Jul 17, 2024 4:51 pm
Forum: Hardware Interface Issues
Topic: Is it possible to use both KStep with SnapAmp
Replies: 10
Views: 167

Re: Is it possible to use both KStep with SnapAmp

That is, I am only getting 50 steps/rev from my steppers instead of the 200steps/rev with the KStep board.Have I missed something? Is there a way to get back my original resolution with the SnapAmps? SnapAmp has very high resolution. Instead of a 16X uStepping resolution of KSTEP (200 x 16 = 3200 i...
by TomKerekes
Mon Jul 15, 2024 5:45 pm
Forum: Configuration Issues
Topic: SETTING UP KFLOP, KANALOG FOR NEW CNC ROUTER RETROFIT
Replies: 290
Views: 18978

Re: SETTING UP KFLOP, KANALOG FOR NEW CNC ROUTER RETROFIT

You might use a Virtual Bit as a flag to indicate the system has been homed. Virtual Bits are cleared on boot up. You could set the Bit after homing is completed. If the C Program below is assigned to the Cycle Start action it should immediately halt with a warning if Cycle Start is attempted before...
by TomKerekes
Thu Jul 11, 2024 5:21 pm
Forum: Tuning Servos
Topic: more spindle servo tuning questions
Replies: 15
Views: 182

Re: more spindle servo tuning questions

the trouble i think started right when i got the custom screen done. :? i think it was running great with the "basic 3 axis" screen The Screen having an effect on the Spindle Stability would be very strange. The obvious thing to do would be to switch back to to the basic screen. do you have any rec...
by TomKerekes
Wed Jul 10, 2024 5:24 pm
Forum: Hardware Interface Issues
Topic: The FPGA(STEP_PULSE_LENGTH_ADD) command is not having any effect.
Replies: 3
Views: 54

Re: The FPGA(STEP_PULSE_LENGTH_ADD) command is not having any effect.

Hi,

We can normally schedule within several days. We like to use TightVNC to connect to the system. Please download and install before any session. Have a good trip.
by TomKerekes
Wed Jul 10, 2024 5:12 am
Forum: Configuration Issues
Topic: IO number for 2nd KStep's Opto INs and Relays
Replies: 2
Views: 41

Re: IO number for 2nd KStep's Opto INs and Relays

The extra IO on the 2nd KStep are not useable. Only the motor driver outputs are available.
by TomKerekes
Wed Jul 10, 2024 5:09 am
Forum: Hardware Interface Issues
Topic: KStep J1 Motor Power
Replies: 2
Views: 27

Re: KStep J1 Motor Power

Power Supply current is not the same as motor currents. You might read this.

But yes it is best to wire the supply to both terminals to reduce the current through each terminal.

The supply switched to the motors will still be the supply voltage. 24V in your case.