Search found 78 matches

by RogerFroud
Sun Sep 12, 2021 7:00 am
Forum: Custom Screens, KMotionCNC Screen Editor
Topic: Setting button text
Replies: 8
Views: 176

Re: Setting button text

I've had several times when I've edited the screen, only to find that some things that were hidden became visible again. However, exiting, going back into the editor and exiting again seems to set it right again. I think some of those were the Step distance radio buttons, but I think there were othe...
by RogerFroud
Fri Aug 20, 2021 9:25 pm
Forum: Configuration Issues
Topic: Using the KMotion MoveRel command
Replies: 4
Views: 69

Re: Using the KMotion MoveRel command

Ah, I didn't know that was there, I've not used that before.

Yes, that seems to work now. Thanks, that's very useful.
by RogerFroud
Fri Aug 20, 2021 8:10 pm
Forum: Configuration Issues
Topic: Using the KMotion MoveRel command
Replies: 4
Views: 69

Re: Using the KMotion MoveRel command

No, I didn't look at the graph, I just looked at the position count on the AC Servo, and it didn't receive any pulses. I'll try it with a larger move.
by RogerFroud
Fri Aug 20, 2021 8:07 pm
Forum: Configuration Issues
Topic: Axis tuning
Replies: 16
Views: 306

Re: Axis tuning

Ok, thanks for that, I can start with that. I can see that you have to apply any modifiers progressively else it will certainly be unstable. It just seemed to me that there is always lost motion, however small, and that's predictable. If it's predictable, I thought that a position offset could be in...
by RogerFroud
Fri Aug 20, 2021 2:59 pm
Forum: Configuration Issues
Topic: Using the KMotion MoveRel command
Replies: 4
Views: 69

Using the KMotion MoveRel command

I'm using KMotion and the Step Response functions for tuning, but I need to be able to move the machine a specified amount in a specific direction. I can see that there's a MoveRel0=10.0 type of command I should be able to use from the Console, but this doesn't seem to move the axis even though it's...
by RogerFroud
Thu Aug 19, 2021 12:09 pm
Forum: Configuration Issues
Topic: Axis tuning
Replies: 16
Views: 306

Re: Axis tuning

I'm just starting to look into this with a view to effectively implementing something very much like this. However, the code you've provided doesn't show how the final position is being modified by the backlash value. Could you share the code that shows that? I'll need to keep the final position tha...
by RogerFroud
Wed Aug 18, 2021 9:50 am
Forum: Hardware Interface Issues
Topic: Damaged KFLOP
Replies: 7
Views: 168

Re: Damaged KFLOP

I've finally found the reason for the damage to the KLOP, there was a tiny streak of solder on one of the connectors to the differential drivers. Unfortunately, this happened to be a +24v connection to one of the Opto Isolators used for the output that controls the DC Brake. I can't try it fully con...
by RogerFroud
Mon Aug 16, 2021 7:18 pm
Forum: Hardware Interface Issues
Topic: Damaged KFLOP
Replies: 7
Views: 168

Re: Damaged KFLOP

Many thanks for that, I've found a bad joint on one of the data lines to the FTDI chip, so it now communicates correctly with KMOTION. All that remains is to hook it all back up to the KANALOG board and see if it now functions as a complete system. Before doing that, I'll bus out each pin on the FPG...
by RogerFroud
Mon Aug 16, 2021 1:03 pm
Forum: Hardware Interface Issues
Topic: Damaged KFLOP
Replies: 7
Views: 168

Re: Damaged KFLOP

I've finally got the right FTDI chip fitted and programmed, it now shows up in the Device Manager as shown in the attached picture. I've right clicked on that and pointed it to the USB driver, and it tells me that the best driver is already installed. That USB port works fine with the new board I've...
by RogerFroud
Sat Jul 24, 2021 11:34 am
Forum: Hardware Interface Issues
Topic: Damaged KFLOP
Replies: 7
Views: 168

Re: Damaged KFLOP

I've replaced the 3V3 regulator and the FPGA, and it now powers up with the two LEDs blinking before they end up permanently on. Does that sound right? Initially I had the current limit on the power supply too low, and it kept tripping out without getting going. So this looks more promising now. I t...