KMotion_dotNet Namespace

Primary Namespace for all Dynomotion .net objects Manipulate IO, Command single axis movement, issue coordinated motion profiles and interpret RS274(G-code) The Dynomotion devices are truly amazing and versatile
Classes
 | Class | Description
Public class | DM_Compiler_Exception | Special Dynomotion Compiler Error Exception
Public class | DM_Disconnected_Exception | Special Dynomotion Board Disconnected Exception
Public class | DM_Firmware_Exception | Special Dynomotion KmotionServer Error Exception
Public class | DM_USB_Exception | Special Dynomotion USB Error Exception
Public class | DMException | Exception class for handling specific DynoMotion.net exceptions
Public class | HexEncoding | Helper class for working with hex-binary stack objects
Public class | KM_Axis | Axis class for KM_Controller Use to control a single axis channel The axis channel can be configured via a c program and the KM_Controller or Use the configuration methods to set the desired parameters
Public class | KM_AxisKM_Axis_HomingParams | Multiple parameters to describe the homing sequence for the axis so that a proper sequence can be auto-generated in some circumstances. (This has not been fully implemented)
Public class | KM_AxisKM_Axis_TuningParams | KFLOP Axis Channel parameters for Tuning and motion profiles
Public class | KM_AxisGroup | KM_Controller Object for grouping Axis channels
Public class | KM_Controller | This is the primary object for interfacing with a Dynomotion product in code You can think of this object as representing the board and an access point for features of the hardware There should only be one KM_Controller object per board, per application domain at any given time To set project to update the GAC: "$(FrameworkSdkDir)\bin\gacutil.exe" /i "$(TargetPath)" /f
Public class | KM_CoordMotion | Coordinated Motion class representing the CoordMotion.cpp object from the C++ Dynotion Code Use to directly control multiple axis motion Notably:: Straight Traverse Straight Feed Arc Feed
Public class | KM_Interpreter | Interpreter class representing the GCodeInterpreter.cpp object from the C++ Dynotion Code Use to control multiple axis motion from the NIST RS274 Interpreter
Public class | KM_InterpreterKM_Interpreter_SetupParams | Direct settings access for the EMC internal settings Warning, use at own risk Make sure to examine the Interpreter.cpp and related files to ensure you are aware of the reprecutions when using these parameters
Public class | KM_IO | IO class for KM_Controller Use to control a single point(bit) of IO Currently supported IO: Digital Input, Digital Output
Public class | KM_MotionParams | Trajectory Planner Motion Parameter Settings
Public class | StatusConsts | Defines form PC-DSP.h defining number of available devices
Structures
 | Structure | Description
Public structure | KM_MainStatus | Bulk status record uploaded from KFLOP
Public structure | KM_MainStatusRaw | This structure matches exactly the binary form as the Kogna/KFLOP MAIN_STATUS Structure so it can be uploaded as a binary image.
Delegates
 | Delegate | Description
Public delegate | KM_CoordMotionArcFeedHandler | Delegate reperesenting the KM_dotNet_Interop netARC_FEED_CALLBACK Function Pointer
Public delegate | KM_CoordMotionArcFeedSixAxisHandler | Delegate reperesenting the KM_dotNet_Interop netARC_FEED_CALLBACK Function Pointer
Public delegate | KM_CoordMotionStraightFeedHandler | Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_FEED_CALLBACK Function Pointer
Public delegate | KM_CoordMotionStraightFeedSixAxisHandler | Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_FEED_SIX_AXIS_CALLBACK Function Pointer
Public delegate | KM_CoordMotionStraightTraverseHandler | Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_TRAVERSE_CALLBACK Function Pointer
Public delegate | KM_CoordMotionStraightTraverseSixAxisHandler | Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_TRAVERSE_SIX_AXIS_CALLBACK Function Pointer
Public delegate | KM_InterpreterKM_GCodeInterpreterCompleteHandler | Delegate reperesenting the KM_dotNet_Interop netG_COMPLETE_CALLBACK Function Pointer
Public delegate | KM_InterpreterKM_GCodeInterpreterStatusHandler | Delegate reperesenting the KM_dotNet_Interop netG_STATUS_CALLBACK Function Pointer
Public delegate | KM_InterpreterKM_GCodeInterpreterUserCallbackHandler | Delegate reperesenting the KM_dotNet_Interop netG_USER_CALLBACK Function Pointer
Public delegate | KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler | Delegate reperesenting the KM_dotNet_Interop netG_USER_MCODE_CALLBACK Function Pointer
Public delegate | KMConsoleHandler | Callback delegate for KM_Controller returns
Public delegate | KMErrorHandler | callback for low level KMotion error messages
Public delegate | TraverseCompletedHandler | Delegate that gets fired off on an async Straight Traverse return call
Enumerations
 | Enumeration | Description
Public enumeration | BOARD_TYPE | Type of Board Currently KFLOP or Kogna Remarks Used where the Controllers Capabilities differ
Public enumeration | CANON_AXIS | Canon Axis
Public enumeration | CANON_DIRECTION | Spindle Direction
Public enumeration | CANON_FEED_REFERENCE | Feed reference Remarks The meaning of feed rate changes depending on the feed reference mode
Public enumeration | CANON_MOTION_MODE | Motion profile for contouring
Public enumeration | CANON_PLANE | Represents the axis pair for executing arc segments Remarks This enum can be parsed to the NIST enums
Public enumeration | CANON_SIDE | Canon Comp Side Remarks Defines the tool offset direction
Public enumeration | CANON_SPEED_FEED_MODE | Feed synchronization mode
Public enumeration | CANON_UNITS | Units used by the g code file Remarks The RS274 interpreter will translate these to inches relative to the CPI parameters in struct MotionParam
Public enumeration | DISTANCE_MODE | Distance Mode Remarks Defines how coordinates are interpreted
Public enumeration | HOMING_DIRECTION | direction factor for homing
Public enumeration | HOMING_ROUTINE_SOURCE_TYPE | Method to be used for creating a home sequence
Public enumeration | HOMING_STATE | enum for homing state
Public enumeration | HOMING_TYPE | enum for homing types
Public enumeration | IO_TYPE | IO Types Remarks Defines the direction of IO Currently only digital inputs and digital outputs are supported
Public enumeration | KMOTION_CHECK_READY | KMotion CheckReady Return Codes
Public enumeration | KMOTION_TOKEN | KMotionLocked Return Codes
Public enumeration | MCODE_TYPE | Possible M Code Action Types
Public enumeration | PREV_STOP_TYPE | Possible Previously Stopping Types after an Interpreter Halt
Public enumeration | RETRACT_MODE | Retract Mode Remarks Used for canned cycles


BOARD_TYPE Enumeration

Type of Board Currently KFLOP or Kogna
Remarks
Used where the Controllers Capabilities differ

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum BOARD_TYPE
Public Enumeration BOARD_TYPE
public enum class BOARD_TYPE
Members
Member name | Value | Description
KFLOP | 2 | Controller is KFLOP
KOGNA | 3 | Controller is Kogna
UNKNOWN | -1 | Board type not yet determined
See Also

Reference

KMotion_dotNet Namespace


CANON_AXIS Enumeration

Canon Axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_AXIS
Public Enumeration CANON_AXIS
public enum class CANON_AXIS
Members
Member name | Value | Description
CANON_AXIS_X | 1 | X Axis Remarks Traverse Axis
CANON_AXIS_Y | 2 | Y Axis Remarks Transverse Axis
CANON_AXIS_Z | 3 | Z Axis Remarks Depth Axis
CANON_AXIS_A | 4 | A Axis Remarks Rotary Axis Rotation is paralell to the X Axis
CANON_AXIS_B | 5 | B Axis Remarks Rotary Axis Rotation is paralell to the Y Axis
CANON_AXIS_C | 6 | C Axis Remarks Rotary Axis Rotation is paralell to the Z Axis
See Also

Reference

KMotion_dotNet Namespace


CANON_DIRECTION Enumeration

Spindle Direction

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_DIRECTION
Public Enumeration CANON_DIRECTION
public enum class CANON_DIRECTION
Members
Member name | Value | Description
CANON_STOPPED | 1 | Stopped Remarks This is the state for the spindle when not spinning
CANON_CLOCKWISE | 2 | Clockwise Remarks This is the state for the spindle when spinning Clockwise The rotation is relative from the tool's view
CANON_COUNTERCLOCKWISE | 3 | CounterClockwise Remarks This is the state for the spindle when spinning CounterClockwise The rotation is relative from the tool's view
See Also

Reference

KMotion_dotNet Namespace


CANON_FEED_REFERENCE Enumeration

Feed reference
Remarks
The meaning of feed rate changes depending on the feed reference mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_FEED_REFERENCE
Public Enumeration CANON_FEED_REFERENCE
public enum class CANON_FEED_REFERENCE
Members
Member name | Value | Description
CANON_WORKPIECE | 1 | Workpiece Relative Remarks Feed rate is from the point of view of the workpiece
CANON_XYZ | 2 | XYZ Relative Remarks Feedrate is in terms of axis motion Some (perhaps most or all) existing dialects of RS274 use only the CANON_XYZ mode
See Also

Reference

KMotion_dotNet Namespace


CANON_MOTION_MODE Enumeration

Motion profile for contouring

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_MOTION_MODE
Public Enumeration CANON_MOTION_MODE
public enum class CANON_MOTION_MODE
Members
Member name | Value | Description
CANON_EXACT_STOP | 1 | Exact Stop Remarks Will perform accel/slew/decel on each segment Most accurate type of motion
CANON_EXACT_PATH | 2 | Exact Path Remarks Creates an optimized path limited by vector accels and velocities
CANON_CONTINUOUS | 3 | Continuous Contouring Remarks Maintains a constant velocity over a series of path segments This is not an accurate machining profile, but useful for fast, smooth motion
See Also

Reference

KMotion_dotNet Namespace


CANON_PLANE Enumeration

Represents the axis pair for executing arc segments
Remarks
This enum can be parsed to the NIST enums

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_PLANE
Public Enumeration CANON_PLANE
public enum class CANON_PLANE
Members
Member name | Value | Description
CANON_PLANE_XY | 1 | Constrains an arc to be executed via X-Y interpolation
CANON_PLANE_YZ | 2 | Constrains an arc to be executed via Y-Z interpolation
CANON_PLANE_XZ | 3 | Constrains an arc to be executed via X-Z interpolation
See Also

Reference

KMotion_dotNet Namespace


CANON_SIDE Enumeration

Canon Comp Side
Remarks
Defines the tool offset direction

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_SIDE
Public Enumeration CANON_SIDE
public enum class CANON_SIDE
Members
Member name | Value | Description
CANON_SIDE_OFF | 0 | No Comp
CANON_SIDE_RIGHT | 1 | Right Comp
CANON_SIDE_LEFT | 2 | Left Comp
See Also

Reference

KMotion_dotNet Namespace


CANON_SPEED_FEED_MODE Enumeration

Feed synchronization mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_SPEED_FEED_MODE
Public Enumeration CANON_SPEED_FEED_MODE
public enum class CANON_SPEED_FEED_MODE
Members
Member name | Value | Description
CANON_SYNCHED | 1 | Synchronized Remarks slaves an axis with a spindle encoder
CANON_INDEPENDENT | 2 | Independent Feed Remarks Motion is commanded without regard to external signals
See Also

Reference

KMotion_dotNet Namespace


CANON_UNITS Enumeration

Units used by the g code file
Remarks
The RS274 interpreter will translate these to inches relative to the CPI parameters in struct MotionParam

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum CANON_UNITS
Public Enumeration CANON_UNITS
public enum class CANON_UNITS
Members
Member name | Value | Description
CANON_UNITS_INCHES | 1 | Inches 1:1
CANON_UNITS_MM | 2 | Milimeters 25.4:1
CANON_UNITS_CM | 3 | Centimeters 2.54:1
See Also

Reference

KMotion_dotNet Namespace


DISTANCE_MODE Enumeration

Distance Mode
Remarks
Defines how coordinates are interpreted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum DISTANCE_MODE
Public Enumeration DISTANCE_MODE
public enum class DISTANCE_MODE
Members
Member name | Value | Description
MODE_ABSOLUTE | 0 | Absolute Remarks Coordinate values are absolute to the machine datum
MODE_INCREMENTAL | 1 | Incremental Remarks Coordinate values are deltas from previous positions
See Also

Reference

KMotion_dotNet Namespace


DM_Compiler_Exception Class

Special Dynomotion Compiler Error Exception
Inheritance Hierarchy
SystemObject
SystemException
KMotion_dotNetDM_Compiler_Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class DM_Compiler_Exception : Exception
Public Class DM_Compiler_Exception
    Inherits Exception
public ref class DM_Compiler_Exception : public Exception

The DM_Compiler_Exception type exposes the following members.

Constructors
 | Name | Description
Public method | DM_Compiler_Exception | Special Dynomotion Compiler Error Exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

KMotion_dotNet Namespace


DM_Compiler_Exception Constructor

Special Dynomotion Compiler Error Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DM_Compiler_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
DM_Compiler_Exception(
    String^ message
)

Parameters

message String
Exception description
See Also

Reference

DM_Compiler_Exception Class


DM_Compiler_Exception Properties

The DM_Compiler_Exception type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Compiler_Exception Class


DM_Compiler_Exception Methods

The DM_Compiler_Exception type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Compiler_Exception Class


DM_Compiler_Exception Events

The DM_Compiler_Exception type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DM_Compiler_Exception Class


DM_Disconnected_Exception Class

Special Dynomotion Board Disconnected Exception
Inheritance Hierarchy
SystemObject
SystemException
KMotion_dotNetDM_Disconnected_Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class DM_Disconnected_Exception : Exception
Public Class DM_Disconnected_Exception
    Inherits Exception
public ref class DM_Disconnected_Exception : public Exception

The DM_Disconnected_Exception type exposes the following members.

Constructors
 | Name | Description
Public method | DM_Disconnected_Exception | Special Dynomotion Board Disconnected Exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

KMotion_dotNet Namespace


DM_Disconnected_Exception Constructor

Special Dynomotion Board Disconnected Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DM_Disconnected_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
DM_Disconnected_Exception(
    String^ message
)

Parameters

message String
Exception description
See Also

Reference

DM_Disconnected_Exception Class


DM_Disconnected_Exception Properties

The DM_Disconnected_Exception type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Disconnected_Exception Class


DM_Disconnected_Exception Methods

The DM_Disconnected_Exception type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Disconnected_Exception Class


DM_Disconnected_Exception Events

The DM_Disconnected_Exception type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DM_Disconnected_Exception Class


DM_Firmware_Exception Class

Special Dynomotion KmotionServer Error Exception
Inheritance Hierarchy
SystemObject
SystemException
KMotion_dotNetDM_Firmware_Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class DM_Firmware_Exception : Exception
Public Class DM_Firmware_Exception
    Inherits Exception
public ref class DM_Firmware_Exception : public Exception

The DM_Firmware_Exception type exposes the following members.

Constructors
 | Name | Description
Public method | DM_Firmware_Exception | Special Dynomotion KmotionServer Error Exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

KMotion_dotNet Namespace


DM_Firmware_Exception Constructor

Special Dynomotion KmotionServer Error Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DM_Firmware_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
DM_Firmware_Exception(
    String^ message
)

Parameters

message String
Exception description
See Also

Reference

DM_Firmware_Exception Class


DM_Firmware_Exception Properties

The DM_Firmware_Exception type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Firmware_Exception Class


DM_Firmware_Exception Methods

The DM_Firmware_Exception type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_Firmware_Exception Class


DM_Firmware_Exception Events

The DM_Firmware_Exception type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DM_Firmware_Exception Class


DM_USB_Exception Class

Special Dynomotion USB Error Exception
Inheritance Hierarchy
SystemObject
SystemException
KMotion_dotNetDM_USB_Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class DM_USB_Exception : Exception
Public Class DM_USB_Exception
    Inherits Exception
public ref class DM_USB_Exception : public Exception

The DM_USB_Exception type exposes the following members.

Constructors
 | Name | Description
Public method | DM_USB_Exception | Special Dynomotion USB Error Exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

KMotion_dotNet Namespace


DM_USB_Exception Constructor

Special Dynomotion USB Error Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DM_USB_Exception(
    string message
)
Public Sub New (
    message As String
)
public:
DM_USB_Exception(
    String^ message
)

Parameters

message String
Exception description
See Also

Reference

DM_USB_Exception Class


DM_USB_Exception Properties

The DM_USB_Exception type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_USB_Exception Class


DM_USB_Exception Methods

The DM_USB_Exception type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DM_USB_Exception Class


DM_USB_Exception Events

The DM_USB_Exception type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DM_USB_Exception Class


DMException Class

Exception class for handling specific DynoMotion.net exceptions
Inheritance Hierarchy
SystemObject
SystemException
KMotion_dotNetDMException

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class DMException : Exception
Public Class DMException
    Inherits Exception
public ref class DMException : public Exception

The DMException type exposes the following members.

Constructors
 | Name | Description
Public method | DMException | Primary constructor for DM Exception
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Actual exception thrown
Public property | Message | Additional information about exception (Overrides ExceptionMessage)
Public property | Sender | Object where execution of exception was encountered
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

KMotion_dotNet Namespace


DMException Constructor

Primary constructor for DM Exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DMException(
    Object sender,
    Exception ex,
    string message
)
Public Sub New (
    sender As Object,
    ex As Exception,
    message As String
)
public:
DMException(
    Object^ sender,
    Exception^ ex,
    String^ message
)

Parameters

sender Object
Current execution object on the stack
ex Exception
original exception encountered
message String
additional information
See Also

Reference

DMException Class


DMException Properties

The DMException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Actual exception thrown
Public property | Message | Additional information about exception (Overrides ExceptionMessage)
Public property | Sender | Object where execution of exception was encountered
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DMException Class


DMException.InnerException Property

KMotion_dotNet Documentation

DMExceptionInnerException Property

Actual exception thrown

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public Exception InnerException { get; }
Public ReadOnly Property InnerException As Exception
    Get
public:
property Exception^ InnerException {
    Exception^ get ();
}

Property Value

Exception
See Also

Reference

DMException Class


DMException.Message Property

DMExceptionMessage Property

Additional information about exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}

Property Value

String

Implements

_ExceptionMessage
See Also

Reference

DMException Class


DMException.Sender Property

DMExceptionSender Property

Object where execution of exception was encountered

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public Object Sender { get; }
Public ReadOnly Property Sender As Object
    Get
public:
property Object^ Sender {
    Object^ get ();
}

Property Value

Object
See Also

Reference

DMException Class


DMException Methods

The DMException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DMException Class


DMException Events

The DMException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DMException Class


HexEncoding Class

Helper class for working with hex-binary stack objects
Inheritance Hierarchy
SystemObject
KMotion_dotNetHexEncoding

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class HexEncoding
Public Class HexEncoding
public ref class HexEncoding

The HexEncoding type exposes the following members.

Constructors
 | Name | Description
Public method | HexEncoding | Default constructor for HexEncoding
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetByteCount | Counts the byte length of a Hex value
 | GetBytes | Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | InHexFormat | Determines if given string is in proper hexadecimal string format
 | IsHexDigit | Returns true is c is a hexadecimal digit (A-F, a-f, 0-9)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ToString(Byte) | Converts an array of bytes to a hexidecimal value represented by a string
Top
See Also

Reference

KMotion_dotNet Namespace


HexEncoding Constructor

Default constructor for HexEncoding

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public HexEncoding()
Public Sub New
public:
HexEncoding()
See Also

Reference

HexEncoding Class


HexEncoding Methods

The HexEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetByteCount | Counts the byte length of a Hex value
 | GetBytes | Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | InHexFormat | Determines if given string is in proper hexadecimal string format
 | IsHexDigit | Returns true is c is a hexadecimal digit (A-F, a-f, 0-9)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ToString(Byte) | Converts an array of bytes to a hexidecimal value represented by a string
Top
See Also

Reference

HexEncoding Class


HexEncoding.GetByteCount Method

HexEncodingGetByteCount Method

Counts the byte length of a Hex value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public static int GetByteCount(
    string hexString
)
Public Shared Function GetByteCount (
    hexString As String
) As Integer
public:
static int GetByteCount(
    String^ hexString
)

Parameters

hexString String
Hex number in string format

Return Value

Int32
The length in bytes
See Also

Reference

HexEncoding Class


HexEncoding.GetBytes Method

HexEncodingGetBytes Method

Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public static byte[] GetBytes(
    string hexString,
    out int discarded
)
Public Shared Function GetBytes (
    hexString As String,
    <OutAttribute> ByRef discarded As Integer
) As Byte()
public:
static array<unsigned char>^ GetBytes(
    String^ hexString,
    [OutAttribute] int% discarded
)

Parameters

hexString String
string to convert to byte array
discarded Int32
number of characters in string ignored

Return Value

Byte
byte array, in the same left-to-right order as the hexString
See Also

Reference

HexEncoding Class


HexEncoding.InHexFormat Method

HexEncodingInHexFormat Method

Determines if given string is in proper hexadecimal string format

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public static bool InHexFormat(
    string hexString
)
Public Shared Function InHexFormat (
    hexString As String
) As Boolean
public:
static bool InHexFormat(
    String^ hexString
)

Parameters

hexString String
the hexidecimal string

Return Value

Boolean
true if in proper format
See Also

Reference

HexEncoding Class


HexEncoding.IsHexDigit Method

HexEncodingIsHexDigit Method

Returns true is c is a hexadecimal digit (A-F, a-f, 0-9)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public static bool IsHexDigit(
    char c
)
Public Shared Function IsHexDigit (
    c As Char
) As Boolean
public:
static bool IsHexDigit(
    wchar_t c
)

Parameters

c Char
Character to test

Return Value

Boolean
true if hex digit, false if not
See Also

Reference

HexEncoding Class


HexEncoding.ToString Method

HexEncodingToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string that represents the current object.
 | ToString(Byte) | Converts an array of bytes to a hexidecimal value represented by a string
Top
See Also

Reference

HexEncoding Class


HexEncoding.ToString(Byte[]) Method

HexEncodingToString(Byte) Method

Converts an array of bytes to a hexidecimal value represented by a string

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public static string ToString(
    byte[] bytes
)
Public Shared Function ToString (
    bytes As Byte()
) As String
public:
static String^ ToString(
    array<unsigned char>^ bytes
)

Parameters

bytes Byte
byte array

Return Value

String
string representing the hexidecimal value from a byte array
See Also

Reference

HexEncoding Class
ToString Overload


HOMING_DIRECTION Enumeration

direction factor for homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum HOMING_DIRECTION
Public Enumeration HOMING_DIRECTION
public enum class HOMING_DIRECTION
Members
Member name | Value | Description
POSITIVE | 1 | move in positive(rising) direction
NEGATIVE | -1 | move in negative(falling) direction
See Also

Reference

KMotion_dotNet Namespace


HOMING_ROUTINE_SOURCE_TYPE Enumeration

Method to be used for creating a home sequence

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum HOMING_ROUTINE_SOURCE_TYPE
Public Enumeration HOMING_ROUTINE_SOURCE_TYPE
public enum class HOMING_ROUTINE_SOURCE_TYPE
Members
Member name | Value | Description
FROM_FILE | 0 | Runs homing sequence from a pre-existing file
FROM_STRING | 1 | Creates a file from the Homing_c_Program contents
FROM_THREAD | 2 | Simply executes a thread
AUTO | 3 | Generates a .c file based on the Homing Params
See Also

Reference

KMotion_dotNet Namespace


HOMING_STATE Enumeration

enum for homing state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum HOMING_STATE
Public Enumeration HOMING_STATE
public enum class HOMING_STATE
Members
Member name | Value | Description
NOT_HOMED | 0 | initial state
ON_SENSOR | 1 | indicates the sensor bit has been set to the requested state
MOVING_TO_SENSOR | 2 | axis is moving towards the sensor bit
MOVING_FROM_SENSOR | 3 | axis is moving away from the sensor bit
MOVING_TO_FINAL | 4 | axis is moving to the final position
COMPLETE | 5 | homing sequence has been completed
ERROR | 6 | an error occured during the homing routine
See Also

Reference

KMotion_dotNet Namespace


HOMING_TYPE Enumeration

enum for homing types

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum HOMING_TYPE
Public Enumeration HOMING_TYPE
public enum class HOMING_TYPE
Members
Member name | Value | Description
HOME_TO_LIMIT_THEN_ROLL_OFF | 0 | Simply home to switch and roll back off
HOME_TO_LIMIT_THEN_MOVE_TO_POSITION | 1 | Perform the roll off sensor and then move to a set position
See Also

Reference

KMotion_dotNet Namespace


IO_TYPE Enumeration

IO Types
Remarks
Defines the direction of IO

Currently only digital inputs and digital outputs are supported

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum IO_TYPE
Public Enumeration IO_TYPE
public enum class IO_TYPE
Members
Member name | Value | Description
UNDEFINED | 0 | Undefined Remarks Default value of uninitialized IO
DIGITAL_IN | 1 | Digital Input
DIGITAL_OUT | 2 | Digital Output
ANALOG_IN | 3 | Analog Input
ANALOG_OUT | 4 | Analog Output
See Also

Reference

KMotion_dotNet Namespace


KM_Axis Class

Axis class for KM_Controller Use to control a single axis channel The axis channel can be configured via a c program and the KM_Controller or Use the configuration methods to set the desired parameters
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_Axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Axis
Public Class KM_Axis
public ref class KM_Axis

The KM_Axis type exposes the following members.

Constructors
 | Name | Description
Public method | KM_Axis | Default constructor for the Axis Object
Top
Properties
 | Name | Description
Public property | Acceleration | Acceleration to use during Rapids and Independent Motion
Public property | CoordAccel | Max Acceleration to to use during Coordinated Motion Feeds
Public property | CoordVelocity | Max Commanded velocity to use during Coordinated Motion Feeds
Public property | CPU | Counts per unit, must set before Velocity, Acceleration, and Jerk
Public property | CPU_is_mm | Indicates if CPU (Counts/unit) is mm otherwise inches
Public property | HomingParams | Data memeber for thr homing sequence attributes
Public property | ID | Axis Channel Number Valid range = ( 0 - 7 )
Public property | Jerk | Jerk to to use during Rapids and Independent Motion
Public property | JogPercent | The level of jog percenatage computed from the commanded jog velocity
Public property | JogVelocity | Commanded jog velocity
Public property | Name | Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...
Public property | TuningParams | Accessor to the axis channel's tuning parameters
Public property | Velocity | Commanded velocity to use during Rapids and Independent Motion
Top
Methods
 | Name | Description
Public method | CheckEnabled | Check if the axis is enabled
Public method | Disable | Disable the axis
Public method | DoHome | Executes a homing sequence based on the settings within the HomingParams variable and waits until the execution is complete
Public method | Enable | Bring an axis to an enabled state
Public method | EnableDest | Bring an axis to an enabled state and specify the commanded destination for the axis dest is multiplied by CPU and sent to KFLOP
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EStop | Stop the current motion and disable the axis
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetActualPosition | Querys the axis channel for the actual position in user units
Public method | GetActualPositionCounts | Querys the axis channel for the actual position in counts
Public method | GetCommandedPosition | Querys the axis channel for the commanded position in user units
Public method | GetCommandedPositionCounts | Querys the axis channel for the commanded position in counts
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHomeFileSource | Creates the source code for the .c file with an empty main() method
Public method | GetHomeSequence | Creates the lines of code to place in the main() method
Public method | GetMoveToStateAtVel | Auto Generates KFLOP C Code to move until an input bit changes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Jog | Jog axis at the commanded preset jogvelocity * jogpercentage
Public method | Jog(Double) | Jog axis at a given velocity
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MotionComplete | Checks if the commanded axis motion is completed
Public method | MoveTo | Calls a move to a given absolute position and blocks the calling thread until the position has been acheived
Public method | RelativeMoveTo | Calls a move to a given relative position and blocks the calling thread until the position has been acheived
Public method | SetCommandedDest | Sets the axis node's commanded Destination Caution: changing this may result in a sudden jump in the axis position
Public method | SetCurrentPosition | Sets the axis node's current position Can be used to "zero" the axis
Public method | StartDoHome | Executes a homing sequence based on the settings within the HomingParams variable
Public method | StartMoveTo | Calls a non-blocking move to a given absolute position
Public method | StartRelativeMoveTo | Calls a non-blocking move to a given relative position
Public method | Stop | Stop the current motion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitforMotionComplete | Blocks the calling thread until the axis is in position within a specified time limit
Public method | ZeroAxis | Sets the Axis' current 0.0 point
Top
Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _CoordAccel | Acceleration to use during Coordinated Motion using Trajectory Planner
Protected field | _CoordVelocity | Velocity to use during Coordinated Motion using Trajectory Planner
Protected field | _CPU | Multiplier for the velocity in counts/unit
Protected field | _CPU_is_mm | The level of jog percenatage computed from the commanded jog velocity
Protected field | _HomingParams | Data memeber for thr homing sequence attributes
Protected field | _ID | Axis Channel Number Valid range = ( 0 - 7 )
Protected field | _JogPercent | The level of jog percenatage computed from the commanded jog velocity
Protected field | _JogVelocity | Commanded jog velocity
Protected field | _Name | Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...
Protected field | _TuningParams | Accessor to the axis channel's tuning parameters
Protected field | _Velocity | Velocity to use during positioning Jogging uses its own velocity passed in
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Axis Constructor

Default constructor for the Axis Object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Axis(
    KM_Controller controller,
    int id,
    string name
)
Public Sub New (
    controller As KM_Controller,
    id As Integer,
    name As String
)
public:
KM_Axis(
    KM_Controller^ controller,
    int id,
    String^ name
)

Parameters

controller KM_Controller
KM_Controller object to associate the axis
id Int32
identifier
name String
friendly name
See Also

Reference

KM_Axis Class


KM_Axis Properties

The KM_Axis type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Acceleration to use during Rapids and Independent Motion
Public property | CoordAccel | Max Acceleration to to use during Coordinated Motion Feeds
Public property | CoordVelocity | Max Commanded velocity to use during Coordinated Motion Feeds
Public property | CPU | Counts per unit, must set before Velocity, Acceleration, and Jerk
Public property | CPU_is_mm | Indicates if CPU (Counts/unit) is mm otherwise inches
Public property | HomingParams | Data memeber for thr homing sequence attributes
Public property | ID | Axis Channel Number Valid range = ( 0 - 7 )
Public property | Jerk | Jerk to to use during Rapids and Independent Motion
Public property | JogPercent | The level of jog percenatage computed from the commanded jog velocity
Public property | JogVelocity | Commanded jog velocity
Public property | Name | Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...
Public property | TuningParams | Accessor to the axis channel's tuning parameters
Public property | Velocity | Commanded velocity to use during Rapids and Independent Motion
Top
See Also

Reference

KM_Axis Class


KM_Axis.Acceleration Property

KM_AxisAcceleration Property

Acceleration to use during Rapids and Independent Motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Acceleration { get; set; }
Public Property Acceleration As Double
    Get
    Set
public:
property double Acceleration {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.CoordAccel Property

KM_AxisCoordAccel Property

Max Acceleration to to use during Coordinated Motion Feeds

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CoordAccel { get; set; }
Public Property CoordAccel As Double
    Get
    Set
public:
property double CoordAccel {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.CoordVelocity Property

KM_AxisCoordVelocity Property

Max Commanded velocity to use during Coordinated Motion Feeds

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CoordVelocity { get; set; }
Public Property CoordVelocity As Double
    Get
    Set
public:
property double CoordVelocity {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.CPU Property

KM_AxisCPU Property

Counts per unit, must set before Velocity, Acceleration, and Jerk

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CPU { get; set; }
Public Property CPU As Double
    Get
    Set
public:
property double CPU {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.CPU_is_mm Property

KM_AxisCPU_is_mm Property

Indicates if CPU (Counts/unit) is mm otherwise inches

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool CPU_is_mm { get; set; }
Public Property CPU_is_mm As Boolean
    Get
    Set
public:
property bool CPU_is_mm {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Axis Class


KM_Axis.HomingParams Property

KM_AxisHomingParams Property

Data memeber for thr homing sequence attributes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_AxisKM_Axis_HomingParams HomingParams { get; }
Public ReadOnly Property HomingParams As KM_AxisKM_Axis_HomingParams
    Get
public:
property KM_AxisKM_Axis_HomingParams^ HomingParams {
    KM_AxisKM_Axis_HomingParams^ get ();
}

Property Value

KM_AxisKM_Axis_HomingParams
See Also

Reference

KM_Axis Class


KM_Axis.ID Property

KM_AxisID Property

Axis Channel Number Valid range = ( 0 - 7 )

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Axis Class


KM_Axis.Jerk Property

KM_AxisJerk Property

Jerk to to use during Rapids and Independent Motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Jerk { get; set; }
Public Property Jerk As Double
    Get
    Set
public:
property double Jerk {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.JogPercent Property

KM_AxisJogPercent Property

The level of jog percenatage computed from the commanded jog velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double JogPercent { get; set; }
Public Property JogPercent As Double
    Get
    Set
public:
property double JogPercent {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.JogVelocity Property

KM_AxisJogVelocity Property

Commanded jog velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double JogVelocity { get; set; }
Public Property JogVelocity As Double
    Get
    Set
public:
property double JogVelocity {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.Name Property

KM_AxisName Property

Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Axis Class


KM_Axis.TuningParams Property

KM_AxisTuningParams Property

Accessor to the axis channel's tuning parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_AxisKM_Axis_TuningParams TuningParams { get; }
Public ReadOnly Property TuningParams As KM_AxisKM_Axis_TuningParams
    Get
public:
property KM_AxisKM_Axis_TuningParams^ TuningParams {
    KM_AxisKM_Axis_TuningParams^ get ();
}

Property Value

KM_AxisKM_Axis_TuningParams
See Also

Reference

KM_Axis Class


KM_Axis.Velocity Property

KM_AxisVelocity Property

Commanded velocity to use during Rapids and Independent Motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Velocity { get; set; }
Public Property Velocity As Double
    Get
    Set
public:
property double Velocity {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Axis Class


KM_Axis Methods

The KM_Axis type exposes the following members.

Methods
 | Name | Description
Public method | CheckEnabled | Check if the axis is enabled
Public method | Disable | Disable the axis
Public method | DoHome | Executes a homing sequence based on the settings within the HomingParams variable and waits until the execution is complete
Public method | Enable | Bring an axis to an enabled state
Public method | EnableDest | Bring an axis to an enabled state and specify the commanded destination for the axis dest is multiplied by CPU and sent to KFLOP
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EStop | Stop the current motion and disable the axis
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetActualPosition | Querys the axis channel for the actual position in user units
Public method | GetActualPositionCounts | Querys the axis channel for the actual position in counts
Public method | GetCommandedPosition | Querys the axis channel for the commanded position in user units
Public method | GetCommandedPositionCounts | Querys the axis channel for the commanded position in counts
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHomeFileSource | Creates the source code for the .c file with an empty main() method
Public method | GetHomeSequence | Creates the lines of code to place in the main() method
Public method | GetMoveToStateAtVel | Auto Generates KFLOP C Code to move until an input bit changes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Jog | Jog axis at the commanded preset jogvelocity * jogpercentage
Public method | Jog(Double) | Jog axis at a given velocity
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MotionComplete | Checks if the commanded axis motion is completed
Public method | MoveTo | Calls a move to a given absolute position and blocks the calling thread until the position has been acheived
Public method | RelativeMoveTo | Calls a move to a given relative position and blocks the calling thread until the position has been acheived
Public method | SetCommandedDest | Sets the axis node's commanded Destination Caution: changing this may result in a sudden jump in the axis position
Public method | SetCurrentPosition | Sets the axis node's current position Can be used to "zero" the axis
Public method | StartDoHome | Executes a homing sequence based on the settings within the HomingParams variable
Public method | StartMoveTo | Calls a non-blocking move to a given absolute position
Public method | StartRelativeMoveTo | Calls a non-blocking move to a given relative position
Public method | Stop | Stop the current motion
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitforMotionComplete | Blocks the calling thread until the axis is in position within a specified time limit
Public method | ZeroAxis | Sets the Axis' current 0.0 point
Top
See Also

Reference

KM_Axis Class


KM_Axis.CheckEnabled Method

KM_AxisCheckEnabled Method

Check if the axis is enabled

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool CheckEnabled()
Public Function CheckEnabled As Boolean
public:
bool CheckEnabled()

Return Value

Boolean
true if enabled
See Also

Reference

KM_Axis Class


KM_Axis.Disable Method

KM_AxisDisable Method

Disable the axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Disable()
Public Sub Disable
public:
void Disable()
See Also

Reference

KM_Axis Class


KM_Axis.DoHome Method

KM_AxisDoHome Method

Executes a homing sequence based on the settings within the HomingParams variable and waits until the execution is complete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool DoHome()
Public Function DoHome As Boolean
public:
bool DoHome()

Return Value

Boolean
true if home routine was successful
See Also

Reference

KM_Axis Class


KM_Axis.Enable Method

KM_AxisEnable Method

Bring an axis to an enabled state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Enable()
Public Sub Enable
public:
void Enable()
See Also

Reference

KM_Axis Class


KM_Axis.EnableDest Method

KM_AxisEnableDest Method

Bring an axis to an enabled state and specify the commanded destination for the axis dest is multiplied by CPU and sent to KFLOP

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void EnableDest(
    double dest
)
Public Sub EnableDest (
    dest As Double
)
public:
void EnableDest(
    double dest
)

Parameters

dest Double
Target Destination for the axis
See Also

Reference

KM_Axis Class


KM_Axis.EStop Method

KM_AxisEStop Method

Stop the current motion and disable the axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void EStop()
Public Sub EStop
public:
void EStop()
See Also

Reference

KM_Axis Class


KM_Axis.GetActualPosition Method

KM_AxisGetActualPosition Method

Querys the axis channel for the actual position in user units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetActualPosition()
Public Function GetActualPosition As Double
public:
double GetActualPosition()

Return Value

Double
user units from the channel's POS
See Also

Reference

KM_Axis Class


KM_Axis.GetActualPositionCounts Method

KM_AxisGetActualPositionCounts Method

Querys the axis channel for the actual position in counts

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetActualPositionCounts()
Public Function GetActualPositionCounts As Double
public:
double GetActualPositionCounts()

Return Value

Double
raw counts from the channel's POS
See Also

Reference

KM_Axis Class


KM_Axis.GetCommandedPosition Method

KM_AxisGetCommandedPosition Method

Querys the axis channel for the commanded position in user units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetCommandedPosition()
Public Function GetCommandedPosition As Double
public:
double GetCommandedPosition()

Return Value

Double
user units from the channel's DEST
See Also

Reference

KM_Axis Class


KM_Axis.GetCommandedPositionCounts Method

KM_AxisGetCommandedPositionCounts Method

Querys the axis channel for the commanded position in counts

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetCommandedPositionCounts()
Public Function GetCommandedPositionCounts As Double
public:
double GetCommandedPositionCounts()

Return Value

Double
raw counts from the channel's DEST
See Also

Reference

KM_Axis Class


KM_Axis.GetHomeFileSource Method

KM_AxisGetHomeFileSource Method

Creates the source code for the .c file with an empty main() method

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string GetHomeFileSource()
Public Function GetHomeFileSource As String
public:
String^ GetHomeFileSource()

Return Value

String
partial source code for homing .c file
See Also

Reference

KM_Axis Class


KM_Axis.GetHomeSequence Method

KM_AxisGetHomeSequence Method

Creates the lines of code to place in the main() method

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string GetHomeSequence()
Public Function GetHomeSequence As String
public:
String^ GetHomeSequence()

Return Value

String
partial source code for homing .c file
See Also

Reference

KM_Axis Class


KM_Axis.GetMoveToStateAtVel Method

KM_AxisGetMoveToStateAtVel Method

Auto Generates KFLOP C Code to move until an input bit changes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string GetMoveToStateAtVel()
Public Function GetMoveToStateAtVel As String
public:
String^ GetMoveToStateAtVel()

Return Value

String
generated code as a string
See Also

Reference

KM_Axis Class


KM_Axis.Jog Method

KM_AxisJog Method

Overload List
 | Name | Description
Public method | Jog | Jog axis at the commanded preset jogvelocity * jogpercentage
Public method | Jog(Double) | Jog axis at a given velocity
Top
See Also

Reference

KM_Axis Class


KM_Axis.Jog Method

KM_AxisJog Method

Jog axis at the commanded preset jogvelocity * jogpercentage

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Jog()
Public Sub Jog
public:
void Jog()
See Also

Reference

KM_Axis Class
Jog Overload


KM_Axis.Jog(Double) Method

KM_AxisJog(Double) Method

Jog axis at a given velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Jog(
    double velocity
)
Public Sub Jog (
    velocity As Double
)
public:
void Jog(
    double velocity
)

Parameters

velocity Double
velocity to jog at : a negative value will reverse the motion
See Also

Reference

KM_Axis Class
Jog Overload


KM_Axis.MotionComplete Method

KM_AxisMotionComplete Method

Checks if the commanded axis motion is completed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool MotionComplete()
Public Function MotionComplete As Boolean
public:
bool MotionComplete()

Return Value

Boolean
true if the axis is idle
See Also

Reference

KM_Axis Class


KM_Axis.MoveTo Method

KM_AxisMoveTo Method

Calls a move to a given absolute position and blocks the calling thread until the position has been acheived

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void MoveTo(
    double pos
)
Public Sub MoveTo (
    pos As Double
)
public:
void MoveTo(
    double pos
)

Parameters

pos Double
absolute position to move to
See Also

Reference

KM_Axis Class


KM_Axis.RelativeMoveTo Method

KM_AxisRelativeMoveTo Method

Calls a move to a given relative position and blocks the calling thread until the position has been acheived

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void RelativeMoveTo(
    double pos
)
Public Sub RelativeMoveTo (
    pos As Double
)
public:
void RelativeMoveTo(
    double pos
)

Parameters

pos Double
position delta from current position to move to
See Also

Reference

KM_Axis Class


KM_Axis.SetCommandedDest Method

KM_AxisSetCommandedDest Method

Sets the axis node's commanded Destination Caution: changing this may result in a sudden jump in the axis position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetCommandedDest(
    double dest
)
Public Sub SetCommandedDest (
    dest As Double
)
public:
void SetCommandedDest(
    double dest
)

Parameters

dest Double
new value for the commanded destination
See Also

Reference

KM_Axis Class


KM_Axis.SetCurrentPosition Method

KM_AxisSetCurrentPosition Method

Sets the axis node's current position Can be used to "zero" the axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetCurrentPosition(
    double pos
)
Public Sub SetCurrentPosition (
    pos As Double
)
public:
void SetCurrentPosition(
    double pos
)

Parameters

pos Double
new value for the current position
See Also

Reference

KM_Axis Class


KM_Axis.StartDoHome Method

KM_AxisStartDoHome Method

Executes a homing sequence based on the settings within the HomingParams variable

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartDoHome()
Public Sub StartDoHome
public:
void StartDoHome()
See Also

Reference

KM_Axis Class


KM_Axis.StartMoveTo Method

KM_AxisStartMoveTo Method

Calls a non-blocking move to a given absolute position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartMoveTo(
    double pos
)
Public Sub StartMoveTo (
    pos As Double
)
public:
void StartMoveTo(
    double pos
)

Parameters

pos Double
absolute position to move to
See Also

Reference

KM_Axis Class


KM_Axis.StartRelativeMoveTo Method

KM_AxisStartRelativeMoveTo Method

Calls a non-blocking move to a given relative position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartRelativeMoveTo(
    double pos
)
Public Sub StartRelativeMoveTo (
    pos As Double
)
public:
void StartRelativeMoveTo(
    double pos
)

Parameters

pos Double
position delta from current position to move to
See Also

Reference

KM_Axis Class


KM_Axis.Stop Method

KM_AxisStop Method

Stop the current motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
See Also

Reference

KM_Axis Class


KM_Axis.WaitforMotionComplete Method

KM_AxisWaitforMotionComplete Method

Blocks the calling thread until the axis is in position within a specified time limit

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool WaitforMotionComplete(
    int timeout
)
Public Function WaitforMotionComplete (
    timeout As Integer
) As Boolean
public:
bool WaitforMotionComplete(
    int timeout
)

Parameters

timeout Int32
time in ms to wait for axis to acheive position, 0 will wait indefinitely

Return Value

Boolean
true if completed
See Also

Reference

KM_Axis Class


KM_Axis.ZeroAxis Method

KM_AxisZeroAxis Method

Sets the Axis' current 0.0 point

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ZeroAxis()
Public Sub ZeroAxis
public:
void ZeroAxis()
See Also

Reference

KM_Axis Class


KM_Axis Fields

The KM_Axis type exposes the following members.

Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _CoordAccel | Acceleration to use during Coordinated Motion using Trajectory Planner
Protected field | _CoordVelocity | Velocity to use during Coordinated Motion using Trajectory Planner
Protected field | _CPU | Multiplier for the velocity in counts/unit
Protected field | _CPU_is_mm | The level of jog percenatage computed from the commanded jog velocity
Protected field | _HomingParams | Data memeber for thr homing sequence attributes
Protected field | _ID | Axis Channel Number Valid range = ( 0 - 7 )
Protected field | _JogPercent | The level of jog percenatage computed from the commanded jog velocity
Protected field | _JogVelocity | Commanded jog velocity
Protected field | _Name | Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...
Protected field | _TuningParams | Accessor to the axis channel's tuning parameters
Protected field | _Velocity | Velocity to use during positioning Jogging uses its own velocity passed in
Top
See Also

Reference

KM_Axis Class


KM_Axis._Controller Field

KM_Axis_Controller Field

KM_Controller Object for used for device access

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_Controller _Controller
Protected _Controller As KM_Controller
protected:
KM_Controller^ _Controller

Field Value

KM_Controller
See Also

Reference

KM_Axis Class


KM_Axis._CoordAccel Field

KM_Axis_CoordAccel Field

Acceleration to use during Coordinated Motion using Trajectory Planner

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _CoordAccel
Protected _CoordAccel As Double
protected:
double _CoordAccel

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis._CoordVelocity Field

KM_Axis_CoordVelocity Field

Velocity to use during Coordinated Motion using Trajectory Planner

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _CoordVelocity
Protected _CoordVelocity As Double
protected:
double _CoordVelocity

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis._CPU Field

KM_Axis_CPU Field

Multiplier for the velocity in counts/unit

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _CPU
Protected _CPU As Double
protected:
double _CPU

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis._CPU_is_mm Field

KM_Axis_CPU_is_mm Field

The level of jog percenatage computed from the commanded jog velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _CPU_is_mm
Protected _CPU_is_mm As Boolean
protected:
bool _CPU_is_mm

Field Value

Boolean
See Also

Reference

KM_Axis Class


KM_Axis._HomingParams Field

KM_Axis_HomingParams Field

Data memeber for thr homing sequence attributes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_AxisKM_Axis_HomingParams _HomingParams
Protected _HomingParams As KM_AxisKM_Axis_HomingParams
protected:
KM_AxisKM_Axis_HomingParams^ _HomingParams

Field Value

KM_AxisKM_Axis_HomingParams
See Also

Reference

KM_Axis Class


KM_Axis._ID Field

KM_Axis_ID Field

Axis Channel Number Valid range = ( 0 - 7 )

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int _ID
Protected _ID As Integer
protected:
int _ID

Field Value

Int32
See Also

Reference

KM_Axis Class


KM_Axis._JogPercent Field

KM_Axis_JogPercent Field

The level of jog percenatage computed from the commanded jog velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _JogPercent
Protected _JogPercent As Double
protected:
double _JogPercent

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis._JogVelocity Field

KM_Axis_JogVelocity Field

Commanded jog velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _JogVelocity
Protected _JogVelocity As Double
protected:
double _JogVelocity

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis._Name Field

KM_Axis_Name Field

Call Name Use to describe what the Axis controls i.e. Positioning Fence 1, X, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected string _Name
Protected _Name As String
protected:
String^ _Name

Field Value

String
See Also

Reference

KM_Axis Class


KM_Axis._TuningParams Field

KM_Axis_TuningParams Field

Accessor to the axis channel's tuning parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_AxisKM_Axis_TuningParams _TuningParams
Protected _TuningParams As KM_AxisKM_Axis_TuningParams
protected:
KM_AxisKM_Axis_TuningParams^ _TuningParams

Field Value

KM_AxisKM_Axis_TuningParams
See Also

Reference

KM_Axis Class


KM_Axis._Velocity Field

KM_Axis_Velocity Field

Velocity to use during positioning Jogging uses its own velocity passed in

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _Velocity
Protected _Velocity As Double
protected:
double _Velocity

Field Value

Double
See Also

Reference

KM_Axis Class


KM_Axis.KM_Axis_HomingParams Class

KM_AxisKM_Axis_HomingParams Class

Multiple parameters to describe the homing sequence for the axis so that a proper sequence can be auto-generated in some circumstances. (This has not been fully implemented)
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_AxisKM_Axis_HomingParams

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Axis_HomingParams
Public Class KM_Axis_HomingParams
public ref class KM_Axis_HomingParams

The KM_AxisKM_Axis_HomingParams type exposes the following members.

Constructors
 | Name | Description
Public method | KM_AxisKM_Axis_HomingParams | Initializes a new instance of the KM_AxisKM_Axis_HomingParams class
Top
Properties
 | Name | Description
Public property | DefaultThread | Which KFLOP Thread should be used to run the Home C Program in
Public property | EncoderBit | Which Input Bit is to be used for any encoder index mark homing
Public property | HomeFastVel | Initial Fast Homing Velocity
Public property | HomeLimitBit | Which bit is to be used as a Limit while Homing
Public property | HomeLimitState | State (polarity) when Input is actively in sensor
Public property | HomeNegative | Direction to be homed
Public property | HomeSlowVel | Secondary Slow Homing Velocity
Public property | Homing_c_Program | C Program Filename for Homing
Public property | Homing_c_Program_Dir | C Program Filename Directory for Homing if unspecified the Directory of the DLL assembly will be used for writing and reading the auto created C Program
Public property | Origin | Origin value to be set after homing
Public property | RepeatHomeAtSlowerRate | Determines if Home sequence is to be performed twice with the second pass at a slower speed
Public property | SensorOffset | Amount to move after finding Home Switch
Public property | SequencePriority | Determines the order of axes to be homed
Public property | SequenceType | Enumerated Code describing the overall homing type for the axis
Public property | SetToZero | Option to Zero Command and Position
Public property | SourceType | Determines method of homing - Fixed C file or Autogenerated C code
Public property | StatusBit | Which bit is to be used as Home input
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetDirection | Returns direction to move for homing
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPolarity | State (polarity) when Input is actively in sensor - optionally inverted
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Axis.KM_Axis_HomingParams Constructor

KM_AxisKM_Axis_HomingParams Constructor

Initializes a new instance of the KM_AxisKM_Axis_HomingParams class

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Axis_HomingParams()
Public Sub New
public:
KM_Axis_HomingParams()
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis_HomingParams Properties

The KM_AxisKM_Axis_HomingParams type exposes the following members.

Properties
 | Name | Description
Public property | DefaultThread | Which KFLOP Thread should be used to run the Home C Program in
Public property | EncoderBit | Which Input Bit is to be used for any encoder index mark homing
Public property | HomeFastVel | Initial Fast Homing Velocity
Public property | HomeLimitBit | Which bit is to be used as a Limit while Homing
Public property | HomeLimitState | State (polarity) when Input is actively in sensor
Public property | HomeNegative | Direction to be homed
Public property | HomeSlowVel | Secondary Slow Homing Velocity
Public property | Homing_c_Program | C Program Filename for Homing
Public property | Homing_c_Program_Dir | C Program Filename Directory for Homing if unspecified the Directory of the DLL assembly will be used for writing and reading the auto created C Program
Public property | Origin | Origin value to be set after homing
Public property | RepeatHomeAtSlowerRate | Determines if Home sequence is to be performed twice with the second pass at a slower speed
Public property | SensorOffset | Amount to move after finding Home Switch
Public property | SequencePriority | Determines the order of axes to be homed
Public property | SequenceType | Enumerated Code describing the overall homing type for the axis
Public property | SetToZero | Option to Zero Command and Position
Public property | SourceType | Determines method of homing - Fixed C file or Autogenerated C code
Public property | StatusBit | Which bit is to be used as Home input
Top
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.DefaultThread Property

KM_AxisKM_Axis_HomingParamsDefaultThread Property

Which KFLOP Thread should be used to run the Home C Program in

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int DefaultThread { get; set; }
Public Property DefaultThread As Integer
    Get
    Set
public:
property int DefaultThread {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.EncoderBit Property

KM_AxisKM_Axis_HomingParamsEncoderBit Property

Which Input Bit is to be used for any encoder index mark homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int EncoderBit { get; set; }
Public Property EncoderBit As Integer
    Get
    Set
public:
property int EncoderBit {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.HomeFastVel Property

KM_AxisKM_Axis_HomingParamsHomeFastVel Property

Initial Fast Homing Velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double HomeFastVel { get; set; }
Public Property HomeFastVel As Double
    Get
    Set
public:
property double HomeFastVel {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.HomeLimitBit Property

KM_AxisKM_Axis_HomingParamsHomeLimitBit Property

Which bit is to be used as a Limit while Homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int HomeLimitBit { get; set; }
Public Property HomeLimitBit As Integer
    Get
    Set
public:
property int HomeLimitBit {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.HomeLimitState Property

KM_AxisKM_Axis_HomingParamsHomeLimitState Property

State (polarity) when Input is actively in sensor

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool HomeLimitState { get; set; }
Public Property HomeLimitState As Boolean
    Get
    Set
public:
property bool HomeLimitState {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.HomeNegative Property

KM_AxisKM_Axis_HomingParamsHomeNegative Property

Direction to be homed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool HomeNegative { get; set; }
Public Property HomeNegative As Boolean
    Get
    Set
public:
property bool HomeNegative {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.HomeSlowVel Property

KM_AxisKM_Axis_HomingParamsHomeSlowVel Property

Secondary Slow Homing Velocity

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double HomeSlowVel { get; set; }
Public Property HomeSlowVel As Double
    Get
    Set
public:
property double HomeSlowVel {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.Homing_c_Program Property

KM_AxisKM_Axis_HomingParamsHoming_c_Program Property

C Program Filename for Homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Homing_c_Program { get; set; }
Public Property Homing_c_Program As String
    Get
    Set
public:
property String^ Homing_c_Program {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.Homing_c_Program_Dir Property

KM_AxisKM_Axis_HomingParamsHoming_c_Program_Dir Property

C Program Filename Directory for Homing if unspecified the Directory of the DLL assembly will be used for writing and reading the auto created C Program

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Homing_c_Program_Dir { get; set; }
Public Property Homing_c_Program_Dir As String
    Get
    Set
public:
property String^ Homing_c_Program_Dir {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.Origin Property

KM_AxisKM_Axis_HomingParamsOrigin Property

Origin value to be set after homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Origin { get; set; }
Public Property Origin As Double
    Get
    Set
public:
property double Origin {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.RepeatHomeAtSlowerRate Property

KM_AxisKM_Axis_HomingParamsRepeatHomeAtSlowerRate Property

Determines if Home sequence is to be performed twice with the second pass at a slower speed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool RepeatHomeAtSlowerRate { get; set; }
Public Property RepeatHomeAtSlowerRate As Boolean
    Get
    Set
public:
property bool RepeatHomeAtSlowerRate {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.SensorOffset Property

KM_AxisKM_Axis_HomingParamsSensorOffset Property

Amount to move after finding Home Switch

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SensorOffset { get; set; }
Public Property SensorOffset As Double
    Get
    Set
public:
property double SensorOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.SequencePriority Property

KM_AxisKM_Axis_HomingParamsSequencePriority Property

Determines the order of axes to be homed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SequencePriority { get; set; }
Public Property SequencePriority As Integer
    Get
    Set
public:
property int SequencePriority {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.SequenceType Property

KM_AxisKM_Axis_HomingParamsSequenceType Property

Enumerated Code describing the overall homing type for the axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public HOMING_TYPE SequenceType { get; set; }
Public Property SequenceType As HOMING_TYPE
    Get
    Set
public:
property HOMING_TYPE SequenceType {
    HOMING_TYPE get ();
    void set (HOMING_TYPE value);
}

Property Value

HOMING_TYPE
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.SetToZero Property

KM_AxisKM_Axis_HomingParamsSetToZero Property

Option to Zero Command and Position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool SetToZero { get; set; }
Public Property SetToZero As Boolean
    Get
    Set
public:
property bool SetToZero {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.SourceType Property

KM_AxisKM_Axis_HomingParamsSourceType Property

Determines method of homing - Fixed C file or Autogenerated C code

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public HOMING_ROUTINE_SOURCE_TYPE SourceType { get; set; }
Public Property SourceType As HOMING_ROUTINE_SOURCE_TYPE
    Get
    Set
public:
property HOMING_ROUTINE_SOURCE_TYPE SourceType {
    HOMING_ROUTINE_SOURCE_TYPE get ();
    void set (HOMING_ROUTINE_SOURCE_TYPE value);
}

Property Value

HOMING_ROUTINE_SOURCE_TYPE
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.StatusBit Property

KM_AxisKM_Axis_HomingParamsStatusBit Property

Which bit is to be used as Home input

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int StatusBit { get; set; }
Public Property StatusBit As Integer
    Get
    Set
public:
property int StatusBit {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis_HomingParams Methods

The KM_AxisKM_Axis_HomingParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetDirection | Returns direction to move for homing
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPolarity | State (polarity) when Input is actively in sensor - optionally inverted
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.GetDirection Method

KM_AxisKM_Axis_HomingParamsGetDirection Method

Returns direction to move for homing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public HOMING_DIRECTION GetDirection()
Public Function GetDirection As HOMING_DIRECTION
public:
HOMING_DIRECTION GetDirection()

Return Value

HOMING_DIRECTION
HOMING_DIRECTION.NEGATIVE or HOMING_DIRECTION.POSITIVE
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_HomingParams.GetPolarity Method

KM_AxisKM_Axis_HomingParamsGetPolarity Method

State (polarity) when Input is actively in sensor - optionally inverted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetPolarity(
    bool reverse
)
Public Function GetPolarity (
    reverse As Boolean
) As Integer
public:
int GetPolarity(
    bool reverse
)

Parameters

reverse Boolean
whether the polarity should be returned inverted

Return Value

Int32
Limit State Polarity
See Also

Reference

KM_AxisKM_Axis_HomingParams Class


KM_Axis.KM_Axis_TuningParams Class

KM_AxisKM_Axis_TuningParams Class

KFLOP Axis Channel parameters for Tuning and motion profiles
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_AxisKM_Axis_TuningParams

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Axis_TuningParams
Public Class KM_Axis_TuningParams
public ref class KM_Axis_TuningParams

The KM_AxisKM_Axis_TuningParams type exposes the following members.

Constructors
 | Name | Description
Public method | KM_AxisKM_Axis_TuningParams | Associate KFLOP Axis Channel with Parameters
Top
Properties
 | Name | Description
Public property | BacklashAmount | Sets or gets the amount of Backlash Compensation Offset to be applied. See also BacklashMode and BacklashRate.
Public property | BacklashMode | Sets or gets the Backlash Compensation mode from either BACKLASH_OFF (0) to BACKLASH_LINEAR (1). When the backlash mode is set to Linear mode, whenever the commanded destination begins moving in the positive direction, a positive offset of the amount, BacklashAmount, will be applied. The offset will be ramped upward as a linear function of time at the rate specified as the BacklashRate. Whenever the commanded destination begins moving in the negative direction the offset will be removed by ramping downward toward zero at the same rate. If the the Backlash Compensation mode is set to BACKLASH_OFF (0), no backlash compensation will be applied. See also BacklashRatee and BacklashAmount.
Public property | BacklashRate | Sets or gets the rate at which the amount of Backlash Compensation Offset will be applied. See also BacklashMode and BacklashAmount.
Public property | CommutationOffset | Get or Set 3 or 4 phase commutation offset. When brushless commutation is performed, the desired Output Magnitude is distributed and applied to the various motor coils as a function of position. The commutation offset shifts the manner in which the Output Magnitude is applied. For a 3 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 2π/3) PhaseC = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 4π/3) For a 4 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * cos((Position+CommutationOffset)*invDistPerCycle*2π) See also invDistPerCycle and Configuration Parameters.
Public property | DeadBandGain | Get or Set gain while error is within the deadband range. See DeadBand Description. See Servo Flow Diagram.
Public property | DeadBandRange | Get or Set range where deadband gain is to be applied. See DeadBand Description. See Servo Flow Diagram.
Public property | Dgain | Get or Set PID Derivative Gain.
Public property | FFAccel | Set or get Acceleration feed forward for the axis.
Public property | FFVel | Set or get Velocity feed forward for the axis.
Public property | ID | Axis Channel Number Valid range = ( 0 - 7 )
Public property | Igain | Get or Set PID Integral Gain.
Public property | InputChan0 | Set or get first Input Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | InputChan1 | Set or get second Input Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | InputGain0 | Set or get first Input Gain of an axis. See description of this parameter on the Configuration Screen.
Public property | InputGain1 | Set or get second Input Gain of an axis. See description of this parameter on the Configuration Screen.
Public property | InputMode | Set or get the position input mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC-DSP.h):
Public property | InputOffset0 | Set or get first Input Offset of an axis. See description of this parameter on the Configuration Screen.
Public property | InputOffset1 | Set or get second Input Offset of an axis. See description of this parameter on the Configuration Screen.
Public property | InvDistPerCycle | Get or Set distance per cycle (specified as an inverse) of an axis. May specify the cycle of either a Stepper of Brushless Motor. See description of this parameter on the Configuration Screen.
Public property | Jerk | Get or Set the max jerk (for independent moves and jogs)
Public property | Lead | Set or get Lead Compensation for an axis. Lead Compensation is used to compensate for lag caused by motor inductance.
Public property | LimitSwitch | Configures Limit Switch Options. Specify Hex value as decribed in KMotionDef.h See also Configuration Screen.
Public property | MasterAxis | Sets or gets the axis to which the current axis is to be slaved. The current axis becomes a slave and will follow the motion of the specified Master Axis. More than one axis can be slaved to a single master axis if desired. When slaved, changes in the commanded destination of the master axis will be mirrored as changes in the slaved axis's destination however scaled by the SlaveGain (as specified in the Slave Axis). The SlaveGain my be negative if opposing motion is desired. Setting the Master Axis value to -1 disables the Slave mode.
Public property | MaxErr | Set or get Maximum Error for axis (Limits magnitude of error entering PID). See Servo Flow Diagram and Step Response Screen for more information.
Public property | MaxFollowingError | Set or get the maximum allowed following error before disabling the axis.
Public property | MaxI | Set or get Maximum Integrator "wind up" for axis. Integrator saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.
Public property | MaxOutput | Set or get Maximum Output for an axis. Limits magnitude of servo output. Output saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.
Public property | OutputChan0 | Get or Set the first Output Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | OutputChan1 | Get or Set the second Output Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | OutputGain | Get or Set the Output Gain of an axis. For Axes of Step/Dir, CL Step Dir, or MicroStep output mode, the output motion can be scaled or reversed. Normally there is no need to use a value other than -1.0 or +1.0. For DAC Servo output mode the output signal (DAC) can be scaled or reversed. Again, normally there is no need to use a value other than -1.0 or +1.0. In other output modes the OutputGain value will have no effect.
Public property | OutputMode | Set or get the position output mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC_DSP.h):
Public property | OutputOffset | Get or Set the Output Offset of an axis. For DAC Servo output mode the output (DAC) signal can be offset. The Output Offset is applied after any Output Gain value. The Output Offset can be used to reduce any DAC output offset or Amplifier input offset that may cause motor axis drift occurs when the DAC is commanded to zero (disabled). In other output modes the OutputGain value will have no effect.
Public property | Pgain | Get or Set PID Proportional Gain.
Public property | SlaveGain | Sets or gets the Slave Gain for the axis. See also MasterAxis for more information
Public property | SoftLimitNeg | Set or get the Soft Limit Setting for the Negative direction in Counts.
Public property | SoftLimitPos | Set or get the Soft Limit Setting for the Positive direction in Counts.
Public property | StepperAmplitude | Set or get the nominal output magnitude used for axis if in MicroStepping Output Mode to the specified value. This will be the output amplitude when stopped or moving slowly. If Lead Compensation is used, the amplitude while moving may be higher.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetIIR0 | Set or get IIR Z domain servo filter #0
Public method | SetIIR1 | Set or get IIR Z domain servo filter #1
Public method | SetIIR2 | Set or get IIR Z domain servo filter #2
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _ID | Axis Channel Number Valid range = ( 0 - 7 )
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Axis.KM_Axis_TuningParams Constructor

KM_AxisKM_Axis_TuningParams Constructor

Associate KFLOP Axis Channel with Parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Axis_TuningParams(
    KM_Controller controller,
    int id
)
Public Sub New (
    controller As KM_Controller,
    id As Integer
)
public:
KM_Axis_TuningParams(
    KM_Controller^ controller,
    int id
)

Parameters

controller KM_Controller
KM_Controller object to axxociate the Axis with
id Int32
Axis ID
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis_TuningParams Properties

The KM_AxisKM_Axis_TuningParams type exposes the following members.

Properties
 | Name | Description
Public property | BacklashAmount | Sets or gets the amount of Backlash Compensation Offset to be applied. See also BacklashMode and BacklashRate.
Public property | BacklashMode | Sets or gets the Backlash Compensation mode from either BACKLASH_OFF (0) to BACKLASH_LINEAR (1). When the backlash mode is set to Linear mode, whenever the commanded destination begins moving in the positive direction, a positive offset of the amount, BacklashAmount, will be applied. The offset will be ramped upward as a linear function of time at the rate specified as the BacklashRate. Whenever the commanded destination begins moving in the negative direction the offset will be removed by ramping downward toward zero at the same rate. If the the Backlash Compensation mode is set to BACKLASH_OFF (0), no backlash compensation will be applied. See also BacklashRatee and BacklashAmount.
Public property | BacklashRate | Sets or gets the rate at which the amount of Backlash Compensation Offset will be applied. See also BacklashMode and BacklashAmount.
Public property | CommutationOffset | Get or Set 3 or 4 phase commutation offset. When brushless commutation is performed, the desired Output Magnitude is distributed and applied to the various motor coils as a function of position. The commutation offset shifts the manner in which the Output Magnitude is applied. For a 3 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 2π/3) PhaseC = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 4π/3) For a 4 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * cos((Position+CommutationOffset)*invDistPerCycle*2π) See also invDistPerCycle and Configuration Parameters.
Public property | DeadBandGain | Get or Set gain while error is within the deadband range. See DeadBand Description. See Servo Flow Diagram.
Public property | DeadBandRange | Get or Set range where deadband gain is to be applied. See DeadBand Description. See Servo Flow Diagram.
Public property | Dgain | Get or Set PID Derivative Gain.
Public property | FFAccel | Set or get Acceleration feed forward for the axis.
Public property | FFVel | Set or get Velocity feed forward for the axis.
Public property | ID | Axis Channel Number Valid range = ( 0 - 7 )
Public property | Igain | Get or Set PID Integral Gain.
Public property | InputChan0 | Set or get first Input Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | InputChan1 | Set or get second Input Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | InputGain0 | Set or get first Input Gain of an axis. See description of this parameter on the Configuration Screen.
Public property | InputGain1 | Set or get second Input Gain of an axis. See description of this parameter on the Configuration Screen.
Public property | InputMode | Set or get the position input mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC-DSP.h):
Public property | InputOffset0 | Set or get first Input Offset of an axis. See description of this parameter on the Configuration Screen.
Public property | InputOffset1 | Set or get second Input Offset of an axis. See description of this parameter on the Configuration Screen.
Public property | InvDistPerCycle | Get or Set distance per cycle (specified as an inverse) of an axis. May specify the cycle of either a Stepper of Brushless Motor. See description of this parameter on the Configuration Screen.
Public property | Jerk | Get or Set the max jerk (for independent moves and jogs)
Public property | Lead | Set or get Lead Compensation for an axis. Lead Compensation is used to compensate for lag caused by motor inductance.
Public property | LimitSwitch | Configures Limit Switch Options. Specify Hex value as decribed in KMotionDef.h See also Configuration Screen.
Public property | MasterAxis | Sets or gets the axis to which the current axis is to be slaved. The current axis becomes a slave and will follow the motion of the specified Master Axis. More than one axis can be slaved to a single master axis if desired. When slaved, changes in the commanded destination of the master axis will be mirrored as changes in the slaved axis's destination however scaled by the SlaveGain (as specified in the Slave Axis). The SlaveGain my be negative if opposing motion is desired. Setting the Master Axis value to -1 disables the Slave mode.
Public property | MaxErr | Set or get Maximum Error for axis (Limits magnitude of error entering PID). See Servo Flow Diagram and Step Response Screen for more information.
Public property | MaxFollowingError | Set or get the maximum allowed following error before disabling the axis.
Public property | MaxI | Set or get Maximum Integrator "wind up" for axis. Integrator saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.
Public property | MaxOutput | Set or get Maximum Output for an axis. Limits magnitude of servo output. Output saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.
Public property | OutputChan0 | Get or Set the first Output Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | OutputChan1 | Get or Set the second Output Channel of an axis. See description of this parameter on the Configuration Screen.
Public property | OutputGain | Get or Set the Output Gain of an axis. For Axes of Step/Dir, CL Step Dir, or MicroStep output mode, the output motion can be scaled or reversed. Normally there is no need to use a value other than -1.0 or +1.0. For DAC Servo output mode the output signal (DAC) can be scaled or reversed. Again, normally there is no need to use a value other than -1.0 or +1.0. In other output modes the OutputGain value will have no effect.
Public property | OutputMode | Set or get the position output mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC_DSP.h):
Public property | OutputOffset | Get or Set the Output Offset of an axis. For DAC Servo output mode the output (DAC) signal can be offset. The Output Offset is applied after any Output Gain value. The Output Offset can be used to reduce any DAC output offset or Amplifier input offset that may cause motor axis drift occurs when the DAC is commanded to zero (disabled). In other output modes the OutputGain value will have no effect.
Public property | Pgain | Get or Set PID Proportional Gain.
Public property | SlaveGain | Sets or gets the Slave Gain for the axis. See also MasterAxis for more information
Public property | SoftLimitNeg | Set or get the Soft Limit Setting for the Negative direction in Counts.
Public property | SoftLimitPos | Set or get the Soft Limit Setting for the Positive direction in Counts.
Public property | StepperAmplitude | Set or get the nominal output magnitude used for axis if in MicroStepping Output Mode to the specified value. This will be the output amplitude when stopped or moving slowly. If Lead Compensation is used, the amplitude while moving may be higher.
Top
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.BacklashAmount Property

KM_AxisKM_Axis_TuningParamsBacklashAmount Property

Sets or gets the amount of Backlash Compensation Offset to be applied. See also BacklashMode and BacklashRate.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double BacklashAmount { get; set; }
Public Property BacklashAmount As Double
    Get
    Set
public:
property double BacklashAmount {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.BacklashMode Property

KM_AxisKM_Axis_TuningParamsBacklashMode Property

Sets or gets the Backlash Compensation mode from either BACKLASH_OFF (0) to BACKLASH_LINEAR (1). When the backlash mode is set to Linear mode, whenever the commanded destination begins moving in the positive direction, a positive offset of the amount, BacklashAmount, will be applied. The offset will be ramped upward as a linear function of time at the rate specified as the BacklashRate. Whenever the commanded destination begins moving in the negative direction the offset will be removed by ramping downward toward zero at the same rate. If the the Backlash Compensation mode is set to BACKLASH_OFF (0), no backlash compensation will be applied. See also BacklashRatee and BacklashAmount.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BacklashMode { get; set; }
Public Property BacklashMode As Integer
    Get
    Set
public:
property int BacklashMode {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.BacklashRate Property

KM_AxisKM_Axis_TuningParamsBacklashRate Property

Sets or gets the rate at which the amount of Backlash Compensation Offset will be applied. See also BacklashMode and BacklashAmount.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double BacklashRate { get; set; }
Public Property BacklashRate As Double
    Get
    Set
public:
property double BacklashRate {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.CommutationOffset Property

KM_AxisKM_Axis_TuningParamsCommutationOffset Property

Get or Set 3 or 4 phase commutation offset. When brushless commutation is performed, the desired Output Magnitude is distributed and applied to the various motor coils as a function of position. The commutation offset shifts the manner in which the Output Magnitude is applied. For a 3 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 2π/3) PhaseC = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π + 4π/3) For a 4 phase brushless output mode, commutation offset is used in the following manner. PhaseA = OutputMagnitude * sin((Position+CommutationOffset)*invDistPerCycle*2π) PhaseB = OutputMagnitude * cos((Position+CommutationOffset)*invDistPerCycle*2π) See also invDistPerCycle and Configuration Parameters.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CommutationOffset { get; set; }
Public Property CommutationOffset As Double
    Get
    Set
public:
property double CommutationOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.DeadBandGain Property

KM_AxisKM_Axis_TuningParamsDeadBandGain Property

Get or Set gain while error is within the deadband range. See DeadBand Description. See Servo Flow Diagram.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double DeadBandGain { get; set; }
Public Property DeadBandGain As Double
    Get
    Set
public:
property double DeadBandGain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.DeadBandRange Property

KM_AxisKM_Axis_TuningParamsDeadBandRange Property

Get or Set range where deadband gain is to be applied. See DeadBand Description. See Servo Flow Diagram.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double DeadBandRange { get; set; }
Public Property DeadBandRange As Double
    Get
    Set
public:
property double DeadBandRange {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.Dgain Property

KM_AxisKM_Axis_TuningParamsDgain Property

Get or Set PID Derivative Gain.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Dgain { get; set; }
Public Property Dgain As Double
    Get
    Set
public:
property double Dgain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.FFAccel Property

KM_AxisKM_Axis_TuningParamsFFAccel Property

Set or get Acceleration feed forward for the axis.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FFAccel { get; set; }
Public Property FFAccel As Double
    Get
    Set
public:
property double FFAccel {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.FFVel Property

KM_AxisKM_Axis_TuningParamsFFVel Property

Set or get Velocity feed forward for the axis.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FFVel { get; set; }
Public Property FFVel As Double
    Get
    Set
public:
property double FFVel {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.ID Property

KM_AxisKM_Axis_TuningParamsID Property

Axis Channel Number Valid range = ( 0 - 7 )

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.Igain Property

KM_AxisKM_Axis_TuningParamsIgain Property

Get or Set PID Integral Gain.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Igain { get; set; }
Public Property Igain As Double
    Get
    Set
public:
property double Igain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputChan0 Property

KM_AxisKM_Axis_TuningParamsInputChan0 Property

Set or get first Input Channel of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputChan0 { get; set; }
Public Property InputChan0 As Double
    Get
    Set
public:
property double InputChan0 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputChan1 Property

KM_AxisKM_Axis_TuningParamsInputChan1 Property

Set or get second Input Channel of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputChan1 { get; set; }
Public Property InputChan1 As Double
    Get
    Set
public:
property double InputChan1 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputGain0 Property

KM_AxisKM_Axis_TuningParamsInputGain0 Property

Set or get first Input Gain of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputGain0 { get; set; }
Public Property InputGain0 As Double
    Get
    Set
public:
property double InputGain0 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputGain1 Property

KM_AxisKM_Axis_TuningParamsInputGain1 Property

Set or get second Input Gain of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputGain1 { get; set; }
Public Property InputGain1 As Double
    Get
    Set
public:
property double InputGain1 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputMode Property

KM_AxisKM_Axis_TuningParamsInputMode Property

Set or get the position input mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC-DSP.h):

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputMode { get; set; }
Public Property InputMode As Integer
    Get
    Set
public:
property int InputMode {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputOffset0 Property

KM_AxisKM_Axis_TuningParamsInputOffset0 Property

Set or get first Input Offset of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputOffset0 { get; set; }
Public Property InputOffset0 As Double
    Get
    Set
public:
property double InputOffset0 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InputOffset1 Property

KM_AxisKM_Axis_TuningParamsInputOffset1 Property

Set or get second Input Offset of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InputOffset1 { get; set; }
Public Property InputOffset1 As Double
    Get
    Set
public:
property double InputOffset1 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.InvDistPerCycle Property

KM_AxisKM_Axis_TuningParamsInvDistPerCycle Property

Get or Set distance per cycle (specified as an inverse) of an axis. May specify the cycle of either a Stepper of Brushless Motor. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InvDistPerCycle { get; set; }
Public Property InvDistPerCycle As Double
    Get
    Set
public:
property double InvDistPerCycle {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.Jerk Property

KM_AxisKM_Axis_TuningParamsJerk Property

Get or Set the max jerk (for independent moves and jogs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Jerk { get; set; }
Public Property Jerk As Double
    Get
    Set
public:
property double Jerk {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.Lead Property

KM_AxisKM_Axis_TuningParamsLead Property

Set or get Lead Compensation for an axis. Lead Compensation is used to compensate for lag caused by motor inductance.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Lead { get; set; }
Public Property Lead As Double
    Get
    Set
public:
property double Lead {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.LimitSwitch Property

KM_AxisKM_Axis_TuningParamsLimitSwitch Property

Configures Limit Switch Options. Specify Hex value as decribed in KMotionDef.h See also Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string LimitSwitch { get; set; }
Public Property LimitSwitch As String
    Get
    Set
public:
property String^ LimitSwitch {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.MasterAxis Property

KM_AxisKM_Axis_TuningParamsMasterAxis Property

Sets or gets the axis to which the current axis is to be slaved. The current axis becomes a slave and will follow the motion of the specified Master Axis. More than one axis can be slaved to a single master axis if desired. When slaved, changes in the commanded destination of the master axis will be mirrored as changes in the slaved axis's destination however scaled by the SlaveGain (as specified in the Slave Axis). The SlaveGain my be negative if opposing motion is desired. Setting the Master Axis value to -1 disables the Slave mode.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int MasterAxis { get; set; }
Public Property MasterAxis As Integer
    Get
    Set
public:
property int MasterAxis {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.MaxErr Property

KM_AxisKM_Axis_TuningParamsMaxErr Property

Set or get Maximum Error for axis (Limits magnitude of error entering PID). See Servo Flow Diagram and Step Response Screen for more information.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxErr { get; set; }
Public Property MaxErr As Double
    Get
    Set
public:
property double MaxErr {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.MaxFollowingError Property

KM_AxisKM_Axis_TuningParamsMaxFollowingError Property

Set or get the maximum allowed following error before disabling the axis.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxFollowingError { get; set; }
Public Property MaxFollowingError As Double
    Get
    Set
public:
property double MaxFollowingError {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.MaxI Property

KM_AxisKM_Axis_TuningParamsMaxI Property

Set or get Maximum Integrator "wind up" for axis. Integrator saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxI { get; set; }
Public Property MaxI As Double
    Get
    Set
public:
property double MaxI {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.MaxOutput Property

KM_AxisKM_Axis_TuningParamsMaxOutput Property

Set or get Maximum Output for an axis. Limits magnitude of servo output. Output saturates at the specified value. See also Servo Flow Diagram and Step Response Screen for further information.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxOutput { get; set; }
Public Property MaxOutput As Double
    Get
    Set
public:
property double MaxOutput {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.OutputChan0 Property

KM_AxisKM_Axis_TuningParamsOutputChan0 Property

Get or Set the first Output Channel of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double OutputChan0 { get; set; }
Public Property OutputChan0 As Double
    Get
    Set
public:
property double OutputChan0 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.OutputChan1 Property

KM_AxisKM_Axis_TuningParamsOutputChan1 Property

Get or Set the second Output Channel of an axis. See description of this parameter on the Configuration Screen.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double OutputChan1 { get; set; }
Public Property OutputChan1 As Double
    Get
    Set
public:
property double OutputChan1 {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.OutputGain Property

KM_AxisKM_Axis_TuningParamsOutputGain Property

Get or Set the Output Gain of an axis. For Axes of Step/Dir, CL Step Dir, or MicroStep output mode, the output motion can be scaled or reversed. Normally there is no need to use a value other than -1.0 or +1.0. For DAC Servo output mode the output signal (DAC) can be scaled or reversed. Again, normally there is no need to use a value other than -1.0 or +1.0. In other output modes the OutputGain value will have no effect.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double OutputGain { get; set; }
Public Property OutputGain As Double
    Get
    Set
public:
property double OutputGain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.OutputMode Property

KM_AxisKM_Axis_TuningParamsOutputMode Property

Set or get the position output mode for an axis. See description of this parameter on the Configuration Screen. Valid modes are (from PC_DSP.h):

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputMode { get; set; }
Public Property OutputMode As Integer
    Get
    Set
public:
property int OutputMode {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.OutputOffset Property

KM_AxisKM_Axis_TuningParamsOutputOffset Property

Get or Set the Output Offset of an axis. For DAC Servo output mode the output (DAC) signal can be offset. The Output Offset is applied after any Output Gain value. The Output Offset can be used to reduce any DAC output offset or Amplifier input offset that may cause motor axis drift occurs when the DAC is commanded to zero (disabled). In other output modes the OutputGain value will have no effect.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double OutputOffset { get; set; }
Public Property OutputOffset As Double
    Get
    Set
public:
property double OutputOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.Pgain Property

KM_AxisKM_Axis_TuningParamsPgain Property

Get or Set PID Proportional Gain.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Pgain { get; set; }
Public Property Pgain As Double
    Get
    Set
public:
property double Pgain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SlaveGain Property

KM_AxisKM_Axis_TuningParamsSlaveGain Property

Sets or gets the Slave Gain for the axis. See also MasterAxis for more information

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SlaveGain { get; set; }
Public Property SlaveGain As Double
    Get
    Set
public:
property double SlaveGain {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SoftLimitNeg Property

KM_AxisKM_Axis_TuningParamsSoftLimitNeg Property

Set or get the Soft Limit Setting for the Negative direction in Counts.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SoftLimitNeg { get; set; }
Public Property SoftLimitNeg As Double
    Get
    Set
public:
property double SoftLimitNeg {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SoftLimitPos Property

KM_AxisKM_Axis_TuningParamsSoftLimitPos Property

Set or get the Soft Limit Setting for the Positive direction in Counts.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SoftLimitPos { get; set; }
Public Property SoftLimitPos As Double
    Get
    Set
public:
property double SoftLimitPos {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.StepperAmplitude Property

KM_AxisKM_Axis_TuningParamsStepperAmplitude Property

Set or get the nominal output magnitude used for axis if in MicroStepping Output Mode to the specified value. This will be the output amplitude when stopped or moving slowly. If Lead Compensation is used, the amplitude while moving may be higher.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double StepperAmplitude { get; set; }
Public Property StepperAmplitude As Double
    Get
    Set
public:
property double StepperAmplitude {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis_TuningParams Methods

The KM_AxisKM_Axis_TuningParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetIIR0 | Set or get IIR Z domain servo filter #0
Public method | SetIIR1 | Set or get IIR Z domain servo filter #1
Public method | SetIIR2 | Set or get IIR Z domain servo filter #2
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SetIIR0 Method

KM_AxisKM_Axis_TuningParamsSetIIR0 Method

Set or get IIR Z domain servo filter #0

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetIIR0(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)
Public Sub SetIIR0 (
    p1 As Double,
    p2 As Double,
    p3 As Double,
    p4 As Double,
    p5 As Double
)
public:
void SetIIR0(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)

Parameters

p1 Double
A1 Coefficient
p2 Double
A2 Coefficient
p3 Double
B0 Coefficient
p4 Double
B1 Coefficient
p5 Double
B2 Coefficient
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SetIIR1 Method

KM_AxisKM_Axis_TuningParamsSetIIR1 Method

Set or get IIR Z domain servo filter #1

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetIIR1(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)
Public Sub SetIIR1 (
    p1 As Double,
    p2 As Double,
    p3 As Double,
    p4 As Double,
    p5 As Double
)
public:
void SetIIR1(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)

Parameters

p1 Double
A1 Coefficient
p2 Double
A2 Coefficient
p3 Double
B0 Coefficient
p4 Double
B1 Coefficient
p5 Double
B2 Coefficient
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams.SetIIR2 Method

KM_AxisKM_Axis_TuningParamsSetIIR2 Method

Set or get IIR Z domain servo filter #2

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetIIR2(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)
Public Sub SetIIR2 (
    p1 As Double,
    p2 As Double,
    p3 As Double,
    p4 As Double,
    p5 As Double
)
public:
void SetIIR2(
    double p1,
    double p2,
    double p3,
    double p4,
    double p5
)

Parameters

p1 Double
A1 Coefficient
p2 Double
A2 Coefficient
p3 Double
B0 Coefficient
p4 Double
B1 Coefficient
p5 Double
B2 Coefficient
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis_TuningParams Fields

The KM_AxisKM_Axis_TuningParams type exposes the following members.

Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _ID | Axis Channel Number Valid range = ( 0 - 7 )
Top
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams._Controller Field

KM_AxisKM_Axis_TuningParams_Controller Field

KM_Controller Object for used for device access

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_Controller _Controller
Protected _Controller As KM_Controller
protected:
KM_Controller^ _Controller

Field Value

KM_Controller
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_Axis.KM_Axis_TuningParams._ID Field

KM_AxisKM_Axis_TuningParams_ID Field

Axis Channel Number Valid range = ( 0 - 7 )

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int _ID
Protected _ID As Integer
protected:
int _ID

Field Value

Int32
See Also

Reference

KM_AxisKM_Axis_TuningParams Class


KM_AxisGroup Class

KM_Controller Object for grouping Axis channels
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_AxisGroup

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_AxisGroup
Public Class KM_AxisGroup
public ref class KM_AxisGroup

The KM_AxisGroup type exposes the following members.

Constructors
 | Name | Description
Public method | KM_AxisGroup | Creates group of axes
Top
Properties
 | Name | Description
Public property | AxisList | Axis objects that the group is comprised of
Public property | BreakAngle | Trajectory Planner Break Angle, larger angles require full stop
Public property | CollinearTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Public property | CornerTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Public property | FacetAngle | Trajectory Planner angles to be used when corner rounding
Public property | FeedRate | Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)
Public property | FeedRateOverride | Coordinated Motion Feed Rate Setting Multiplier
Public property | ID | Axis C is in Degrees
Public property | IsAborted | Coordinated Motion Abort State
Public property | IsHalted | Coordinated Motion Halt State
Public property | LookAhead | Trajectory Planner Lookahead/buffer time
Public property | MaxLength | Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)
Public property | Name | Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...
Public property | PreviousStopped | Get/Set Previous Stopped after Halt State
Public property | RapidParamsDirty | Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna
Public property | Simulate | Get/Set Coordinated Motion Simulation Mode
Top
Methods
 | Name | Description
Public method | Abort | Abort any Coordinated Motion
Public method | AddArc(Double, Double, Double, Double, Boolean, Double) | Perform Coordinated Arc Move of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double) | Perform Coordinated Arc Move (in specified plane - replace xyz as appropriate) of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double, Double, Double, Double) | Perform Coordinated Arc Move (in specified plane) of multiple axis to a desired destination with aditional a,b,c, axes linearly interpolated
Public method | AddCommand | Insert special embedded IO commaand into the Coordinated moition buffer
Public method | AddLine | Add a linear motion to the coordinated motion buffer
Public method | ClearAbort | Clear any Coordinated Motion Abort condition
Public method | ClearHalt | Clear any Coordinated Motion Halt condition
Public method | CompletePath | Finalize any motion that resides in the coordinated motion buffer
Public method | DisableGroup | Abort and disable an entire coordinated group
Public method | EnableGroup | Define, configure, and enable an axis group
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt any Coordinated Motion
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MotionComplete | Checks if the commanded axis group motion is completed
Public method | RapidTo | Perform Rapid Move (independent motion) of multiple axis to a desired destination and wait until motion is completed
Public method | RunGcodeFile | Launch GCode Interpreter executing specified GCode file
Public method | RunGcodeFileSegment | Launch GCode Interpreter executing specified GCode file
Public method | SetMCodeAction | Specifies a specific M Code action to be performed for a encountered MCodeSet. Parameters and data are specific to the action type
Public method | SetOffsetData | Set Work Fixture Offset to be used by the GCode Interpreter
Public method | SetParamsFile | Set Params File name to be used by the GCode Interpreter
Public method | SetToolFile | Set Tool File name to be used by the GCode Interpreter
Public method | SetToolTableEntry | Set Tool Table Entry to be used by the GCode Interpreter
Public method | StartPath | Flush/clear coordinated motion buffer and wait for any rapids to complete
Public method | StartRapidTo | Perform Start of Rapid Move (independent motion) of multiple axis to a desired destination
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitforMotionComplete | Blocks the calling thread until the axis group is in position within a specified time limit
Top
Fields
 | Name | Description
Protected field | _ArcsToSegs | Causes Arcs to be converted to segments (Kinematic Setting)
Protected field | _AxisList | Axis objects that the group is comprised of
Protected field | _BreakAngle | Trajectory Planner Break Angle, larger angles require full stop
Protected field | _CollinearTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _CornerTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Protected field | _DegreesA | Causes Arcs to be converted to segments (User Setting)
Protected field | _DegreesB | Axis A is in Degrees
Protected field | _DegreesC | Axis B is in Degrees
Protected field | _FacetAngle | Trajectory Planner angles to be used when corner rounding
Protected field | _FeedRate | Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)
Protected field | _ID | Axis Group Number
Protected field | _LookAhead | Trajectory Planner Plan/Look ahead in seconds
Protected field | _MaxLength | Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)
Protected field | _Name | Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...
Protected field | _UseOnlyLinearSegments | Axis Group Number
Top
See Also

Reference

KMotion_dotNet Namespace


KM_AxisGroup Constructor

Creates group of axes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_AxisGroup(
    KM_Controller controller,
    params KM_Axis[] axislist
)
Public Sub New (
    controller As KM_Controller,
    ParamArray axislist As KM_Axis()
)
public:
KM_AxisGroup(
    KM_Controller^ controller,
    ... array<KM_Axis^>^ axislist
)

Parameters

controller KM_Controller
KM_Controller to associate the group with
axislist KM_Axis
List of Axes
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup Properties

The KM_AxisGroup type exposes the following members.

Properties
 | Name | Description
Public property | AxisList | Axis objects that the group is comprised of
Public property | BreakAngle | Trajectory Planner Break Angle, larger angles require full stop
Public property | CollinearTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Public property | CornerTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Public property | FacetAngle | Trajectory Planner angles to be used when corner rounding
Public property | FeedRate | Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)
Public property | FeedRateOverride | Coordinated Motion Feed Rate Setting Multiplier
Public property | ID | Axis C is in Degrees
Public property | IsAborted | Coordinated Motion Abort State
Public property | IsHalted | Coordinated Motion Halt State
Public property | LookAhead | Trajectory Planner Lookahead/buffer time
Public property | MaxLength | Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)
Public property | Name | Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...
Public property | PreviousStopped | Get/Set Previous Stopped after Halt State
Public property | RapidParamsDirty | Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna
Public property | Simulate | Get/Set Coordinated Motion Simulation Mode
Top
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.AxisList Property

KM_AxisGroupAxisList Property

Axis objects that the group is comprised of

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public List<KM_Axis> AxisList { get; set; }
Public Property AxisList As List(Of KM_Axis)
    Get
    Set
public:
property List<KM_Axis^>^ AxisList {
    List<KM_Axis^>^ get ();
    void set (List<KM_Axis^>^ value);
}

Property Value

List KM_Axis
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.BreakAngle Property

KM_AxisGroupBreakAngle Property

Trajectory Planner Break Angle, larger angles require full stop

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double BreakAngle { get; set; }
Public Property BreakAngle As Double
    Get
    Set
public:
property double BreakAngle {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.CollinearTolerance Property

KM_AxisGroupCollinearTolerance Property

Trajectory Planner Collinear tolerance at which in-line segments can be combined

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CollinearTolerance { get; set; }
Public Property CollinearTolerance As Double
    Get
    Set
public:
property double CollinearTolerance {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.CornerTolerance Property

KM_AxisGroupCornerTolerance Property

Trajectory Planner Collinear tolerance at which in-line segments can be combined

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CornerTolerance { get; set; }
Public Property CornerTolerance As Double
    Get
    Set
public:
property double CornerTolerance {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.FacetAngle Property

KM_AxisGroupFacetAngle Property

Trajectory Planner angles to be used when corner rounding

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FacetAngle { get; set; }
Public Property FacetAngle As Double
    Get
    Set
public:
property double FacetAngle {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.FeedRate Property

KM_AxisGroupFeedRate Property

Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FeedRate { get; set; }
Public Property FeedRate As Double
    Get
    Set
public:
property double FeedRate {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.FeedRateOverride Property

KM_AxisGroupFeedRateOverride Property

Coordinated Motion Feed Rate Setting Multiplier

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FeedRateOverride { get; set; }
Public Property FeedRateOverride As Double
    Get
    Set
public:
property double FeedRateOverride {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.ID Property

KM_AxisGroupID Property

Axis C is in Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.IsAborted Property

KM_AxisGroupIsAborted Property

Coordinated Motion Abort State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsAborted { get; }
Public ReadOnly Property IsAborted As Boolean
    Get
public:
property bool IsAborted {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.IsHalted Property

KM_AxisGroupIsHalted Property

Coordinated Motion Halt State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsHalted { get; }
Public ReadOnly Property IsHalted As Boolean
    Get
public:
property bool IsHalted {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.LookAhead Property

KM_AxisGroupLookAhead Property

Trajectory Planner Lookahead/buffer time

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double LookAhead { get; set; }
Public Property LookAhead As Double
    Get
    Set
public:
property double LookAhead {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.MaxLength Property

KM_AxisGroupMaxLength Property

Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxLength { get; set; }
Public Property MaxLength As Double
    Get
    Set
public:
property double MaxLength {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.Name Property

KM_AxisGroupName Property

Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.PreviousStopped Property

KM_AxisGroupPreviousStopped Property

Get/Set Previous Stopped after Halt State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public PREV_STOP_TYPE PreviousStopped { get; set; }
Public Property PreviousStopped As PREV_STOP_TYPE
    Get
    Set
public:
property PREV_STOP_TYPE PreviousStopped {
    PREV_STOP_TYPE get ();
    void set (PREV_STOP_TYPE value);
}

Property Value

PREV_STOP_TYPE
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.RapidParamsDirty Property

KM_AxisGroupRapidParamsDirty Property

Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool RapidParamsDirty { get; set; }
Public Property RapidParamsDirty As Boolean
    Get
    Set
public:
property bool RapidParamsDirty {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.Simulate Property

KM_AxisGroupSimulate Property

Get/Set Coordinated Motion Simulation Mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool Simulate { get; set; }
Public Property Simulate As Boolean
    Get
    Set
public:
property bool Simulate {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup Methods

The KM_AxisGroup type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Abort any Coordinated Motion
Public method | AddArc(Double, Double, Double, Double, Boolean, Double) | Perform Coordinated Arc Move of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double) | Perform Coordinated Arc Move (in specified plane - replace xyz as appropriate) of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double, Double, Double, Double) | Perform Coordinated Arc Move (in specified plane) of multiple axis to a desired destination with aditional a,b,c, axes linearly interpolated
Public method | AddCommand | Insert special embedded IO commaand into the Coordinated moition buffer
Public method | AddLine | Add a linear motion to the coordinated motion buffer
Public method | ClearAbort | Clear any Coordinated Motion Abort condition
Public method | ClearHalt | Clear any Coordinated Motion Halt condition
Public method | CompletePath | Finalize any motion that resides in the coordinated motion buffer
Public method | DisableGroup | Abort and disable an entire coordinated group
Public method | EnableGroup | Define, configure, and enable an axis group
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt any Coordinated Motion
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | MotionComplete | Checks if the commanded axis group motion is completed
Public method | RapidTo | Perform Rapid Move (independent motion) of multiple axis to a desired destination and wait until motion is completed
Public method | RunGcodeFile | Launch GCode Interpreter executing specified GCode file
Public method | RunGcodeFileSegment | Launch GCode Interpreter executing specified GCode file
Public method | SetMCodeAction | Specifies a specific M Code action to be performed for a encountered MCodeSet. Parameters and data are specific to the action type
Public method | SetOffsetData | Set Work Fixture Offset to be used by the GCode Interpreter
Public method | SetParamsFile | Set Params File name to be used by the GCode Interpreter
Public method | SetToolFile | Set Tool File name to be used by the GCode Interpreter
Public method | SetToolTableEntry | Set Tool Table Entry to be used by the GCode Interpreter
Public method | StartPath | Flush/clear coordinated motion buffer and wait for any rapids to complete
Public method | StartRapidTo | Perform Start of Rapid Move (independent motion) of multiple axis to a desired destination
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitforMotionComplete | Blocks the calling thread until the axis group is in position within a specified time limit
Top
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.Abort Method

KM_AxisGroupAbort Method

Abort any Coordinated Motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Abort()
Public Sub Abort
public:
void Abort()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.AddArc Method

KM_AxisGroupAddArc Method

Overload List
 | Name | Description
Public method | AddArc(Double, Double, Double, Double, Boolean, Double) | Perform Coordinated Arc Move of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double) | Perform Coordinated Arc Move (in specified plane - replace xyz as appropriate) of multiple axis to a desired destination
Public method | AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double, Double, Double, Double) | Perform Coordinated Arc Move (in specified plane) of multiple axis to a desired destination with aditional a,b,c, axes linearly interpolated
Top
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.AddArc(Double, Double, Double, Double, Boolean, Double) Method

KM_AxisGroupAddArc(Double, Double, Double, Double, Boolean, Double) Method

Perform Coordinated Arc Move of multiple axis to a desired destination

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    bool clockwise,
    double finalz
)
Public Sub AddArc (
    endx As Double,
    endy As Double,
    centerx As Double,
    centery As Double,
    clockwise As Boolean,
    finalz As Double
)
public:
void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    bool clockwise,
    double finalz
)

Parameters

endx Double
X end point of arc
endy Double
Y end point of arc
centerx Double
X center of rotation of arc
centery Double
Y center of rotation of arc
clockwise Boolean
CW or ACW
finalz Double
End point of perpindicular axis(for helical motion)
See Also

Reference

KM_AxisGroup Class
AddArc Overload


KM_AxisGroup.AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double) Method

KM_AxisGroupAddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double) Method

Perform Coordinated Arc Move (in specified plane - replace xyz as appropriate) of multiple axis to a desired destination

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    CANON_PLANE plane,
    bool clockwise,
    double finalz
)
Public Sub AddArc (
    endx As Double,
    endy As Double,
    centerx As Double,
    centery As Double,
    plane As CANON_PLANE,
    clockwise As Boolean,
    finalz As Double
)
public:
void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    CANON_PLANE plane,
    bool clockwise,
    double finalz
)

Parameters

endx Double
X end point of arc
endy Double
Y end point of arc
centerx Double
X center of rotation of arc
centery Double
Y center of rotation of arc
plane CANON_PLANE
CANON_PLANE of arc
clockwise Boolean
CW or ACW
finalz Double
End point of perpindicular axis(for helical motion)
See Also

Reference

KM_AxisGroup Class
AddArc Overload


KM_AxisGroup.AddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double, Double, Double, Double) Method

KM_AxisGroupAddArc(Double, Double, Double, Double, CANON_PLANE, Boolean, Double, Double, Double, Double) Method

Perform Coordinated Arc Move (in specified plane) of multiple axis to a desired destination with aditional a,b,c, axes linearly interpolated

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    CANON_PLANE plane,
    bool clockwise,
    double finalz,
    double a,
    double b,
    double c
)
Public Sub AddArc (
    endx As Double,
    endy As Double,
    centerx As Double,
    centery As Double,
    plane As CANON_PLANE,
    clockwise As Boolean,
    finalz As Double,
    a As Double,
    b As Double,
    c As Double
)
public:
void AddArc(
    double endx,
    double endy,
    double centerx,
    double centery,
    CANON_PLANE plane,
    bool clockwise,
    double finalz,
    double a,
    double b,
    double c
)

Parameters

endx Double
X end point of arc
endy Double
Y end point of arc
centerx Double
X center of rotation of arc
centery Double
Y center of rotation of arc
plane CANON_PLANE
CANON_PLANE of arc
clockwise Boolean
CW or ACW
finalz Double
End point of perpindicular axis(for helical motion)
a Double
a Axis final position
b Double
b Axis final position
c Double
c Axis final position
See Also

Reference

KM_AxisGroup Class
AddArc Overload


KM_AxisGroup.AddCommand Method

KM_AxisGroupAddCommand Method

Insert special embedded IO commaand into the Coordinated moition buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void AddCommand(
    int command
)
Public Sub AddCommand (
    command As Integer
)
public:
void AddCommand(
    int command
)

Parameters

command Int32
index of command to be added
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.AddLine Method

KM_AxisGroupAddLine Method

Add a linear motion to the coordinated motion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void AddLine(
    double[] nextpoint
)
Public Sub AddLine (
    nextpoint As Double()
)
public:
void AddLine(
    array<double>^ nextpoint
)

Parameters

nextpoint Double
XYZABC point to feed to
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.ClearAbort Method

KM_AxisGroupClearAbort Method

Clear any Coordinated Motion Abort condition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearAbort()
Public Sub ClearAbort
public:
void ClearAbort()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.ClearHalt Method

KM_AxisGroupClearHalt Method

Clear any Coordinated Motion Halt condition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearHalt()
Public Sub ClearHalt
public:
void ClearHalt()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.CompletePath Method

KM_AxisGroupCompletePath Method

Finalize any motion that resides in the coordinated motion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void CompletePath()
Public Sub CompletePath
public:
void CompletePath()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.DisableGroup Method

KM_AxisGroupDisableGroup Method

Abort and disable an entire coordinated group

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DisableGroup()
Public Sub DisableGroup
public:
void DisableGroup()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.EnableGroup Method

KM_AxisGroupEnableGroup Method

Define, configure, and enable an axis group

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void EnableGroup()
Public Sub EnableGroup
public:
void EnableGroup()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.Halt Method

KM_AxisGroupHalt Method

Halt any Coordinated Motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Halt()
Public Sub Halt
public:
void Halt()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.MotionComplete Method

KM_AxisGroupMotionComplete Method

Checks if the commanded axis group motion is completed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool MotionComplete()
Public Function MotionComplete As Boolean
public:
bool MotionComplete()

Return Value

Boolean
true if the axis is idle
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.RapidTo Method

KM_AxisGroupRapidTo Method

Perform Rapid Move (independent motion) of multiple axis to a desired destination and wait until motion is completed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void RapidTo(
    double[] position
)
Public Sub RapidTo (
    position As Double()
)
public:
void RapidTo(
    array<double>^ position
)

Parameters

position Double
XYZABC position to Rapid to
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.RunGcodeFile Method

KM_AxisGroupRunGcodeFile Method

Launch GCode Interpreter executing specified GCode file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void RunGcodeFile(
    string file
)
Public Sub RunGcodeFile (
    file As String
)
public:
void RunGcodeFile(
    String^ file
)

Parameters

file String
Gcode File Path
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.RunGcodeFileSegment Method

KM_AxisGroupRunGcodeFileSegment Method

Launch GCode Interpreter executing specified GCode file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void RunGcodeFileSegment(
    string file,
    int firstline,
    int lastline
)
Public Sub RunGcodeFileSegment (
    file As String,
    firstline As Integer,
    lastline As Integer
)
public:
void RunGcodeFileSegment(
    String^ file,
    int firstline,
    int lastline
)

Parameters

file String
Gcode File Path
firstline Int32
Gcode line number to start
lastline Int32
Gcode line number to stop
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.SetMCodeAction Method

KM_AxisGroupSetMCodeAction Method

Specifies a specific M Code action to be performed for a encountered MCodeSet. Parameters and data are specific to the action type

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetMCodeAction(
    int num,
    MCODE_TYPE type,
    double p1,
    double p2,
    double p3,
    double p4,
    double p5,
    string data
)
Public Sub SetMCodeAction (
    num As Integer,
    type As MCODE_TYPE,
    p1 As Double,
    p2 As Double,
    p3 As Double,
    p4 As Double,
    p5 As Double,
    data As String
)
public:
void SetMCodeAction(
    int num,
    MCODE_TYPE type,
    double p1,
    double p2,
    double p3,
    double p4,
    double p5,
    String^ data
)

Parameters

num Int32
MCode Mapping Number
type MCODE_TYPE
type of action to be performed
p1 Double
parameter #1
p2 Double
parameter #3
p3 Double
parameter #3
p4 Double
parameter #4
p5 Double
parameter #5
data String
string parameter - typically a file name
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.SetOffsetData Method

KM_AxisGroupSetOffsetData Method

Set Work Fixture Offset to be used by the GCode Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetOffsetData(
    int num,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c
)
Public Sub SetOffsetData (
    num As Integer,
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double
)
public:
void SetOffsetData(
    int num,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c
)

Parameters

num Int32
Fixture Number
x Double
x offset
y Double
y offset
z Double
z offset
a Double
a offset
b Double
b offset
c Double
c offset
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.SetParamsFile Method

KM_AxisGroupSetParamsFile Method

Set Params File name to be used by the GCode Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetParamsFile(
    string paramsfile
)
Public Sub SetParamsFile (
    paramsfile As String
)
public:
void SetParamsFile(
    String^ paramsfile
)

Parameters

paramsfile String
Params File Path String
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.SetToolFile Method

KM_AxisGroupSetToolFile Method

Set Tool File name to be used by the GCode Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetToolFile(
    string toolFile
)
Public Sub SetToolFile (
    toolFile As String
)
public:
void SetToolFile(
    String^ toolFile
)

Parameters

toolFile String
Tool File Path String
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.SetToolTableEntry Method

KM_AxisGroupSetToolTableEntry Method

Set Tool Table Entry to be used by the GCode Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetToolTableEntry(
    int index,
    int slot,
    int ID,
    double length,
    double diameter,
    double xoffset,
    double yoffset
)
Public Sub SetToolTableEntry (
    index As Integer,
    slot As Integer,
    ID As Integer,
    length As Double,
    diameter As Double,
    xoffset As Double,
    yoffset As Double
)
public:
void SetToolTableEntry(
    int index,
    int slot,
    int ID,
    double length,
    double diameter,
    double xoffset,
    double yoffset
)

Parameters

index Int32
Tool Table Index Number
slot Int32
Tool changer 2 digit slot Number
ID Int32
Tool 4 digit ID Number
length Double
Tool length offset
diameter Double
Tool diameter used in radius compensation
xoffset Double
Tool X Offset
yoffset Double
Tool Y Offset
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.StartPath Method

KM_AxisGroupStartPath Method

Flush/clear coordinated motion buffer and wait for any rapids to complete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartPath()
Public Sub StartPath
public:
void StartPath()
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.StartRapidTo Method

KM_AxisGroupStartRapidTo Method

Perform Start of Rapid Move (independent motion) of multiple axis to a desired destination

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartRapidTo(
    double[] position
)
Public Sub StartRapidTo (
    position As Double()
)
public:
void StartRapidTo(
    array<double>^ position
)

Parameters

position Double
XYZABC position to Rapid to
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup.WaitforMotionComplete Method

KM_AxisGroupWaitforMotionComplete Method

Blocks the calling thread until the axis group is in position within a specified time limit

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool WaitforMotionComplete(
    int timeout
)
Public Function WaitforMotionComplete (
    timeout As Integer
) As Boolean
public:
bool WaitforMotionComplete(
    int timeout
)

Parameters

timeout Int32
time in ms to wait for axis group to acheive position, 0 will wait indefinitely

Return Value

Boolean
true if completed
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup Fields

The KM_AxisGroup type exposes the following members.

Fields
 | Name | Description
Protected field | _ArcsToSegs | Causes Arcs to be converted to segments (Kinematic Setting)
Protected field | _AxisList | Axis objects that the group is comprised of
Protected field | _BreakAngle | Trajectory Planner Break Angle, larger angles require full stop
Protected field | _CollinearTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _CornerTolerance | Trajectory Planner Collinear tolerance at which in-line segments can be combined
Protected field | _DegreesA | Causes Arcs to be converted to segments (User Setting)
Protected field | _DegreesB | Axis A is in Degrees
Protected field | _DegreesC | Axis B is in Degrees
Protected field | _FacetAngle | Trajectory Planner angles to be used when corner rounding
Protected field | _FeedRate | Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)
Protected field | _ID | Axis Group Number
Protected field | _LookAhead | Trajectory Planner Plan/Look ahead in seconds
Protected field | _MaxLength | Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)
Protected field | _Name | Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...
Protected field | _UseOnlyLinearSegments | Axis Group Number
Top
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._ArcsToSegs Field

KM_AxisGroup_ArcsToSegs Field

Causes Arcs to be converted to segments (Kinematic Setting)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _ArcsToSegs
Protected _ArcsToSegs As Boolean
protected:
bool _ArcsToSegs

Field Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._AxisList Field

KM_AxisGroup_AxisList Field

Axis objects that the group is comprised of

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected List<KM_Axis> _AxisList
Protected _AxisList As List(Of KM_Axis)
protected:
List<KM_Axis^>^ _AxisList

Field Value

List KM_Axis
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._BreakAngle Field

KM_AxisGroup_BreakAngle Field

Trajectory Planner Break Angle, larger angles require full stop

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _BreakAngle
Protected _BreakAngle As Double
protected:
double _BreakAngle

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._CollinearTolerance Field

KM_AxisGroup_CollinearTolerance Field

Trajectory Planner Collinear tolerance at which in-line segments can be combined

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _CollinearTolerance
Protected _CollinearTolerance As Double
protected:
double _CollinearTolerance

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._Controller Field

KM_AxisGroup_Controller Field

KM_Controller Object for used for device access

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_Controller _Controller
Protected _Controller As KM_Controller
protected:
KM_Controller^ _Controller

Field Value

KM_Controller
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._CornerTolerance Field

KM_AxisGroup_CornerTolerance Field

Trajectory Planner Collinear tolerance at which in-line segments can be combined

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _CornerTolerance
Protected _CornerTolerance As Double
protected:
double _CornerTolerance

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._DegreesA Field

KM_AxisGroup_DegreesA Field

Causes Arcs to be converted to segments (User Setting)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _DegreesA
Protected _DegreesA As Boolean
protected:
bool _DegreesA

Field Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._DegreesB Field

KM_AxisGroup_DegreesB Field

Axis A is in Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _DegreesB
Protected _DegreesB As Boolean
protected:
bool _DegreesB

Field Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._DegreesC Field

KM_AxisGroup_DegreesC Field

Axis B is in Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _DegreesC
Protected _DegreesC As Boolean
protected:
bool _DegreesC

Field Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._FacetAngle Field

KM_AxisGroup_FacetAngle Field

Trajectory Planner angles to be used when corner rounding

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _FacetAngle
Protected _FacetAngle As Double
protected:
double _FacetAngle

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._FeedRate Field

KM_AxisGroup_FeedRate Field

Desired FeedRate in inches/sec for coordinated motion Feeds (G1,G2,G3)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _FeedRate
Protected _FeedRate As Double
protected:
double _FeedRate

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._ID Field

KM_AxisGroup_ID Field

Axis Group Number

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int _ID
Protected _ID As Integer
protected:
int _ID

Field Value

Int32
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._LookAhead Field

KM_AxisGroup_LookAhead Field

Trajectory Planner Plan/Look ahead in seconds

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _LookAhead
Protected _LookAhead As Double
protected:
double _LookAhead

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._MaxLength Field

KM_AxisGroup_MaxLength Field

Trajectory Planner max allowed length for individual segments (long linear segments can cause cord errors in non-linear systems)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double _MaxLength
Protected _MaxLength As Double
protected:
double _MaxLength

Field Value

Double
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._Name Field

KM_AxisGroup_Name Field

Call Name Use to describe what the Axis Group controls i.e. Spindle 1 Carriage, Wrist, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected string _Name
Protected _Name As String
protected:
String^ _Name

Field Value

String
See Also

Reference

KM_AxisGroup Class


KM_AxisGroup._UseOnlyLinearSegments Field

KM_AxisGroup_UseOnlyLinearSegments Field

Axis Group Number

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _UseOnlyLinearSegments
Protected _UseOnlyLinearSegments As Boolean
protected:
bool _UseOnlyLinearSegments

Field Value

Boolean
See Also

Reference

KM_AxisGroup Class


KM_Controller Class

This is the primary object for interfacing with a Dynomotion product in code You can think of this object as representing the board and an access point for features of the hardware There should only be one KM_Controller object per board, per application domain at any given time To set project to update the GAC: "$(FrameworkSdkDir)\bin\gacutil.exe" /i "$(TargetPath)" /f
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_Controller

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Controller : IDisposable
Public Class KM_Controller
    Implements IDisposable
public ref class KM_Controller : IDisposable

The KM_Controller type exposes the following members.

Constructors
 | Name | Description
Public method | KM_Controller(Boolean) | Default constructor for the KM_Controller object Use this for single board applications
Public method | KM_Controller(Int32, Boolean) | Multiple board constructor for attaching this object to a specific board address
Top
Properties
 | Name | Description
Public property | BoardID | Board USB ID
Public property | BoardNumber | Board number (for use in multiple board scenarios)
Public property | BoardType | Dynomotion board device type
Public property | CoordMotion | Coordinated Motion Component
Public property | CurrentStatus | Locally maintained Main_Status struct
Public property | ErrorLog | Contains all error messages until cleared
Public property | InstanceHandle | KMotion_DLL class instance pointer
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | LockStatusOnUpdate | Flags whether to obtain a lock token while gathering the status data
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | MessageLog | Contains all messages until cleared
Public property | StatusUpdateInterval | Maximum time in ms between refreshing the status
Public property | ThrowExceptions | If this flag is true, exceptions will be generated from the ErrorMsg handler
Top
Methods
 | Name | Description
Public method | CheckCoffSize | Determines and returns the section sizes of various sections in a KFLOP coff (common object file format) file
Public method | CheckConnected | Tries to obtain a lock, and if a lock is obtained can execute optional actions before releasing the lock token.
Public method | CheckIsReady | Call this to check if a "Ready" response came back after a command was manually typed in and we don't know what the response will be if any Note:There is a possibility that other DSP threads are printing to the console screen First check if any input is available if not, return instantly (KMOTION_OK) if so, then a whole line might not be available but should be in transmission and be in very soon, so wait up to a short while to get in an entire line if the line doesn't come in for some reason return (KMOTION_TIMEOUT) check if the line should go to the console (esc) if so print it and repeat the above as long as there is still input available if the line is not console data, check for "Ready", if it is "Ready" send it to the console and return KMOTION_READY; otherwise send it to the console ///
Public method | ClearError | Clears the Error log
Public method | ClearFeedhold | Clears Feedhold without Resuming(Performs Console Command StopImmediate2)
Public method | ClearMessages | Clears the Message log
Public method | Compile | Compiles a source file
Public method | CompileAndLoadCoff | Compiles a source file and loads it into the board
Public method | Disconnect | Disconnect the application from the board
Public method | Dispose | Releases object resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecuteProgram(Int32) | Executes a previously loaded program
Public method | ExecuteProgram(Int32, String, Boolean) | Loads and executes a program from file
Public method | Feedhold | Initiates Feedhold (Performs Console Command StopImmediate0)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAxis | Creates a KM_Axis object
Public method | GetAxisGroup | Creates a KM_AxisGroup
Public method | GetBoards | Get Boards checks the list of connected board locations and returns the total board count
Public method | GetBoardType | Gets the board type BOARD_TYPE.KFLOP = 2 = KFlop 8 Axes Controller BOARD_TYPE.KOGNA = 3 = Kogna 16 Axis Controller
Public method | GetCommandValueT | Returns the value of a WriteLineReadLine(), converted to the requested type
Public method | GetFirmwareVersion | Query device for the loaded firmware version
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIO | Creates a new KM_IO bit
Public method | GetStatus | Generates and returns an updated copy of the MAIN_STATUS structure
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUSBLocation | USB tree node location
Public method | GetUserData | Gets a 32 bit word of user data To set int value in KFLOP in C do: persist.UserData[index] = i;
Public method | GetUserDataDouble | Gets a 64 bit double from a KFLOP user data pair of 32 bit vars To set double value in KFLOP in C do: *(double *)&persist.UserData[index*2] = d;
Public method | GetUserDataFloat | Gets a 32 bit float word of user data To set float value in KFLOP in C do: *(float *)&persist.UserData[index] = f;
Public method | HasErrors | Checks if any error messages are in qeue
Public method | HasMessages | Checks if any messages are in qeue
Public method | KillProgramThreads | Halts the execution of each supplied thread
Public method | KMotionLock | Prevents outside access to the board This function is similar to the WaitToken function, except that it returns immediately (instead of waiting) if the board is already locked
Public method | LoadCoff(Int32, String) | Load a compiled C program into the board
Public method | LoadCoff(Int32, String, Int32) | Load a compiled C program into the board (with PackToFlash arg)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadLineTimeout | Block the calling thread while waiting for the response to complete within a specified timeout
Public method | RecoverKMotionLock | Recovers controller from a motion lock state
Public method | ReleaseToken | Allow normal access to the board
Public method | ResetUserData | Sets all words of user data to 0
Public method | ResumeFeedhold | Resumes Feedhold (Performs Console Command StopImmediate1)
Public method | ServiceConsole | Flushes the console buffer
Public method | SetCallbackHandler | Sets the internal c++ interop callback handler Separate delegate for this callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Public method | SetFailed | Places the controller in a failed state, prevents further commands from processing
Public method | SetUserData | Sets a 32 bit word of integer user data
Public method | SetUserDataDouble | Sets a pair of two 32 bit words with a 64-bit double of user data To get the value in KFLOP in C do: double f = *(double *)&persist.UserData[index*2];
Public method | SetUserDataFloat | Sets a 32 bit word with a 32-bit float of user data To get the value in KFLOP in C do: float f = *(float *)&persist.UserData[index];
Public method | ThreadExecuting | Checks whether a User Program Thread is currently executing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitForThreadComplete | Waits for a User Program Thread to finish executing.
Public method | WaitToken | Prevents outside access to the board until ReleaseToken is commanded
Public method | WriteLine | Sends a console command to the board
Public method | WriteLineReadLine | Sends a console command to the board and waits for the return value
Public method | WriteLineWithEcho | Sends a console command to the board while echoing commands back to the callback handler
Top
Events
 | Name | Description
Public event | ErrorReceived | Error Messages are routed through this event
Public event | MessageReceived | All general messages are pumped out from the internal callback handler thru this event
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Controller Constructor

Overload List
 | Name | Description
Public method | KM_Controller(Boolean) | Default constructor for the KM_Controller object Use this for single board applications
Public method | KM_Controller(Int32, Boolean) | Multiple board constructor for attaching this object to a specific board address
Top
See Also

Reference

KM_Controller Class


KM_Controller(Boolean) Constructor

Default constructor for the KM_Controller object Use this for single board applications

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Controller(
    bool DoNotObtainConsoleMessages = false
)
Public Sub New (
    Optional DoNotObtainConsoleMessages As Boolean = false
)
public:
KM_Controller(
    bool DoNotObtainConsoleMessages = false
)

Parameters

DoNotObtainConsoleMessages Boolean (Optional)
Set true if Console Messages should not be handled by this App Defaults to false.
See Also

Reference

KM_Controller Class
KM_Controller Overload


KM_Controller(Int32, Boolean) Constructor

Multiple board constructor for attaching this object to a specific board address

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Controller(
    int boardnumber,
    bool DoNotObtainConsoleMessages = false
)
Public Sub New (
    boardnumber As Integer,
    Optional DoNotObtainConsoleMessages As Boolean = false
)
public:
KM_Controller(
    int boardnumber,
    bool DoNotObtainConsoleMessages = false
)

Parameters

boardnumber Int32
device ID 0=any KFLOP/Kogna found less than or equal to 0x00FFFFFF assume USB Location ID greater than or equal to 0xFF00XXXX Kogna with Serial Number XXXX Otherwise assume Static IP Address ie. 0xC0A80A64 -> 192.168.10.100
DoNotObtainConsoleMessages Boolean (Optional)
Set true if Console Messages should not be handled by this App Defaults to false.
See Also

Reference

KM_Controller Class
KM_Controller Overload


KM_Controller Properties

The KM_Controller type exposes the following members.

Properties
 | Name | Description
Public property | BoardID | Board USB ID
Public property | BoardNumber | Board number (for use in multiple board scenarios)
Public property | BoardType | Dynomotion board device type
Public property | CoordMotion | Coordinated Motion Component
Public property | CurrentStatus | Locally maintained Main_Status struct
Public property | ErrorLog | Contains all error messages until cleared
Public property | InstanceHandle | KMotion_DLL class instance pointer
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | LockStatusOnUpdate | Flags whether to obtain a lock token while gathering the status data
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | MessageLog | Contains all messages until cleared
Public property | StatusUpdateInterval | Maximum time in ms between refreshing the status
Public property | ThrowExceptions | If this flag is true, exceptions will be generated from the ErrorMsg handler
Top
See Also

Reference

KM_Controller Class


KM_Controller.BoardID Property

KM_ControllerBoardID Property

Board USB ID

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BoardID { get; set; }
Public Property BoardID As Integer
    Get
    Set
public:
property int BoardID {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Controller Class


KM_Controller.BoardNumber Property

KM_ControllerBoardNumber Property

Board number (for use in multiple board scenarios)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BoardNumber { get; set; }
Public Property BoardNumber As Integer
    Get
    Set
public:
property int BoardNumber {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Controller Class


KM_Controller.BoardType Property

KM_ControllerBoardType Property

Dynomotion board device type

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public BOARD_TYPE BoardType { get; set; }
Public Property BoardType As BOARD_TYPE
    Get
    Set
public:
property BOARD_TYPE BoardType {
    BOARD_TYPE get ();
    void set (BOARD_TYPE value);
}

Property Value

BOARD_TYPE
See Also

Reference

KM_Controller Class


KM_Controller.CoordMotion Property

KM_ControllerCoordMotion Property

Coordinated Motion Component

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_CoordMotion CoordMotion { get; set; }
Public Property CoordMotion As KM_CoordMotion
    Get
    Set
public:
property KM_CoordMotion^ CoordMotion {
    KM_CoordMotion^ get ();
    void set (KM_CoordMotion^ value);
}

Property Value

KM_CoordMotion
See Also

Reference

KM_Controller Class


KM_Controller.CurrentStatus Property

KM_ControllerCurrentStatus Property

Locally maintained Main_Status struct

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_MainStatus CurrentStatus { get; }
Public ReadOnly Property CurrentStatus As KM_MainStatus
    Get
public:
property KM_MainStatus CurrentStatus {
    KM_MainStatus get ();
}

Property Value

KM_MainStatus
See Also

Reference

KM_Controller Class


KM_Controller.ErrorLog Property

KM_ControllerErrorLog Property

Contains all error messages until cleared

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string ErrorLog { get; set; }
Public Property ErrorLog As String
    Get
    Set
public:
property String^ ErrorLog {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Controller Class


KM_Controller.InstanceHandle Property

KM_ControllerInstanceHandle Property

KMotion_DLL class instance pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public IntPtr InstanceHandle { get; }
Public ReadOnly Property InstanceHandle As IntPtr
    Get
public:
property IntPtr InstanceHandle {
    IntPtr get ();
}

Property Value

IntPtr
See Also

Reference

KM_Controller Class


KM_Controller.Loaded Property

KM_ControllerLoaded Property

Flag to determine that this object has been properly initialized

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool Loaded { get; }
Public ReadOnly Property Loaded As Boolean
    Get
public:
property bool Loaded {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_Controller Class


KM_Controller.LockStatusOnUpdate Property

KM_ControllerLockStatusOnUpdate Property

Flags whether to obtain a lock token while gathering the status data

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool LockStatusOnUpdate { get; set; }
Public Property LockStatusOnUpdate As Boolean
    Get
    Set
public:
property bool LockStatusOnUpdate {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Controller Class


KM_Controller.MaxErrorLength Property

KM_ControllerMaxErrorLength Property

Maximum allowed return error string length

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int MaxErrorLength { get; set; }
Public Property MaxErrorLength As Integer
    Get
    Set
public:
property int MaxErrorLength {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Controller Class


KM_Controller.MessageLog Property

KM_ControllerMessageLog Property

Contains all messages until cleared

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string MessageLog { get; set; }
Public Property MessageLog As String
    Get
    Set
public:
property String^ MessageLog {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Controller Class


KM_Controller.StatusUpdateInterval Property

KM_ControllerStatusUpdateInterval Property

Maximum time in ms between refreshing the status

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int StatusUpdateInterval { get; set; }
Public Property StatusUpdateInterval As Integer
    Get
    Set
public:
property int StatusUpdateInterval {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Controller Class


KM_Controller.ThrowExceptions Property

KM_ControllerThrowExceptions Property

If this flag is true, exceptions will be generated from the ErrorMsg handler

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ThrowExceptions { get; set; }
Public Property ThrowExceptions As Boolean
    Get
    Set
public:
property bool ThrowExceptions {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Controller Class


KM_Controller Methods

The KM_Controller type exposes the following members.

Methods
 | Name | Description
Public method | CheckCoffSize | Determines and returns the section sizes of various sections in a KFLOP coff (common object file format) file
Public method | CheckConnected | Tries to obtain a lock, and if a lock is obtained can execute optional actions before releasing the lock token.
Public method | CheckIsReady | Call this to check if a "Ready" response came back after a command was manually typed in and we don't know what the response will be if any Note:There is a possibility that other DSP threads are printing to the console screen First check if any input is available if not, return instantly (KMOTION_OK) if so, then a whole line might not be available but should be in transmission and be in very soon, so wait up to a short while to get in an entire line if the line doesn't come in for some reason return (KMOTION_TIMEOUT) check if the line should go to the console (esc) if so print it and repeat the above as long as there is still input available if the line is not console data, check for "Ready", if it is "Ready" send it to the console and return KMOTION_READY; otherwise send it to the console ///
Public method | ClearError | Clears the Error log
Public method | ClearFeedhold | Clears Feedhold without Resuming(Performs Console Command StopImmediate2)
Public method | ClearMessages | Clears the Message log
Public method | Compile | Compiles a source file
Public method | CompileAndLoadCoff | Compiles a source file and loads it into the board
Public method | Disconnect | Disconnect the application from the board
Public method | Dispose | Releases object resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecuteProgram(Int32) | Executes a previously loaded program
Public method | ExecuteProgram(Int32, String, Boolean) | Loads and executes a program from file
Public method | Feedhold | Initiates Feedhold (Performs Console Command StopImmediate0)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAxis | Creates a KM_Axis object
Public method | GetAxisGroup | Creates a KM_AxisGroup
Public method | GetBoards | Get Boards checks the list of connected board locations and returns the total board count
Public method | GetBoardType | Gets the board type BOARD_TYPE.KFLOP = 2 = KFlop 8 Axes Controller BOARD_TYPE.KOGNA = 3 = Kogna 16 Axis Controller
Public method | GetCommandValueT | Returns the value of a WriteLineReadLine(), converted to the requested type
Public method | GetFirmwareVersion | Query device for the loaded firmware version
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIO | Creates a new KM_IO bit
Public method | GetStatus | Generates and returns an updated copy of the MAIN_STATUS structure
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUSBLocation | USB tree node location
Public method | GetUserData | Gets a 32 bit word of user data To set int value in KFLOP in C do: persist.UserData[index] = i;
Public method | GetUserDataDouble | Gets a 64 bit double from a KFLOP user data pair of 32 bit vars To set double value in KFLOP in C do: *(double *)&persist.UserData[index*2] = d;
Public method | GetUserDataFloat | Gets a 32 bit float word of user data To set float value in KFLOP in C do: *(float *)&persist.UserData[index] = f;
Public method | HasErrors | Checks if any error messages are in qeue
Public method | HasMessages | Checks if any messages are in qeue
Public method | KillProgramThreads | Halts the execution of each supplied thread
Public method | KMotionLock | Prevents outside access to the board This function is similar to the WaitToken function, except that it returns immediately (instead of waiting) if the board is already locked
Public method | LoadCoff(Int32, String) | Load a compiled C program into the board
Public method | LoadCoff(Int32, String, Int32) | Load a compiled C program into the board (with PackToFlash arg)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadLineTimeout | Block the calling thread while waiting for the response to complete within a specified timeout
Public method | RecoverKMotionLock | Recovers controller from a motion lock state
Public method | ReleaseToken | Allow normal access to the board
Public method | ResetUserData | Sets all words of user data to 0
Public method | ResumeFeedhold | Resumes Feedhold (Performs Console Command StopImmediate1)
Public method | ServiceConsole | Flushes the console buffer
Public method | SetCallbackHandler | Sets the internal c++ interop callback handler Separate delegate for this callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Public method | SetFailed | Places the controller in a failed state, prevents further commands from processing
Public method | SetUserData | Sets a 32 bit word of integer user data
Public method | SetUserDataDouble | Sets a pair of two 32 bit words with a 64-bit double of user data To get the value in KFLOP in C do: double f = *(double *)&persist.UserData[index*2];
Public method | SetUserDataFloat | Sets a 32 bit word with a 32-bit float of user data To get the value in KFLOP in C do: float f = *(float *)&persist.UserData[index];
Public method | ThreadExecuting | Checks whether a User Program Thread is currently executing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitForThreadComplete | Waits for a User Program Thread to finish executing.
Public method | WaitToken | Prevents outside access to the board until ReleaseToken is commanded
Public method | WriteLine | Sends a console command to the board
Public method | WriteLineReadLine | Sends a console command to the board and waits for the return value
Public method | WriteLineWithEcho | Sends a console command to the board while echoing commands back to the callback handler
Top
See Also

Reference

KM_Controller Class


KM_Controller.CheckCoffSize Method

KM_ControllerCheckCoffSize Method

Determines and returns the section sizes of various sections in a KFLOP coff (common object file format) file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int CheckCoffSize(
    string name,
    out int size_text,
    out int size_bss,
    out int size_data,
    out int size_total
)
Public Function CheckCoffSize (
    name As String,
    <OutAttribute> ByRef size_text As Integer,
    <OutAttribute> ByRef size_bss As Integer,
    <OutAttribute> ByRef size_data As Integer,
    <OutAttribute> ByRef size_total As Integer
) As Integer
public:
int CheckCoffSize(
    String^ name,
    [OutAttribute] int% size_text,
    [OutAttribute] int% size_bss,
    [OutAttribute] int% size_data,
    [OutAttribute] int% size_total
)

Parameters

name String
file name of KFLOP coff
size_text Int32
variable to return the text (code) size in bytes
size_bss Int32
variable to return the bss (global variables) size in bytes
size_data Int32
variable to return the data (global constants) size in bytes
size_total Int32
variable to return the total size of all 3 sections in bytes

Return Value

Int32
integer 0 if sucessful
See Also

Reference

KM_Controller Class


KM_Controller.CheckConnected Method

KM_ControllerCheckConnected Method

Tries to obtain a lock, and if a lock is obtained can execute optional actions before releasing the lock token.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool CheckConnected(
    params Action[] actions
)
Public Function CheckConnected (
    ParamArray actions As Action()
) As Boolean
public:
bool CheckConnected(
    ... array<Action^>^ actions
)

Parameters

actions Action
delegates to execute while the board is locked

Return Value

Boolean
true if the lock status was not KMOTION_TOKEN.KMOTION_NOT_CONNECTED
See Also

Reference

KM_Controller Class


KM_Controller.CheckIsReady Method

KM_ControllerCheckIsReady Method

Call this to check if a "Ready" response came back after a command was manually typed in and we don't know what the response will be if any Note:There is a possibility that other DSP threads are printing to the console screen First check if any input is available if not, return instantly (KMOTION_OK) if so, then a whole line might not be available but should be in transmission and be in very soon, so wait up to a short while to get in an entire line if the line doesn't come in for some reason return (KMOTION_TIMEOUT) check if the line should go to the console (esc) if so print it and repeat the above as long as there is still input available if the line is not console data, check for "Ready", if it is "Ready" send it to the console and return KMOTION_READY; otherwise send it to the console ///

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KMOTION_CHECK_READY CheckIsReady()
Public Function CheckIsReady As KMOTION_CHECK_READY
public:
KMOTION_CHECK_READY CheckIsReady()

Return Value

KMOTION_CHECK_READY
true if board has received "Ready"
See Also

Reference

KM_Controller Class


KM_Controller.ClearError Method

KM_ControllerClearError Method

Clears the Error log

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearError()
Public Sub ClearError
public:
void ClearError()
See Also

Reference

KM_Controller Class


KM_Controller.ClearFeedhold Method

KM_ControllerClearFeedhold Method

Clears Feedhold without Resuming(Performs Console Command StopImmediate2)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearFeedhold()
Public Sub ClearFeedhold
public:
void ClearFeedhold()
See Also

Reference

KM_Controller Class


KM_Controller.ClearMessages Method

KM_ControllerClearMessages Method

Clears the Message log

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearMessages()
Public Sub ClearMessages
public:
void ClearMessages()
See Also

Reference

KM_Controller Class


KM_Controller.Compile Method

KM_ControllerCompile Method

Compiles a source file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Compile(
    int thread,
    string programname
)
Public Function Compile (
    thread As Integer,
    programname As String
) As String
public:
String^ Compile(
    int thread,
    String^ programname
)

Parameters

thread Int32
thread address to load into
programname String
file name of the C program

Return Value

String
program output
See Also

Reference

KM_Controller Class


KM_Controller.CompileAndLoadCoff Method

KM_ControllerCompileAndLoadCoff Method

Compiles a source file and loads it into the board

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string CompileAndLoadCoff(
    int thread,
    string programname,
    bool bypasserror
)
Public Function CompileAndLoadCoff (
    thread As Integer,
    programname As String,
    bypasserror As Boolean
) As String
public:
String^ CompileAndLoadCoff(
    int thread,
    String^ programname,
    bool bypasserror
)

Parameters

thread Int32
thread address to load into
programname String
file name of the C program
bypasserror Boolean
determines whether to collect any error returns

Return Value

String
return message from the C program's execution, including any errors
See Also

Reference

KM_Controller Class


KM_Controller.Disconnect Method

KM_ControllerDisconnect Method

Disconnect the application from the board

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Disconnect()
Public Sub Disconnect
public:
void Disconnect()
See Also

Reference

KM_Controller Class


KM_Controller.Dispose Method

KM_ControllerDispose Method

Releases object resources

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

KM_Controller Class


KM_Controller.ExecuteProgram Method

KM_ControllerExecuteProgram Method

Overload List
 | Name | Description
Public method | ExecuteProgram(Int32) | Executes a previously loaded program
Public method | ExecuteProgram(Int32, String, Boolean) | Loads and executes a program from file
Top
See Also

Reference

KM_Controller Class


KM_Controller.ExecuteProgram(Int32) Method

KM_ControllerExecuteProgram(Int32) Method

Executes a previously loaded program

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ExecuteProgram(
    int thread
)
Public Sub ExecuteProgram (
    thread As Integer
)
public:
void ExecuteProgram(
    int thread
)

Parameters

thread Int32
program thread in the kflop to run
See Also

Reference

KM_Controller Class
ExecuteProgram Overload


KM_Controller.ExecuteProgram(Int32, String, Boolean) Method

KM_ControllerExecuteProgram(Int32, String, Boolean) Method

Loads and executes a program from file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string ExecuteProgram(
    int thread,
    string programname,
    bool bypasserror
)
Public Function ExecuteProgram (
    thread As Integer,
    programname As String,
    bypasserror As Boolean
) As String
public:
String^ ExecuteProgram(
    int thread,
    String^ programname,
    bool bypasserror
)

Parameters

thread Int32
program thread in the kflop to run
programname String
complete path to th .c file to execute
bypasserror Boolean
determines whether to collect any error returns

Return Value

String
compile data
See Also

Reference

KM_Controller Class
ExecuteProgram Overload


KM_Controller.Feedhold Method

KM_ControllerFeedhold Method

Initiates Feedhold (Performs Console Command StopImmediate0)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Feedhold()
Public Sub Feedhold
public:
void Feedhold()
See Also

Reference

KM_Controller Class


KM_Controller.GetAxis Method

KM_ControllerGetAxis Method

Creates a KM_Axis object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Axis GetAxis(
    int channel,
    string name
)
Public Function GetAxis (
    channel As Integer,
    name As String
) As KM_Axis
public:
KM_Axis^ GetAxis(
    int channel,
    String^ name
)

Parameters

channel Int32
KFLOP Axis Channel
name String
descriptive name

Return Value

KM_Axis
Created Axis
See Also

Reference

KM_Controller Class


KM_Controller.GetAxisGroup Method

KM_ControllerGetAxisGroup Method

Creates a KM_AxisGroup

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_AxisGroup GetAxisGroup(
    int id,
    string name,
    params KM_Axis[] axislist
)
Public Function GetAxisGroup (
    id As Integer,
    name As String,
    ParamArray axislist As KM_Axis()
) As KM_AxisGroup
public:
KM_AxisGroup^ GetAxisGroup(
    int id,
    String^ name,
    ... array<KM_Axis^>^ axislist
)

Parameters

id Int32
integer id
name String
descriptive name
axislist KM_Axis
List of KM_Axis to place in the group

Return Value

KM_AxisGroup
Created KM_AxisGroup
See Also

Reference

KM_Controller Class


KM_Controller.GetBoards Method

KM_ControllerGetBoards Method

Get Boards checks the list of connected board locations and returns the total board count

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] GetBoards(
    out int numberofboards
)
Public Function GetBoards (
    <OutAttribute> ByRef numberofboards As Integer
) As Integer()
public:
array<int>^ GetBoards(
    [OutAttribute] int% numberofboards
)

Parameters

numberofboards Int32
returned total board count

Return Value

Int32
array of USB locations for all boards
See Also

Reference

KM_Controller Class


KM_Controller.GetBoardType Method

KM_ControllerGetBoardType Method

Gets the board type BOARD_TYPE.KFLOP = 2 = KFlop 8 Axes Controller BOARD_TYPE.KOGNA = 3 = Kogna 16 Axis Controller

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public BOARD_TYPE GetBoardType()
Public Function GetBoardType As BOARD_TYPE
public:
BOARD_TYPE GetBoardType()

Return Value

BOARD_TYPE
Board Type we are talking to
See Also

Reference

KM_Controller Class


KM_Controller.GetCommandValue<T> Method

KM_ControllerGetCommandValueT Method

Returns the value of a WriteLineReadLine(), converted to the requested type

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public T GetCommandValue<T>(
    string command,
    bool throwexception
)

Public Function GetCommandValue(Of T) (
    command As String,
    throwexception As Boolean
) As T
public:
generic<typename T>
T GetCommandValue(
    String^ command,
    bool throwexception
)

Parameters

command String
Console script statement
throwexception Boolean
flag determine whether or not to throw an exception

Type Parameters

T
System.Type to convert return value to

Return Value

T
the returned string value of the command converted to the requested type
See Also

Reference

KM_Controller Class


KM_Controller.GetFirmwareVersion Method

KM_ControllerGetFirmwareVersion Method

Query device for the loaded firmware version

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetFirmwareVersion()
Public Function GetFirmwareVersion As Integer
public:
int GetFirmwareVersion()

Return Value

Int32
Firmware version
See Also

Reference

KM_Controller Class


KM_Controller.GetIO Method

KM_ControllerGetIO Method

Creates a new KM_IO bit

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_IO GetIO(
    int bit,
    IO_TYPE type,
    string name
)
Public Function GetIO (
    bit As Integer,
    type As IO_TYPE,
    name As String
) As KM_IO
public:
KM_IO^ GetIO(
    int bit,
    IO_TYPE type,
    String^ name
)

Parameters

bit Int32
nit index
type IO_TYPE
IO type for bit
name String
Name of bit

Return Value

KM_IO
Created KM_IO
See Also

Reference

KM_Controller Class


KM_Controller.GetStatus Method

KM_ControllerGetStatus Method

Generates and returns an updated copy of the MAIN_STATUS structure

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_MainStatus GetStatus(
    bool locked
)
Public Function GetStatus (
    locked As Boolean
) As KM_MainStatus
public:
KM_MainStatus GetStatus(
    bool locked
)

Parameters

locked Boolean
flag to determine whether to place a lock on the card while generating the MAIN_STATUS data

Return Value

KM_MainStatus
KM_MainStatus, which is member compatible with the unmanaged MAIN_STATUS struct
See Also

Reference

KM_Controller Class


KM_Controller.GetUSBLocation Method

KM_ControllerGetUSBLocation Method

USB tree node location

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetUSBLocation()
Public Function GetUSBLocation As Integer
public:
int GetUSBLocation()

Return Value

Int32
USB location address
See Also

Reference

KM_Controller Class


KM_Controller.GetUserData Method

KM_ControllerGetUserData Method

Gets a 32 bit word of user data To set int value in KFLOP in C do: persist.UserData[index] = i;

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetUserData(
    int index
)
Public Function GetUserData (
    index As Integer
) As Integer
public:
int GetUserData(
    int index
)

Parameters

index Int32
array offset (0-199)

Return Value

Int32
Int32 data from the array
See Also

Reference

KM_Controller Class


KM_Controller.GetUserDataDouble Method

KM_ControllerGetUserDataDouble Method

Gets a 64 bit double from a KFLOP user data pair of 32 bit vars To set double value in KFLOP in C do: *(double *)&persist.UserData[index*2] = d;

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetUserDataDouble(
    int index
)
Public Function GetUserDataDouble (
    index As Integer
) As Double
public:
double GetUserDataDouble(
    int index
)

Parameters

index Int32
array offset (0-99)

Return Value

Double
double data from the array
See Also

Reference

KM_Controller Class


KM_Controller.GetUserDataFloat Method

KM_ControllerGetUserDataFloat Method

Gets a 32 bit float word of user data To set float value in KFLOP in C do: *(float *)&persist.UserData[index] = f;

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public float GetUserDataFloat(
    int index
)
Public Function GetUserDataFloat (
    index As Integer
) As Single
public:
float GetUserDataFloat(
    int index
)

Parameters

index Int32
array offset (0-199)

Return Value

Single
float data from the array
See Also

Reference

KM_Controller Class


KM_Controller.HasErrors Method

KM_ControllerHasErrors Method

Checks if any error messages are in qeue

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool HasErrors()
Public Function HasErrors As Boolean
public:
bool HasErrors()

Return Value

Boolean
true if Error log ! = ""
See Also

Reference

KM_Controller Class


KM_Controller.HasMessages Method

KM_ControllerHasMessages Method

Checks if any messages are in qeue

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool HasMessages()
Public Function HasMessages As Boolean
public:
bool HasMessages()

Return Value

Boolean
true if Message log ! = ""
See Also

Reference

KM_Controller Class


KM_Controller.KillProgramThreads Method

KM_ControllerKillProgramThreads Method

Halts the execution of each supplied thread

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void KillProgramThreads(
    params int[] threads
)
Public Sub KillProgramThreads (
    ParamArray threads As Integer()
)
public:
void KillProgramThreads(
    ... array<int>^ threads
)

Parameters

threads Int32
threads to kill
See Also

Reference

KM_Controller Class


KM_Controller.KMotionLock Method

KM_ControllerKMotionLock Method

Prevents outside access to the board This function is similar to the WaitToken function, except that it returns immediately (instead of waiting) if the board is already locked

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int KMotionLock()
Public Function KMotionLock As Integer
public:
int KMotionLock()

Return Value

Int32
KMOTION_LOCKED=0, // (and token is locked) if KMotion is available for use KMOTION_IN_USE=1, // if already in use KMOTION_NOT_CONNECTED=2, // if error or not able to connect
See Also

Reference

KM_Controller Class


KM_Controller.LoadCoff Method

KM_ControllerLoadCoff Method

Overload List
 | Name | Description
Public method | LoadCoff(Int32, String) | Load a compiled C program into the board
Public method | LoadCoff(Int32, String, Int32) | Load a compiled C program into the board (with PackToFlash arg)
Top
See Also

Reference

KM_Controller Class


KM_Controller.LoadCoff(Int32, String) Method

KM_ControllerLoadCoff(Int32, String) Method

Load a compiled C program into the board

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void LoadCoff(
    int thread,
    string programname
)
Public Sub LoadCoff (
    thread As Integer,
    programname As String
)
public:
void LoadCoff(
    int thread,
    String^ programname
)

Parameters

thread Int32
thread address to load into(must match the thread the C program was compiled to)
programname String
file name of the C program
See Also

Reference

KM_Controller Class
LoadCoff Overload


KM_Controller.LoadCoff(Int32, String, Int32) Method

KM_ControllerLoadCoff(Int32, String, Int32) Method

Load a compiled C program into the board (with PackToFlash arg)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int LoadCoff(
    int thread,
    string programname,
    int PackToFlash
)
Public Function LoadCoff (
    thread As Integer,
    programname As String,
    PackToFlash As Integer
) As Integer
public:
int LoadCoff(
    int thread,
    String^ programname,
    int PackToFlash
)

Parameters

thread Int32
thread address to load into(must match the thread the C program was compiled to)
programname String
file name of the C program
PackToFlash Int32
flag for packing in special format for bootup firmware

Return Value

Int32
Returns 0 if successful
See Also

Reference

KM_Controller Class
LoadCoff Overload


KM_Controller.ReadLineTimeout Method

KM_ControllerReadLineTimeout Method

Block the calling thread while waiting for the response to complete within a specified timeout

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ReadLineTimeout(
    ref string message,
    int timeout_ms
)
Public Function ReadLineTimeout (
    ByRef message As String,
    timeout_ms As Integer
) As Boolean
public:
bool ReadLineTimeout(
    String^% message,
    int timeout_ms
)

Parameters

message String
return message value
timeout_ms Int32
time in ms to wait for message return to complete

Return Value

Boolean
true is completed within the timeout
See Also

Reference

KM_Controller Class


KM_Controller.RecoverKMotionLock Method

KM_ControllerRecoverKMotionLock Method

Recovers controller from a motion lock state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void RecoverKMotionLock()
Public Sub RecoverKMotionLock
public:
void RecoverKMotionLock()
See Also

Reference

KM_Controller Class


KM_Controller.ReleaseToken Method

KM_ControllerReleaseToken Method

Allow normal access to the board

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ReleaseToken()
Public Sub ReleaseToken
public:
void ReleaseToken()
See Also

Reference

KM_Controller Class


KM_Controller.ResetUserData Method

KM_ControllerResetUserData Method

Sets all words of user data to 0

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ResetUserData()
Public Sub ResetUserData
public:
void ResetUserData()
See Also

Reference

KM_Controller Class


KM_Controller.ResumeFeedhold Method

KM_ControllerResumeFeedhold Method

Resumes Feedhold (Performs Console Command StopImmediate1)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ResumeFeedhold()
Public Sub ResumeFeedhold
public:
void ResumeFeedhold()
See Also

Reference

KM_Controller Class


KM_Controller.ServiceConsole Method

KM_ControllerServiceConsole Method

Flushes the console buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ServiceConsole()
Public Function ServiceConsole As Boolean
public:
bool ServiceConsole()

Return Value

Boolean
true if successful
See Also

Reference

KM_Controller Class


KM_Controller.SetCallbackHandler Method

KM_ControllerSetCallbackHandler Method

Sets the internal c++ interop callback handler Separate delegate for this callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetCallbackHandler()
Public Sub SetCallbackHandler
public:
void SetCallbackHandler()
See Also

Reference

KM_Controller Class


KM_Controller.SetFailed Method

KM_ControllerSetFailed Method

Places the controller in a failed state, prevents further commands from processing

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetFailed()
Public Sub SetFailed
public:
void SetFailed()
See Also

Reference

KM_Controller Class


KM_Controller.SetUserData Method

KM_ControllerSetUserData Method

Sets a 32 bit word of integer user data

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetUserData(
    int index,
    int data
)
Public Sub SetUserData (
    index As Integer,
    data As Integer
)
public:
void SetUserData(
    int index,
    int data
)

Parameters

index Int32
array offset (0-199)
data Int32
32bits of data to store
See Also

Reference

KM_Controller Class


KM_Controller.SetUserDataDouble Method

KM_ControllerSetUserDataDouble Method

Sets a pair of two 32 bit words with a 64-bit double of user data To get the value in KFLOP in C do: double f = *(double *)&persist.UserData[index*2];

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetUserDataDouble(
    int index,
    double ddata
)
Public Sub SetUserDataDouble (
    index As Integer,
    ddata As Double
)
public:
void SetUserDataDouble(
    int index,
    double ddata
)

Parameters

index Int32
array offset (0-99) even pair of 32-bit regs
ddata Double
64bit double data to store
See Also

Reference

KM_Controller Class


KM_Controller.SetUserDataFloat Method

KM_ControllerSetUserDataFloat Method

Sets a 32 bit word with a 32-bit float of user data To get the value in KFLOP in C do: float f = *(float *)&persist.UserData[index];

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetUserDataFloat(
    int index,
    float fdata
)
Public Sub SetUserDataFloat (
    index As Integer,
    fdata As Single
)
public:
void SetUserDataFloat(
    int index,
    float fdata
)

Parameters

index Int32
array offset (0-199)
fdata Single
32bits float data to store
See Also

Reference

KM_Controller Class


KM_Controller.ThreadExecuting Method

KM_ControllerThreadExecuting Method

Checks whether a User Program Thread is currently executing.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ThreadExecuting(
    int thread
)
Public Function ThreadExecuting (
    thread As Integer
) As Boolean
public:
bool ThreadExecuting(
    int thread
)

Parameters

thread Int32
Which User Thread 1-7 to check

Return Value

Boolean
Returns true if executing, false if not executing
See Also

Reference

KM_Controller Class


KM_Controller.WaitForThreadComplete Method

KM_ControllerWaitForThreadComplete Method

Waits for a User Program Thread to finish executing.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool WaitForThreadComplete(
    int thread,
    int timeout
)
Public Function WaitForThreadComplete (
    thread As Integer,
    timeout As Integer
) As Boolean
public:
bool WaitForThreadComplete(
    int thread,
    int timeout
)

Parameters

thread Int32
Which User Thread 1-7 to check
timeout Int32
time to wait in milliseconds

Return Value

Boolean
Returns true if successful, false if timed out
See Also

Reference

KM_Controller Class


KM_Controller.WaitToken Method

KM_ControllerWaitToken Method

Prevents outside access to the board until ReleaseToken is commanded

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KMOTION_TOKEN WaitToken(
    int timeout
)
Public Function WaitToken (
    timeout As Integer
) As KMOTION_TOKEN
public:
KMOTION_TOKEN WaitToken(
    int timeout
)

Parameters

timeout Int32
ms to wait

Return Value

KMOTION_TOKEN
true if lock was successful
See Also

Reference

KM_Controller Class


KM_Controller.WriteLine Method

KM_ControllerWriteLine Method

Sends a console command to the board

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void WriteLine(
    string command
)
Public Sub WriteLine (
    command As String
)
public:
void WriteLine(
    String^ command
)

Parameters

command String
script command to send
See Also

Reference

KM_Controller Class


KM_Controller.WriteLineReadLine Method

KM_ControllerWriteLineReadLine Method

Sends a console command to the board and waits for the return value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string WriteLineReadLine(
    string command
)
Public Function WriteLineReadLine (
    command As String
) As String
public:
String^ WriteLineReadLine(
    String^ command
)

Parameters

command String
script command to send

Return Value

String
return value (if any)
See Also

Reference

KM_Controller Class


KM_Controller.WriteLineWithEcho Method

KM_ControllerWriteLineWithEcho Method

Sends a console command to the board while echoing commands back to the callback handler

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void WriteLineWithEcho(
    string command
)
Public Sub WriteLineWithEcho (
    command As String
)
public:
void WriteLineWithEcho(
    String^ command
)

Parameters

command String
script command to send
See Also

Reference

KM_Controller Class


KM_Controller Events

The KM_Controller type exposes the following members.

Events
 | Name | Description
Public event | ErrorReceived | Error Messages are routed through this event
Public event | MessageReceived | All general messages are pumped out from the internal callback handler thru this event
Top
See Also

Reference

KM_Controller Class


KM_Controller.ErrorReceived Event

KM_ControllerErrorReceived Event

Error Messages are routed through this event

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KMErrorHandler ErrorReceived
Public Event ErrorReceived As KMErrorHandler
public:
 event KMErrorHandler^ ErrorReceived {
    void add (KMErrorHandler^ value);
    void remove (KMErrorHandler^ value);
}

Value

KMErrorHandler
See Also

Reference

KM_Controller Class


KM_Controller.MessageReceived Event

KM_ControllerMessageReceived Event

All general messages are pumped out from the internal callback handler thru this event

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KMConsoleHandler MessageReceived
Public Event MessageReceived As KMConsoleHandler
public:
 event KMConsoleHandler^ MessageReceived {
    void add (KMConsoleHandler^ value);
    void remove (KMConsoleHandler^ value);
}

Value

KMConsoleHandler
See Also

Reference

KM_Controller Class


KM_CoordMotion Class

Coordinated Motion class representing the CoordMotion.cpp object from the C++ Dynotion Code Use to directly control multiple axis motion Notably:: Straight Traverse Straight Feed Arc Feed
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_CoordMotion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_CoordMotion : IDisposable
Public Class KM_CoordMotion
    Implements IDisposable
public ref class KM_CoordMotion : IDisposable

The KM_CoordMotion type exposes the following members.

Constructors
 | Name | Description
Public method | KM_CoordMotion | Primary constructor for KM_CoordMotion object
Top
Properties
 | Name | Description
Public property | BoardNumber | Board number (for use in multiple board scenarios)
Public property | BufferedSegments | Gets how may segments are currently loaded into the CoordMotion buffer
Public property | FeedRateOverride | Gets/Sets the Feedrate override for all axes
Public property | FeedRateRapidOverride | Gets/Sets the Feedrate Rapid override for all axes
Public property | HardwareFRORange | Gets/Sets the Hardware FRO Range for all axes Below this value FRO is handled by hardware (no delay) Above this value FRO is handle by the Trajectory Planner (proper accelerations)
Public property | InstanceHandle | CCoordMotion class instance pointer
Public property | Interpreter | RS274 Interpreter Component
Public property | IsAbort | Returns true if the CoordMotion is aborting
Public property | IsHalt | Returns true if the CoordMotion is halted
Public property | IsPreviouslyStopped | Result of previous Interpreter Halt
Public property | IsSimulation | Flags whether to Simulate commands or not
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | MotionParams | Accessor to the various MotionParams
Public property | RapidParamsDirty | Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna
Public property | RemainingTimeInBuffer | Gets time Total time downloaded into the CoordMotion buffer
Public property | SpindleRateOverride | Gets/Sets the Spindlerate override for all axes
Public property | TimeExecuted | Gets how many seconds have already been executed
Public property | TotalTimeInBuffer | Gets time Total time downloaded into the CoordMotion buffer
Top
Methods
 | Name | Description
Public method | Abort | Abort causes all motion to abruptly stop usually due to something catastrophic like a communication error Use in an E-Stop condition
Public method | ArcFeed | Perform arc motion at a specified feed rate (in/sec)
Public method | ArcFeedAccel | Perform arc motion at a specified feed rate (in/sec) and Acceleration (in/sec2)
Public method | CheckMotionHalt | Cehecks for a motion halt
Public method | ClearAbort | Clears any existing Abort conditions
Public method | ClearHalt | Clear any exisiting halts
Public method | Dispose | Releases object resources
Public method | DoKMotionBufCmd | Inserts a console script command in the buffer
Public method | DoKMotionCmd | Processes a console script command
Public method | DoRateAdjustments | Update the Trajectory Planner's segment feedrates.
Public method | DoSpecialCommand | Perform segment execution
Public method | DownloadDoneSegments | Download all computed segments from the Trajectory Planner to the device buffer
Public method | DownloadInit | Initializes download
Public method | Dwell | Pause motion fow given amount of time
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecutionStop | Stop the execution of current motion in a controlled number
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | FlushSegments | Flushes the segment buffer
Public method | GetAxisDefinitions | Get the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis
Public method | GetAxisDestination | Gets the axis destination
Public method | GetAxisPosition | Gets the axis position
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt cause motion to stop in a controlled manner. A feed hold is commanded so that the motion decellerates along the intended path. After the system completely stops, the exact point in the Coordinated Motion Buffer where the stop actually happened is uploaded and the GCode Interpreter is rewound to that point.
Public method | KinematicsReadGeoTable | Loads Coordinated Motion Kinematics Geo Correction Table
Public method | MeasurePointAppendToFile | Write position data to file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | OnTraverseCompletes | Returns after the Async Traverse is called
Public method | OutputSegment | Output given segment
Public method | ReadAndSyncCurPositions | First Syncs the Coor Motion Library to the current axis destinations then sets the passed variables to the CoordMotion's Absolute positions
Public method | SetAxisDefinitions | Set the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis
Public method | SetTPParams | Force the Trajectory Planner to update it's parameters
Public method | StartTraverse | Fires an async delegate to move axes at traversal speeds non-interpolated
Public method | StraightFeed | Perform linear motion at a specified feed rate (in/sec)
Public method | StraightFeedAccel | Perform linear motion at a specified feed rate (in/sec) and Acceleration (in/sec2)
Public method | StraightTraverse | Move axes at traversal speeds non-interpolated
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateCurrentPositionsABS | Sets the passed variables to the CoordMotion's Absolute positions
Public method | WaitForMoveXYZABCFinished | Blocks calling thread until all commanded motion is complete
Public method | WaitForSegmentsFinished | Waits for all buffered segments to complete Blocks calling thread until the buffer is complete
Top
Events
 | Name | Description
Public event | AsyncTraverseCompleted | Event handler to signal calling application when an async traverse has completed
Public event | CoordMotionArcFeed | Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer
Public event | CoordMotionArcFeedSixAxis | Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightFeed | Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightFeedSixAxis | Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightTraverse | Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer
Public event | CoordMotionStraightTraverseSixAxis | Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer
Top
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotion Constructor

Primary constructor for KM_CoordMotion object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_CoordMotion(
    KM_Controller controller
)
Public Sub New (
    controller As KM_Controller
)
public:
KM_CoordMotion(
    KM_Controller^ controller
)

Parameters

controller KM_Controller
KM_Controller object to associate the CoodMotion object with
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion Properties

The KM_CoordMotion type exposes the following members.

Properties
 | Name | Description
Public property | BoardNumber | Board number (for use in multiple board scenarios)
Public property | BufferedSegments | Gets how may segments are currently loaded into the CoordMotion buffer
Public property | FeedRateOverride | Gets/Sets the Feedrate override for all axes
Public property | FeedRateRapidOverride | Gets/Sets the Feedrate Rapid override for all axes
Public property | HardwareFRORange | Gets/Sets the Hardware FRO Range for all axes Below this value FRO is handled by hardware (no delay) Above this value FRO is handle by the Trajectory Planner (proper accelerations)
Public property | InstanceHandle | CCoordMotion class instance pointer
Public property | Interpreter | RS274 Interpreter Component
Public property | IsAbort | Returns true if the CoordMotion is aborting
Public property | IsHalt | Returns true if the CoordMotion is halted
Public property | IsPreviouslyStopped | Result of previous Interpreter Halt
Public property | IsSimulation | Flags whether to Simulate commands or not
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | MotionParams | Accessor to the various MotionParams
Public property | RapidParamsDirty | Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna
Public property | RemainingTimeInBuffer | Gets time Total time downloaded into the CoordMotion buffer
Public property | SpindleRateOverride | Gets/Sets the Spindlerate override for all axes
Public property | TimeExecuted | Gets how many seconds have already been executed
Public property | TotalTimeInBuffer | Gets time Total time downloaded into the CoordMotion buffer
Top
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.BoardNumber Property

KM_CoordMotionBoardNumber Property

Board number (for use in multiple board scenarios)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BoardNumber { get; }
Public ReadOnly Property BoardNumber As Integer
    Get
public:
property int BoardNumber {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.BufferedSegments Property

KM_CoordMotionBufferedSegments Property

Gets how may segments are currently loaded into the CoordMotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BufferedSegments { get; }
Public ReadOnly Property BufferedSegments As Integer
    Get
public:
property int BufferedSegments {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.FeedRateOverride Property

KM_CoordMotionFeedRateOverride Property

Gets/Sets the Feedrate override for all axes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FeedRateOverride { get; set; }
Public Property FeedRateOverride As Double
    Get
    Set
public:
property double FeedRateOverride {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.FeedRateRapidOverride Property

KM_CoordMotionFeedRateRapidOverride Property

Gets/Sets the Feedrate Rapid override for all axes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FeedRateRapidOverride { get; set; }
Public Property FeedRateRapidOverride As Double
    Get
    Set
public:
property double FeedRateRapidOverride {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.HardwareFRORange Property

KM_CoordMotionHardwareFRORange Property

Gets/Sets the Hardware FRO Range for all axes Below this value FRO is handled by hardware (no delay) Above this value FRO is handle by the Trajectory Planner (proper accelerations)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double HardwareFRORange { get; set; }
Public Property HardwareFRORange As Double
    Get
    Set
public:
property double HardwareFRORange {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.InstanceHandle Property

KM_CoordMotionInstanceHandle Property

CCoordMotion class instance pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public IntPtr InstanceHandle { get; }
Public ReadOnly Property InstanceHandle As IntPtr
    Get
public:
property IntPtr InstanceHandle {
    IntPtr get ();
}

Property Value

IntPtr
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Interpreter Property

KM_CoordMotionInterpreter Property

RS274 Interpreter Component

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Interpreter Interpreter { get; set; }
Public Property Interpreter As KM_Interpreter
    Get
    Set
public:
property KM_Interpreter^ Interpreter {
    KM_Interpreter^ get ();
    void set (KM_Interpreter^ value);
}

Property Value

KM_Interpreter
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.IsAbort Property

KM_CoordMotionIsAbort Property

Returns true if the CoordMotion is aborting

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsAbort { get; }
Public ReadOnly Property IsAbort As Boolean
    Get
public:
property bool IsAbort {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.IsHalt Property

KM_CoordMotionIsHalt Property

Returns true if the CoordMotion is halted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsHalt { get; }
Public ReadOnly Property IsHalt As Boolean
    Get
public:
property bool IsHalt {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.IsPreviouslyStopped Property

KM_CoordMotionIsPreviouslyStopped Property

Result of previous Interpreter Halt

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public PREV_STOP_TYPE IsPreviouslyStopped { get; set; }
Public Property IsPreviouslyStopped As PREV_STOP_TYPE
    Get
    Set
public:
property PREV_STOP_TYPE IsPreviouslyStopped {
    PREV_STOP_TYPE get ();
    void set (PREV_STOP_TYPE value);
}

Property Value

PREV_STOP_TYPE
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.IsSimulation Property

KM_CoordMotionIsSimulation Property

Flags whether to Simulate commands or not

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsSimulation { get; set; }
Public Property IsSimulation As Boolean
    Get
    Set
public:
property bool IsSimulation {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Loaded Property

KM_CoordMotionLoaded Property

Flag to determine that this object has been properly initialized

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool Loaded { get; set; }
Public Property Loaded As Boolean
    Get
    Set
public:
property bool Loaded {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.MaxErrorLength Property

KM_CoordMotionMaxErrorLength Property

Maximum allowed return error string length

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int MaxErrorLength { get; set; }
Public Property MaxErrorLength As Integer
    Get
    Set
public:
property int MaxErrorLength {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.MotionParams Property

KM_CoordMotionMotionParams Property

Accessor to the various MotionParams

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_MotionParams MotionParams { get; }
Public ReadOnly Property MotionParams As KM_MotionParams
    Get
public:
property KM_MotionParams^ MotionParams {
    KM_MotionParams^ get ();
}

Property Value

KM_MotionParams
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.RapidParamsDirty Property

KM_CoordMotionRapidParamsDirty Property

Gets/Sets the RapidParamsDirty, if set Rapid parameters will be refressed from KFLOP/Kogna

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool RapidParamsDirty { get; set; }
Public Property RapidParamsDirty As Boolean
    Get
    Set
public:
property bool RapidParamsDirty {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.RemainingTimeInBuffer Property

KM_CoordMotionRemainingTimeInBuffer Property

Gets time Total time downloaded into the CoordMotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double RemainingTimeInBuffer { get; }
Public ReadOnly Property RemainingTimeInBuffer As Double
    Get
public:
property double RemainingTimeInBuffer {
    double get ();
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.SpindleRateOverride Property

KM_CoordMotionSpindleRateOverride Property

Gets/Sets the Spindlerate override for all axes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SpindleRateOverride { get; set; }
Public Property SpindleRateOverride As Double
    Get
    Set
public:
property double SpindleRateOverride {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.TimeExecuted Property

KM_CoordMotionTimeExecuted Property

Gets how many seconds have already been executed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TimeExecuted { get; }
Public ReadOnly Property TimeExecuted As Double
    Get
public:
property double TimeExecuted {
    double get ();
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.TotalTimeInBuffer Property

KM_CoordMotionTotalTimeInBuffer Property

Gets time Total time downloaded into the CoordMotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TotalTimeInBuffer { get; }
Public ReadOnly Property TotalTimeInBuffer As Double
    Get
public:
property double TotalTimeInBuffer {
    double get ();
}

Property Value

Double
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion Methods

The KM_CoordMotion type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Abort causes all motion to abruptly stop usually due to something catastrophic like a communication error Use in an E-Stop condition
Public method | ArcFeed | Perform arc motion at a specified feed rate (in/sec)
Public method | ArcFeedAccel | Perform arc motion at a specified feed rate (in/sec) and Acceleration (in/sec2)
Public method | CheckMotionHalt | Cehecks for a motion halt
Public method | ClearAbort | Clears any existing Abort conditions
Public method | ClearHalt | Clear any exisiting halts
Public method | Dispose | Releases object resources
Public method | DoKMotionBufCmd | Inserts a console script command in the buffer
Public method | DoKMotionCmd | Processes a console script command
Public method | DoRateAdjustments | Update the Trajectory Planner's segment feedrates.
Public method | DoSpecialCommand | Perform segment execution
Public method | DownloadDoneSegments | Download all computed segments from the Trajectory Planner to the device buffer
Public method | DownloadInit | Initializes download
Public method | Dwell | Pause motion fow given amount of time
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecutionStop | Stop the execution of current motion in a controlled number
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | FlushSegments | Flushes the segment buffer
Public method | GetAxisDefinitions | Get the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis
Public method | GetAxisDestination | Gets the axis destination
Public method | GetAxisPosition | Gets the axis position
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt cause motion to stop in a controlled manner. A feed hold is commanded so that the motion decellerates along the intended path. After the system completely stops, the exact point in the Coordinated Motion Buffer where the stop actually happened is uploaded and the GCode Interpreter is rewound to that point.
Public method | KinematicsReadGeoTable | Loads Coordinated Motion Kinematics Geo Correction Table
Public method | MeasurePointAppendToFile | Write position data to file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | OnTraverseCompletes | Returns after the Async Traverse is called
Public method | OutputSegment | Output given segment
Public method | ReadAndSyncCurPositions | First Syncs the Coor Motion Library to the current axis destinations then sets the passed variables to the CoordMotion's Absolute positions
Public method | SetAxisDefinitions | Set the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis
Public method | SetTPParams | Force the Trajectory Planner to update it's parameters
Public method | StartTraverse | Fires an async delegate to move axes at traversal speeds non-interpolated
Public method | StraightFeed | Perform linear motion at a specified feed rate (in/sec)
Public method | StraightFeedAccel | Perform linear motion at a specified feed rate (in/sec) and Acceleration (in/sec2)
Public method | StraightTraverse | Move axes at traversal speeds non-interpolated
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateCurrentPositionsABS | Sets the passed variables to the CoordMotion's Absolute positions
Public method | WaitForMoveXYZABCFinished | Blocks calling thread until all commanded motion is complete
Public method | WaitForSegmentsFinished | Waits for all buffered segments to complete Blocks calling thread until the buffer is complete
Top
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Abort Method

KM_CoordMotionAbort Method

Abort causes all motion to abruptly stop usually due to something catastrophic like a communication error Use in an E-Stop condition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Abort()
Public Sub Abort
public:
void Abort()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ArcFeed Method

KM_CoordMotionArcFeed Method

Perform arc motion at a specified feed rate (in/sec)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ArcFeed(
    double feedrate,
    int plane,
    double planarXend,
    double planarYend,
    double planarXcenter,
    double planarYcenter,
    int rotation,
    double planarZ,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)
Public Sub ArcFeed (
    feedrate As Double,
    plane As Integer,
    planarXend As Double,
    planarYend As Double,
    planarXcenter As Double,
    planarYcenter As Double,
    rotation As Integer,
    planarZ As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer,
    ID As Integer
)
public:
void ArcFeed(
    double feedrate,
    int plane,
    double planarXend,
    double planarYend,
    double planarXcenter,
    double planarYcenter,
    int rotation,
    double planarZ,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)

Parameters

feedrate Double
Desired feed rate
plane Int32
plane to perform arc (determines axis pair to use)
planarXend Double
X end point of arc
planarYend Double
Y end point of arc
planarXcenter Double
X center of rotation of arc
planarYcenter Double
Y center of rotation of arc
rotation Int32
CW or ACW
planarZ Double
End point of perpindicular axis(for helical motion)
a Double
final end position of a axis
b Double
final end position of a axis
c Double
final end position of a axis
sequence_number Int32
internal reference
ID Int32
internal reference
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ArcFeedAccel Method

KM_CoordMotionArcFeedAccel Method

Perform arc motion at a specified feed rate (in/sec) and Acceleration (in/sec2)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ArcFeedAccel(
    double feedrate,
    double accel,
    int plane,
    double planarXend,
    double planarYend,
    double planarXcenter,
    double planarYcenter,
    int rotation,
    double planarZ,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)
Public Sub ArcFeedAccel (
    feedrate As Double,
    accel As Double,
    plane As Integer,
    planarXend As Double,
    planarYend As Double,
    planarXcenter As Double,
    planarYcenter As Double,
    rotation As Integer,
    planarZ As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer,
    ID As Integer
)
public:
void ArcFeedAccel(
    double feedrate,
    double accel,
    int plane,
    double planarXend,
    double planarYend,
    double planarXcenter,
    double planarYcenter,
    int rotation,
    double planarZ,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)

Parameters

feedrate Double
Desired feed rate
accel Double
Desired acceleration rate
plane Int32
plane to perform arc (determines axis pair to use)
planarXend Double
X end point of arc
planarYend Double
Y end point of arc
planarXcenter Double
X center of rotation of arc
planarYcenter Double
Y center of rotation of arc
rotation Int32
CW or ACW
planarZ Double
End point of perpindicular axis(for helical motion)
a Double
final end position of a axis
b Double
final end position of a axis
c Double
final end position of a axis
sequence_number Int32
internal reference
ID Int32
internal reference
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CheckMotionHalt Method

KM_CoordMotionCheckMotionHalt Method

Cehecks for a motion halt

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int CheckMotionHalt(
    bool coord
)
Public Function CheckMotionHalt (
    coord As Boolean
) As Integer
public:
int CheckMotionHalt(
    bool coord
)

Parameters

coord Boolean
specify axis mapped axes only

Return Value

Int32
true if a halt exists
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ClearAbort Method

KM_CoordMotionClearAbort Method

Clears any existing Abort conditions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearAbort()
Public Sub ClearAbort
public:
void ClearAbort()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ClearHalt Method

KM_CoordMotionClearHalt Method

Clear any exisiting halts

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ClearHalt()
Public Sub ClearHalt
public:
void ClearHalt()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Dispose Method

KM_CoordMotionDispose Method

Releases object resources

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DoKMotionBufCmd Method

KM_CoordMotionDoKMotionBufCmd Method

Inserts a console script command in the buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DoKMotionBufCmd(
    string command
)
Public Sub DoKMotionBufCmd (
    command As String
)
public:
void DoKMotionBufCmd(
    String^ command
)

Parameters

command String
command
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DoKMotionCmd Method

KM_CoordMotionDoKMotionCmd Method

Processes a console script command

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DoKMotionCmd(
    string command,
    bool flushbufferfirst
)
Public Sub DoKMotionCmd (
    command As String,
    flushbufferfirst As Boolean
)
public:
void DoKMotionCmd(
    String^ command,
    bool flushbufferfirst
)

Parameters

command String
console script
flushbufferfirst Boolean
Flush current buffered commands before adding a new one
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DoRateAdjustments Method

KM_CoordMotionDoRateAdjustments Method

Update the Trajectory Planner's segment feedrates.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DoRateAdjustments(
    int i0,
    int i1,
    double feedrate
)
Public Sub DoRateAdjustments (
    i0 As Integer,
    i1 As Integer,
    feedrate As Double
)
public:
void DoRateAdjustments(
    int i0,
    int i1,
    double feedrate
)

Parameters

i0 Int32
starting segment
i1 Int32
ending segment (inclusive)
feedrate Double
Desired Feedrate in in/sec
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DoSpecialCommand Method

KM_CoordMotionDoSpecialCommand Method

Perform segment execution

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DoSpecialCommand(
    int segment
)
Public Sub DoSpecialCommand (
    segment As Integer
)
public:
void DoSpecialCommand(
    int segment
)

Parameters

segment Int32
segment index
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DownloadDoneSegments Method

KM_CoordMotionDownloadDoneSegments Method

Download all computed segments from the Trajectory Planner to the device buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DownloadDoneSegments()
Public Sub DownloadDoneSegments
public:
void DownloadDoneSegments()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.DownloadInit Method

KM_CoordMotionDownloadInit Method

Initializes download

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void DownloadInit()
Public Sub DownloadInit
public:
void DownloadInit()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Dwell Method

KM_CoordMotionDwell Method

Pause motion fow given amount of time

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Dwell(
    double seconds,
    int sequence_number
)
Public Sub Dwell (
    seconds As Double,
    sequence_number As Integer
)
public:
void Dwell(
    double seconds,
    int sequence_number
)

Parameters

seconds Double
time in seconds
sequence_number Int32
sequence number to be associated with the dwell
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ExecutionStop Method

KM_CoordMotionExecutionStop Method

Stop the execution of current motion in a controlled number

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ExecutionStop()
Public Sub ExecutionStop
public:
void ExecutionStop()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.FlushSegments Method

KM_CoordMotionFlushSegments Method

Flushes the segment buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void FlushSegments()
Public Sub FlushSegments
public:
void FlushSegments()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.GetAxisDefinitions Method

KM_CoordMotionGetAxisDefinitions Method

Get the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void GetAxisDefinitions(
    ref int x,
    ref int y,
    ref int z,
    ref int a,
    ref int b,
    ref int c
)
Public Sub GetAxisDefinitions (
    ByRef x As Integer,
    ByRef y As Integer,
    ByRef z As Integer,
    ByRef a As Integer,
    ByRef b As Integer,
    ByRef c As Integer
)
public:
void GetAxisDefinitions(
    int% x,
    int% y,
    int% z,
    int% a,
    int% b,
    int% c
)

Parameters

x Int32
KFLOP Axis number for x axis
y Int32
KFLOP Axis number for y axis
z Int32
KFLOP Axis number for z axis
a Int32
KFLOP Axis number for a axis
b Int32
KFLOP Axis number for b axis
c Int32
KFLOP Axis number for c axis
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.GetAxisDestination Method

KM_CoordMotionGetAxisDestination Method

Gets the axis destination

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetAxisDestination(
    int axis
)
Public Function GetAxisDestination (
    axis As Integer
) As Double
public:
double GetAxisDestination(
    int axis
)

Parameters

axis Int32
Axis map index

Return Value

Double
actual axis destination
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.GetAxisPosition Method

KM_CoordMotionGetAxisPosition Method

Gets the axis position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetAxisPosition(
    int axis
)
Public Function GetAxisPosition (
    axis As Integer
) As Double
public:
double GetAxisPosition(
    int axis
)

Parameters

axis Int32
Axis map index

Return Value

Double
actual axis position
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.Halt Method

KM_CoordMotionHalt Method

Halt cause motion to stop in a controlled manner. A feed hold is commanded so that the motion decellerates along the intended path. After the system completely stops, the exact point in the Coordinated Motion Buffer where the stop actually happened is uploaded and the GCode Interpreter is rewound to that point.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Halt()
Public Sub Halt
public:
void Halt()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.KinematicsReadGeoTable Method

KM_CoordMotionKinematicsReadGeoTable Method

Loads Coordinated Motion Kinematics Geo Correction Table

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void KinematicsReadGeoTable(
    string filename
)
Public Sub KinematicsReadGeoTable (
    filename As String
)
public:
void KinematicsReadGeoTable(
    String^ filename
)

Parameters

filename String
Geo Correction File Name to load
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.MeasurePointAppendToFile Method

KM_CoordMotionMeasurePointAppendToFile Method

Write position data to file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void MeasurePointAppendToFile(
    string command
)
Public Sub MeasurePointAppendToFile (
    command As String
)
public:
void MeasurePointAppendToFile(
    String^ command
)

Parameters

command String
file name to append to
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.OnTraverseCompletes Method

KM_CoordMotionOnTraverseCompletes Method

Returns after the Async Traverse is called

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void OnTraverseCompletes(
    IAsyncResult result
)
Protected Sub OnTraverseCompletes (
    result As IAsyncResult
)
protected:
void OnTraverseCompletes(
    IAsyncResult^ result
)

Parameters

result IAsyncResult
User supplied object that gets returned when traverse is complete
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.OutputSegment Method

KM_CoordMotionOutputSegment Method

Output given segment

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void OutputSegment(
    int segment
)
Public Sub OutputSegment (
    segment As Integer
)
public:
void OutputSegment(
    int segment
)

Parameters

segment Int32
segment index to output
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.ReadAndSyncCurPositions Method

KM_CoordMotionReadAndSyncCurPositions Method

First Syncs the Coor Motion Library to the current axis destinations then sets the passed variables to the CoordMotion's Absolute positions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ReadAndSyncCurPositions(
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c
)
Public Sub ReadAndSyncCurPositions (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double
)
public:
void ReadAndSyncCurPositions(
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c
)

Parameters

x Double
X axis value
y Double
Y axis value
z Double
Z axis value
a Double
A axis value
b Double
B axis value
c Double
C axis value
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.SetAxisDefinitions Method

KM_CoordMotionSetAxisDefinitions Method

Set the assignment of KFLOP axis Channels to GCode Axes XYZABC, -1 indicates unused/unassigned axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetAxisDefinitions(
    int x,
    int y,
    int z,
    int a,
    int b,
    int c
)
Public Sub SetAxisDefinitions (
    x As Integer,
    y As Integer,
    z As Integer,
    a As Integer,
    b As Integer,
    c As Integer
)
public:
void SetAxisDefinitions(
    int x,
    int y,
    int z,
    int a,
    int b,
    int c
)

Parameters

x Int32
KFLOP Axis number for x axis
y Int32
KFLOP Axis number for y axis
z Int32
KFLOP Axis number for z axis
a Int32
KFLOP Axis number for a axis
b Int32
KFLOP Axis number for b axis
c Int32
KFLOP Axis number for c axis
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.SetTPParams Method

KM_CoordMotionSetTPParams Method

Force the Trajectory Planner to update it's parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetTPParams()
Public Sub SetTPParams
public:
void SetTPParams()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.StartTraverse Method

KM_CoordMotionStartTraverse Method

Fires an async delegate to move axes at traversal speeds non-interpolated

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StartTraverse(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    bool suppresscallback,
    Object usercallback
)
Public Sub StartTraverse (
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    suppresscallback As Boolean,
    usercallback As Object
)
public:
void StartTraverse(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    bool suppresscallback,
    Object^ usercallback
)

Parameters

x Double
x position
y Double
y position
z Double
z position
a Double
a position
b Double
b position
c Double
c position
suppresscallback Boolean
Prevents callback information from being dispatched
usercallback Object
User supplied object that gets returned when traverse is complete
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.StraightFeed Method

KM_CoordMotionStraightFeed Method

Perform linear motion at a specified feed rate (in/sec)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StraightFeed(
    double feedrate,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)
Public Sub StraightFeed (
    feedrate As Double,
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer,
    ID As Integer
)
public:
void StraightFeed(
    double feedrate,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)

Parameters

feedrate Double
Desired feed rate
x Double
X end point
y Double
Y end point
z Double
Z end point
a Double
A end point
b Double
B end point
c Double
C end point
sequence_number Int32
internal reference
ID Int32
internal reference
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.StraightFeedAccel Method

KM_CoordMotionStraightFeedAccel Method

Perform linear motion at a specified feed rate (in/sec) and Acceleration (in/sec2)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StraightFeedAccel(
    double feedrate,
    double accel,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)
Public Sub StraightFeedAccel (
    feedrate As Double,
    accel As Double,
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer,
    ID As Integer
)
public:
void StraightFeedAccel(
    double feedrate,
    double accel,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)

Parameters

feedrate Double
Desired feed rate
accel Double
Desired acceleration rate
x Double
X end point
y Double
Y end point
z Double
Z end point
a Double
A end point
b Double
B end point
c Double
C end point
sequence_number Int32
internal reference
ID Int32
internal reference
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.StraightTraverse Method

KM_CoordMotionStraightTraverse Method

Move axes at traversal speeds non-interpolated

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void StraightTraverse(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    bool suppresscallback
)
Public Sub StraightTraverse (
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    suppresscallback As Boolean
)
public:
void StraightTraverse(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    bool suppresscallback
)

Parameters

x Double
x position
y Double
y position
z Double
z position
a Double
a position
b Double
b position
c Double
c position
suppresscallback Boolean
Prevents callback information from being dispatched
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.UpdateCurrentPositionsABS Method

KM_CoordMotionUpdateCurrentPositionsABS Method

Sets the passed variables to the CoordMotion's Absolute positions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void UpdateCurrentPositionsABS(
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c,
    bool snap
)
Public Sub UpdateCurrentPositionsABS (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double,
    snap As Boolean
)
public:
void UpdateCurrentPositionsABS(
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c,
    bool snap
)

Parameters

x Double
X axis value
y Double
Y axis value
z Double
Z axis value
a Double
A axis value
b Double
B axis value
c Double
C axis value
snap Boolean
snap to exact previously commanded postion (if close) to avoid rounding errors
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.WaitForMoveXYZABCFinished Method

KM_CoordMotionWaitForMoveXYZABCFinished Method

Blocks calling thread until all commanded motion is complete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void WaitForMoveXYZABCFinished()
Public Sub WaitForMoveXYZABCFinished
public:
void WaitForMoveXYZABCFinished()
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.WaitForSegmentsFinished Method

KM_CoordMotionWaitForSegmentsFinished Method

Waits for all buffered segments to complete Blocks calling thread until the buffer is complete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void WaitForSegmentsFinished(
    bool suppressdisablederror
)
Public Sub WaitForSegmentsFinished (
    suppressdisablederror As Boolean
)
public:
void WaitForSegmentsFinished(
    bool suppressdisablederror
)

Parameters

suppressdisablederror Boolean
suppress errors cause by commanding a disabled axis
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion Events

The KM_CoordMotion type exposes the following members.

Events
 | Name | Description
Public event | AsyncTraverseCompleted | Event handler to signal calling application when an async traverse has completed
Public event | CoordMotionArcFeed | Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer
Public event | CoordMotionArcFeedSixAxis | Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightFeed | Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightFeedSixAxis | Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer
Public event | CoordMotionStraightTraverse | Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer
Public event | CoordMotionStraightTraverseSixAxis | Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer
Top
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.AsyncTraverseCompleted Event

KM_CoordMotionAsyncTraverseCompleted Event

Event handler to signal calling application when an async traverse has completed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event TraverseCompletedHandler AsyncTraverseCompleted
Public Event AsyncTraverseCompleted As TraverseCompletedHandler
public:
 event TraverseCompletedHandler^ AsyncTraverseCompleted {
    void add (TraverseCompletedHandler^ value);
    void remove (TraverseCompletedHandler^ value);
}

Value

TraverseCompletedHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionArcFeed Event

KM_CoordMotionCoordMotionArcFeed Event

Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionArcFeedHandler CoordMotionArcFeed
Public Event CoordMotionArcFeed As KM_CoordMotionArcFeedHandler
public:
 event KM_CoordMotionArcFeedHandler^ CoordMotionArcFeed {
    void add (KM_CoordMotionArcFeedHandler^ value);
    void remove (KM_CoordMotionArcFeedHandler^ value);
}

Value

KM_CoordMotionArcFeedHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionArcFeedSixAxis Event

KM_CoordMotionCoordMotionArcFeedSixAxis Event

Event handler to signal the download of a Arc Feed segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionArcFeedSixAxisHandler CoordMotionArcFeedSixAxis
Public Event CoordMotionArcFeedSixAxis As KM_CoordMotionArcFeedSixAxisHandler
public:
 event KM_CoordMotionArcFeedSixAxisHandler^ CoordMotionArcFeedSixAxis {
    void add (KM_CoordMotionArcFeedSixAxisHandler^ value);
    void remove (KM_CoordMotionArcFeedSixAxisHandler^ value);
}

Value

KM_CoordMotionArcFeedSixAxisHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionStraightFeed Event

KM_CoordMotionCoordMotionStraightFeed Event

Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionStraightFeedHandler CoordMotionStraightFeed
Public Event CoordMotionStraightFeed As KM_CoordMotionStraightFeedHandler
public:
 event KM_CoordMotionStraightFeedHandler^ CoordMotionStraightFeed {
    void add (KM_CoordMotionStraightFeedHandler^ value);
    void remove (KM_CoordMotionStraightFeedHandler^ value);
}

Value

KM_CoordMotionStraightFeedHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionStraightFeedSixAxis Event

KM_CoordMotionCoordMotionStraightFeedSixAxis Event

Event handler to signal the download of a Straight Feed segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionStraightFeedSixAxisHandler CoordMotionStraightFeedSixAxis
Public Event CoordMotionStraightFeedSixAxis As KM_CoordMotionStraightFeedSixAxisHandler
public:
 event KM_CoordMotionStraightFeedSixAxisHandler^ CoordMotionStraightFeedSixAxis {
    void add (KM_CoordMotionStraightFeedSixAxisHandler^ value);
    void remove (KM_CoordMotionStraightFeedSixAxisHandler^ value);
}

Value

KM_CoordMotionStraightFeedSixAxisHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionStraightTraverse Event

KM_CoordMotionCoordMotionStraightTraverse Event

Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionStraightTraverseHandler CoordMotionStraightTraverse
Public Event CoordMotionStraightTraverse As KM_CoordMotionStraightTraverseHandler
public:
 event KM_CoordMotionStraightTraverseHandler^ CoordMotionStraightTraverse {
    void add (KM_CoordMotionStraightTraverseHandler^ value);
    void remove (KM_CoordMotionStraightTraverseHandler^ value);
}

Value

KM_CoordMotionStraightTraverseHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotion.CoordMotionStraightTraverseSixAxis Event

KM_CoordMotionCoordMotionStraightTraverseSixAxis Event

Event handler to signal the download of a Straight Traverse segment into the Coordmotion buffer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_CoordMotionStraightTraverseSixAxisHandler CoordMotionStraightTraverseSixAxis
Public Event CoordMotionStraightTraverseSixAxis As KM_CoordMotionStraightTraverseSixAxisHandler
public:
 event KM_CoordMotionStraightTraverseSixAxisHandler^ CoordMotionStraightTraverseSixAxis {
    void add (KM_CoordMotionStraightTraverseSixAxisHandler^ value);
    void remove (KM_CoordMotionStraightTraverseSixAxisHandler^ value);
}

Value

KM_CoordMotionStraightTraverseSixAxisHandler
See Also

Reference

KM_CoordMotion Class


KM_CoordMotionArcFeedHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netARC_FEED_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionArcFeedHandler(
    bool ZeroLenAsFullCircles,
    double DesiredFeedRate_in_per_sec,
    int plane,
    double first_end,
    double second_end,
    double first_axis,
    double second_axis,
    int rotation,
    double axis_end_point,
    double first_start,
    double second_start,
    double axis_start_point,
    int sequence_number,
    int ID
)
Public Delegate Sub KM_CoordMotionArcFeedHandler (
    ZeroLenAsFullCircles As Boolean,
    DesiredFeedRate_in_per_sec As Double,
    plane As Integer,
    first_end As Double,
    second_end As Double,
    first_axis As Double,
    second_axis As Double,
    rotation As Integer,
    axis_end_point As Double,
    first_start As Double,
    second_start As Double,
    axis_start_point As Double,
    sequence_number As Integer,
    ID As Integer
)
public delegate void KM_CoordMotionArcFeedHandler(
    bool ZeroLenAsFullCircles,
    double DesiredFeedRate_in_per_sec,
    int plane,
    double first_end,
    double second_end,
    double first_axis,
    double second_axis,
    int rotation,
    double axis_end_point,
    double first_start,
    double second_start,
    double axis_start_point,
    int sequence_number,
    int ID
)

Parameters

ZeroLenAsFullCircles Boolean
DesiredFeedRate_in_per_sec Double
Requested Feedrate (may have been adjusted by the Tplanner)
plane Int32
CANON_PLANE arc is being commanded
first_end Double
Localized "X" end point
second_end Double
Localized "Y" end point
first_axis Double
Localized "X" center point
second_axis Double
Localized "Y" center point
rotation Int32
Rotation of arc 0=CW 1 = CCW
axis_end_point Double
Final Z position for helix calls
first_start Double
Localized "X" start point
second_start Double
Localized "Y" start point
axis_start_point Double
Initial Z position for helix calls
sequence_number Int32
User supplied sequence
ID Int32
User supplied geometry ID
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotionArcFeedSixAxisHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netARC_FEED_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionArcFeedSixAxisHandler(
    bool ZeroLenAsFullCircles,
    double DesiredFeedRate_in_per_sec,
    int plane,
    double first_end,
    double second_end,
    double first_axis,
    double second_axis,
    int rotation,
    double axis_end_point,
    double a,
    double b,
    double c,
    double first_start,
    double second_start,
    double axis_start_point,
    int sequence_number,
    int ID
)
Public Delegate Sub KM_CoordMotionArcFeedSixAxisHandler (
    ZeroLenAsFullCircles As Boolean,
    DesiredFeedRate_in_per_sec As Double,
    plane As Integer,
    first_end As Double,
    second_end As Double,
    first_axis As Double,
    second_axis As Double,
    rotation As Integer,
    axis_end_point As Double,
    a As Double,
    b As Double,
    c As Double,
    first_start As Double,
    second_start As Double,
    axis_start_point As Double,
    sequence_number As Integer,
    ID As Integer
)
public delegate void KM_CoordMotionArcFeedSixAxisHandler(
    bool ZeroLenAsFullCircles,
    double DesiredFeedRate_in_per_sec,
    int plane,
    double first_end,
    double second_end,
    double first_axis,
    double second_axis,
    int rotation,
    double axis_end_point,
    double a,
    double b,
    double c,
    double first_start,
    double second_start,
    double axis_start_point,
    int sequence_number,
    int ID
)

Parameters

ZeroLenAsFullCircles Boolean
DesiredFeedRate_in_per_sec Double
Requested Feedrate (may have been adjusted by the Tplanner)
plane Int32
CANON_PLANE arc is being commanded
first_end Double
Localized "X" end point
second_end Double
Localized "Y" end point
first_axis Double
Localized "X" center point
second_axis Double
Localized "Y" center point
rotation Int32
Rotation of arc 0=CW 1 = CCW
axis_end_point Double
Final Z position for helix calls
a Double
Final A position
b Double
Final B position
c Double
Final C position
first_start Double
Localized "X" start point
second_start Double
Localized "Y" start point
axis_start_point Double
Initial Z position for helix calls
sequence_number Int32
User supplied sequence
ID Int32
User supplied geometry ID
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotionStraightFeedHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_FEED_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionStraightFeedHandler(
    double DesiredFeedRate_in_per_sec,
    double x,
    double y,
    double z,
    int sequence_number,
    int ID
)
Public Delegate Sub KM_CoordMotionStraightFeedHandler (
    DesiredFeedRate_in_per_sec As Double,
    x As Double,
    y As Double,
    z As Double,
    sequence_number As Integer,
    ID As Integer
)
public delegate void KM_CoordMotionStraightFeedHandler(
    double DesiredFeedRate_in_per_sec,
    double x,
    double y,
    double z,
    int sequence_number,
    int ID
)

Parameters

DesiredFeedRate_in_per_sec Double
Requested Feedrate (may have been adjusted by the Tplanner)
x Double
X destination
y Double
Y destination
z Double
Z destination
sequence_number Int32
User supplied sequence
ID Int32
User supplied geometry ID
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotionStraightFeedSixAxisHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_FEED_SIX_AXIS_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionStraightFeedSixAxisHandler(
    double DesiredFeedRate_in_per_sec,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)
Public Delegate Sub KM_CoordMotionStraightFeedSixAxisHandler (
    DesiredFeedRate_in_per_sec As Double,
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer,
    ID As Integer
)
public delegate void KM_CoordMotionStraightFeedSixAxisHandler(
    double DesiredFeedRate_in_per_sec,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number,
    int ID
)

Parameters

DesiredFeedRate_in_per_sec Double
Requested Feedrate (may have been adjusted by the Tplanner)
x Double
X destination
y Double
Y destination
z Double
Z destination
a Double
A destination
b Double
B destination
c Double
C destination
sequence_number Int32
User supplied sequence
ID Int32
User supplied geometry ID
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotionStraightTraverseHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_TRAVERSE_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionStraightTraverseHandler(
    double x,
    double y,
    double z,
    int sequence_number
)
Public Delegate Sub KM_CoordMotionStraightTraverseHandler (
    x As Double,
    y As Double,
    z As Double,
    sequence_number As Integer
)
public delegate void KM_CoordMotionStraightTraverseHandler(
    double x,
    double y,
    double z,
    int sequence_number
)

Parameters

x Double
X destination
y Double
Y destination
z Double
Z destination
sequence_number Int32
User supplied sequence
See Also

Reference

KMotion_dotNet Namespace


KM_CoordMotionStraightTraverseSixAxisHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netSTRAIGHT_TRAVERSE_SIX_AXIS_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_CoordMotionStraightTraverseSixAxisHandler(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number
)
Public Delegate Sub KM_CoordMotionStraightTraverseSixAxisHandler (
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    sequence_number As Integer
)
public delegate void KM_CoordMotionStraightTraverseSixAxisHandler(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    int sequence_number
)

Parameters

x Double
X destination
y Double
Y destination
z Double
Z destination
a Double
A destination
b Double
B destination
c Double
C destination
sequence_number Int32
User supplied sequence
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter Class

Interpreter class representing the GCodeInterpreter.cpp object from the C++ Dynotion Code Use to control multiple axis motion from the NIST RS274 Interpreter
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Interpreter : IDisposable
Public Class KM_Interpreter
    Implements IDisposable
public ref class KM_Interpreter : IDisposable

The KM_Interpreter type exposes the following members.

Constructors
 | Name | Description
Public method | KM_Interpreter | Primary constructor for the KM_Interpreter object
Top
Properties
 | Name | Description
Public property | CanResume | Enables Resuming after a Halt or Tool Change
Public property | Handle | CCoordMotion class instance pointer
Public property | InitializeOnExecute | Specifies whether or not the Interpreter should be intialized before execution
Public property | InterpretThreadID | The Worker Thread ID of the GCode Interpreter
Public property | InvokeThreadID | The Worker Thread ID of the GCode Interpreter Invoke Action
Public property | IsAbort | Returns true if the CoordMotion is aborting
Public property | IsHalt | Returns true if the CoordMotion is halted
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | ReadToolFile | Specifies whether or not the Interpreter should read the Tool file before execution
Public property | ResumeDoSafeFeedZ | specifies if the Z should then be fed down to some height
Public property | ResumeFeedRate | Specifies Rate at which feed rate should be restored to before continuing GCode
Public property | ResumeFeedSafeZ | Specifies height Z should be fed down to
Public property | ResumeMoveToSafeZ | Specifies whether or not the Z should be first moved up
Public property | ResumeRestoreFeedRate | Specifies whether or not the specified feed rate should be restored
Public property | ResumeSafeRelAbs | Specifies if the Z heights are Absolute or Relative
Public property | ResumeSafeSpindleCWCCW | Specifies Spindle direction if it is to be re-started
Public property | ResumeSafeStartSpindle | Specifies if the Spindle should be re-started
Public property | ResumeSafeZ | Safe Z height to be raised to.
Public property | ResumeTraverseSafeX | Position in X on Resume
Public property | ResumeTraverseSafeY | Position in Y on Resume
Public property | ResumeTraverseXY | Specifies whether it is OK to move back to an XY position
Public property | ResumeZFeedRate | Specifies Rate at which Z feed rate should be set at
Public property | SetupFile | File path for the EMC setup parameters
Public property | SetupParams | Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run
Public property | ToolFile | File path for the EMC style Tool File
Public property | VarsFile | File path for the EMC Vars file
Top
Methods
 | Name | Description
Public method | Abort | Abort Intpreter Execution
Public method | ChangeFixtureNumber | Set the current fixture
Public method | ConvertAbsoluteToInterpreterCoord | Convert Absolute to Interpreter Coordinates
Public method | ConvertAbsoluteToMachine | Convert Absolute to Machine Coordinates
Public method | ConvertAbsToUserUnitsA | Takes ABS "A" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsB | Takes ABS "B" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsC | Takes ABS "C" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsX | Takes ABS "X" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsY | Takes ABS "Y" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsZ | Takes ABS "Z" value and translates to Iterpreter User Units
Public method | Dispose | Releases the object resources
Public method | DoExecute | Internal Use only?
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecutePC | Calling this spawns a Windows PC Application by the specified name
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Protected method | Get_CanResume | Get KM_Interpreter possible to resume after a halt
Public method | Get_InterpretWin32ThreadID | Return the current Thread ID as a Win32 Identifier useful in comparing Thead IDs with Interpreter Worker Thread
Protected method | Get_ResumeDoSafeFeedZ | Get KM_Interpreter Safe Resume Z Feed to be performed
Protected method | Get_ResumeFeedRate | Get KM_Interpreter Safe Resume Feed Rate to be used
Protected method | Get_ResumeFeedSafeZ | Get KM_Interpreter Safe Resume Z Feed Rate to be used
Protected method | Get_ResumeMoveToSafeZ | Get KM_Interpreter Safe Z Motion to be performed or not
Protected method | Get_ResumeRestoreFeedRate | Get KM_Interpreter Safe Resume Feed Rate to be restored or not
Protected method | Get_ResumeSafeRelAbs | Get KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel
Protected method | Get_ResumeSafeSpindleCWCCW | Get KM_Interpreter Safe Resume Start Spindle Direction to be performed
Protected method | Get_ResumeSafeStartSpindle | Get KM_Interpreter Safe Resume Start Spindle to be performed
Protected method | Get_ResumeSafeZ | Get KM_Interpreter Safe Z height for Resume sequence
Protected method | Get_ResumeTraverseSafeX | Get KM_Interpreter XY Traverse Safe Motion to be performed
Protected method | Get_ResumeTraverseSafeY | Get KM_Interpreter Traverse Safe Motion Y Position
Protected method | Get_ResumeTraverseXY | Get KM_Interpreter XY Traverse Motion to be performed
Protected method | Get_ResumeZFeedRate | Get KM_Interpreter Safe Resume Z Feed Rate to be used
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Protected method | GetIsAbort | KM_Interpreter Abort Condition
Protected method | GetIsHalt | KM_Interpreter Halt Condition
Public method | GetMcodeAction | Gets an MCode Action definition
Public method | GetOrigin | Gets the Origin offset
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt Intpreter Execution
Public method | InchesToUserUnits | Takes in an inch value and returns the value in Interpreter's current units
Public method | InitializeInterpreter | Resets the interpreter params to the inital state
Public method | Interpret(String) | Interpret an entire File
Public method | Interpret(String, Int32, Int32, Int32) | Interpret a File with the functionality to only interpret a portion of the file (useful for resuming execution after a program stoppage)
Public method | InvokeAction | Invokes a preset "Action" Will need clarification on how to setup these Actions
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadAndSynchCurInterpreterPosition | Syncronizes the Interpreter Position to the current Axes Positions
Public method | ReadCurInterpreterPosition | Syncronizes the Interpreter Position to the current Axes Positions
Public method | ReadCurMachinePosition | Read Hardware and convert to Absolute Machine Coordinates
Public method | SaveVars | Saves Interpreter GCode Variables to disk in filename specified by VarsFile
Protected method | Set_CanResume | Set KM_Interpreter possible to resume after a halt
Protected method | Set_ResumeDoSafeFeedZ | Set KM_Interpreter Safe Resume Z Feed to be performed
Protected method | Set_ResumeFeedRate | Set KM_Interpreter Safe Resume Feed Rate to be used
Protected method | Set_ResumeFeedSafeZ | Set KM_Interpreter Safe Resume Z Feed Rate to be used
Protected method | Set_ResumeMoveToSafeZ | Set KM_Interpreter Safe Z Motion to be performed
Protected method | Set_ResumeRestoreFeedRate | Set KM_Interpreter Safe Resume Feed Rate to be restored or not
Protected method | Set_ResumeSafeRelAbs | Set KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel
Protected method | Set_ResumeSafeSpindleCWCCW | Set KM_Interpreter Safe Resume Start Spindle Direction to be performed
Protected method | Set_ResumeSafeStartSpindle | Set KM_Interpreter Safe Resume Start Spindle to be performed
Protected method | Set_ResumeSafeZ | Set KM_Interpreter Safe Z height for Resume sequence
Protected method | Set_ResumeTraverseSafeX | Set KM_Interpreter Traverse Safe Motion X Position
Protected method | Set_ResumeTraverseSafeY | Set KM_Interpreter Traverse Safe Motion Y Position
Protected method | Set_ResumeTraverseXY | Set KM_Interpreter XY Traverse Safe Motion to be performed
Protected method | Set_ResumeZFeedRate | Set KM_Interpreter Safe Resume Z Feed Rate to be used
Public method | SetMcodeAction | Sets an MCode Action definition
Public method | SetOrigin | Sets the origin offset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UserUnitsToInches | Takes in a value as Interpreter's current units and returns the value in Inches
Top
Events
 | Name | Description
Public event | InterpreterCompleted | Event handler to signal that Interpreter has completed
Public event | InterpreterStatusUpdated | Event handler to signal that Interpreter Status has been updated
Public event | InterpreterUserCallbackRequested | Event handler to signal that a User Callback has been issued Blocks interpretation until handled by subscriber(s)
Public event | InterpreterUserMCodeCallbackRequested | Event handler to signal that a User MCode Callback has been issued Blocks interpretation until handled by subscriber(s)
Top
Fields
 | Name | Description
Protected field | _ErrorLength | Maximum allowed return error string length
Protected field | _InstanceHandle | CCoordMotion class instance pointer
Protected field | _Loaded | Flag to determine that this object has been properly initialized
Protected field | _SetupParams | Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run
Protected field | InterpreterCompletedHandler | Internal Interpreter Complete callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterStatusUpdatedHandler | Internal Interpreter Status callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterUserCallbackRequestedHandler | Internal Interpreter UserCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterUserMCodeCallbackRequestedHandler | Internal Interpreter UserMcodeCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter Constructor

Primary constructor for the KM_Interpreter object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Interpreter(
    KM_CoordMotion coordmotion
)
Public Sub New (
    coordmotion As KM_CoordMotion
)
public:
KM_Interpreter(
    KM_CoordMotion^ coordmotion
)

Parameters

coordmotion KM_CoordMotion
KM_CoordMotion object to associate the Interpreter with
See Also

Reference

KM_Interpreter Class


KM_Interpreter Properties

The KM_Interpreter type exposes the following members.

Properties
 | Name | Description
Public property | CanResume | Enables Resuming after a Halt or Tool Change
Public property | Handle | CCoordMotion class instance pointer
Public property | InitializeOnExecute | Specifies whether or not the Interpreter should be intialized before execution
Public property | InterpretThreadID | The Worker Thread ID of the GCode Interpreter
Public property | InvokeThreadID | The Worker Thread ID of the GCode Interpreter Invoke Action
Public property | IsAbort | Returns true if the CoordMotion is aborting
Public property | IsHalt | Returns true if the CoordMotion is halted
Public property | Loaded | Flag to determine that this object has been properly initialized
Public property | MaxErrorLength | Maximum allowed return error string length
Public property | ReadToolFile | Specifies whether or not the Interpreter should read the Tool file before execution
Public property | ResumeDoSafeFeedZ | specifies if the Z should then be fed down to some height
Public property | ResumeFeedRate | Specifies Rate at which feed rate should be restored to before continuing GCode
Public property | ResumeFeedSafeZ | Specifies height Z should be fed down to
Public property | ResumeMoveToSafeZ | Specifies whether or not the Z should be first moved up
Public property | ResumeRestoreFeedRate | Specifies whether or not the specified feed rate should be restored
Public property | ResumeSafeRelAbs | Specifies if the Z heights are Absolute or Relative
Public property | ResumeSafeSpindleCWCCW | Specifies Spindle direction if it is to be re-started
Public property | ResumeSafeStartSpindle | Specifies if the Spindle should be re-started
Public property | ResumeSafeZ | Safe Z height to be raised to.
Public property | ResumeTraverseSafeX | Position in X on Resume
Public property | ResumeTraverseSafeY | Position in Y on Resume
Public property | ResumeTraverseXY | Specifies whether it is OK to move back to an XY position
Public property | ResumeZFeedRate | Specifies Rate at which Z feed rate should be set at
Public property | SetupFile | File path for the EMC setup parameters
Public property | SetupParams | Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run
Public property | ToolFile | File path for the EMC style Tool File
Public property | VarsFile | File path for the EMC Vars file
Top
See Also

Reference

KM_Interpreter Class


KM_Interpreter.CanResume Property

KM_InterpreterCanResume Property

Enables Resuming after a Halt or Tool Change

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool CanResume { get; set; }
Public Property CanResume As Boolean
    Get
    Set
public:
property bool CanResume {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Handle Property

KM_InterpreterHandle Property

CCoordMotion class instance pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Handle { get; }
Public ReadOnly Property Handle As Integer
    Get
public:
property int Handle {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InitializeOnExecute Property

KM_InterpreterInitializeOnExecute Property

Specifies whether or not the Interpreter should be intialized before execution

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool InitializeOnExecute { get; set; }
Public Property InitializeOnExecute As Boolean
    Get
    Set
public:
property bool InitializeOnExecute {
    bool get ();
    void set (bool value);
}

Return Value

Boolean
true if the Interpreter should be initialized
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpretThreadID Property

KM_InterpreterInterpretThreadID Property

The Worker Thread ID of the GCode Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InterpretThreadID { get; }
Public ReadOnly Property InterpretThreadID As Integer
    Get
public:
property int InterpretThreadID {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InvokeThreadID Property

KM_InterpreterInvokeThreadID Property

The Worker Thread ID of the GCode Interpreter Invoke Action

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InvokeThreadID { get; }
Public ReadOnly Property InvokeThreadID As Integer
    Get
public:
property int InvokeThreadID {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.IsAbort Property

KM_InterpreterIsAbort Property

Returns true if the CoordMotion is aborting

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsAbort { get; }
Public ReadOnly Property IsAbort As Boolean
    Get
public:
property bool IsAbort {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.IsHalt Property

KM_InterpreterIsHalt Property

Returns true if the CoordMotion is halted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool IsHalt { get; }
Public ReadOnly Property IsHalt As Boolean
    Get
public:
property bool IsHalt {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Loaded Property

KM_InterpreterLoaded Property

Flag to determine that this object has been properly initialized

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool Loaded { get; set; }
Public Property Loaded As Boolean
    Get
    Set
public:
property bool Loaded {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.MaxErrorLength Property

KM_InterpreterMaxErrorLength Property

Maximum allowed return error string length

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int MaxErrorLength { get; set; }
Public Property MaxErrorLength As Integer
    Get
    Set
public:
property int MaxErrorLength {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ReadToolFile Property

KM_InterpreterReadToolFile Property

Specifies whether or not the Interpreter should read the Tool file before execution

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ReadToolFile { get; set; }
Public Property ReadToolFile As Boolean
    Get
    Set
public:
property bool ReadToolFile {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeDoSafeFeedZ Property

KM_InterpreterResumeDoSafeFeedZ Property

specifies if the Z should then be fed down to some height

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ResumeDoSafeFeedZ { get; set; }
Public Property ResumeDoSafeFeedZ As Boolean
    Get
    Set
public:
property bool ResumeDoSafeFeedZ {
    bool get ();
    void set (bool value);
}

Return Value

Boolean
true if feed should be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeFeedRate Property

KM_InterpreterResumeFeedRate Property

Specifies Rate at which feed rate should be restored to before continuing GCode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeFeedRate { get; set; }
Public Property ResumeFeedRate As Double
    Get
    Set
public:
property double ResumeFeedRate {
    double get ();
    void set (double value);
}

Return Value

Double
Rate in ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeFeedSafeZ Property

KM_InterpreterResumeFeedSafeZ Property

Specifies height Z should be fed down to

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeFeedSafeZ { get; set; }
Public Property ResumeFeedSafeZ As Double
    Get
    Set
public:
property double ResumeFeedSafeZ {
    double get ();
    void set (double value);
}

Return Value

Double
height in inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeMoveToSafeZ Property

KM_InterpreterResumeMoveToSafeZ Property

Specifies whether or not the Z should be first moved up

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ResumeMoveToSafeZ { get; set; }
Public Property ResumeMoveToSafeZ As Boolean
    Get
    Set
public:
property bool ResumeMoveToSafeZ {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeRestoreFeedRate Property

KM_InterpreterResumeRestoreFeedRate Property

Specifies whether or not the specified feed rate should be restored

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ResumeRestoreFeedRate { get; set; }
Public Property ResumeRestoreFeedRate As Boolean
    Get
    Set
public:
property bool ResumeRestoreFeedRate {
    bool get ();
    void set (bool value);
}

Return Value

Boolean
true if feed should be restored
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeSafeRelAbs Property

KM_InterpreterResumeSafeRelAbs Property

Specifies if the Z heights are Absolute or Relative

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ResumeSafeRelAbs { get; set; }
Public Property ResumeSafeRelAbs As Integer
    Get
    Set
public:
property int ResumeSafeRelAbs {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeSafeSpindleCWCCW Property

KM_InterpreterResumeSafeSpindleCWCCW Property

Specifies Spindle direction if it is to be re-started

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ResumeSafeSpindleCWCCW { get; set; }
Public Property ResumeSafeSpindleCWCCW As Integer
    Get
    Set
public:
property int ResumeSafeSpindleCWCCW {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeSafeStartSpindle Property

KM_InterpreterResumeSafeStartSpindle Property

Specifies if the Spindle should be re-started

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ResumeSafeStartSpindle { get; set; }
Public Property ResumeSafeStartSpindle As Boolean
    Get
    Set
public:
property bool ResumeSafeStartSpindle {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeSafeZ Property

KM_InterpreterResumeSafeZ Property

Safe Z height to be raised to.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeSafeZ { get; set; }
Public Property ResumeSafeZ As Double
    Get
    Set
public:
property double ResumeSafeZ {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeTraverseSafeX Property

KM_InterpreterResumeTraverseSafeX Property

Position in X on Resume

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeTraverseSafeX { get; set; }
Public Property ResumeTraverseSafeX As Double
    Get
    Set
public:
property double ResumeTraverseSafeX {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeTraverseSafeY Property

KM_InterpreterResumeTraverseSafeY Property

Position in Y on Resume

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeTraverseSafeY { get; set; }
Public Property ResumeTraverseSafeY As Double
    Get
    Set
public:
property double ResumeTraverseSafeY {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeTraverseXY Property

KM_InterpreterResumeTraverseXY Property

Specifies whether it is OK to move back to an XY position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ResumeTraverseXY { get; set; }
Public Property ResumeTraverseXY As Boolean
    Get
    Set
public:
property bool ResumeTraverseXY {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ResumeZFeedRate Property

KM_InterpreterResumeZFeedRate Property

Specifies Rate at which Z feed rate should be set at

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ResumeZFeedRate { get; set; }
Public Property ResumeZFeedRate As Double
    Get
    Set
public:
property double ResumeZFeedRate {
    double get ();
    void set (double value);
}

Return Value

Double
Rate in ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.SetupFile Property

KM_InterpreterSetupFile Property

File path for the EMC setup parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string SetupFile { get; set; }
Public Property SetupFile As String
    Get
    Set
public:
property String^ SetupFile {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Interpreter Class


KM_Interpreter.SetupParams Property

KM_InterpreterSetupParams Property

Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_InterpreterKM_Interpreter_SetupParams SetupParams { get; }
Public ReadOnly Property SetupParams As KM_InterpreterKM_Interpreter_SetupParams
    Get
public:
property KM_InterpreterKM_Interpreter_SetupParams^ SetupParams {
    KM_InterpreterKM_Interpreter_SetupParams^ get ();
}

Property Value

KM_InterpreterKM_Interpreter_SetupParams
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ToolFile Property

KM_InterpreterToolFile Property

File path for the EMC style Tool File

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string ToolFile { get; set; }
Public Property ToolFile As String
    Get
    Set
public:
property String^ ToolFile {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Interpreter Class


KM_Interpreter.VarsFile Property

KM_InterpreterVarsFile Property

File path for the EMC Vars file

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string VarsFile { get; set; }
Public Property VarsFile As String
    Get
    Set
public:
property String^ VarsFile {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_Interpreter Class


KM_Interpreter Methods

The KM_Interpreter type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Abort Intpreter Execution
Public method | ChangeFixtureNumber | Set the current fixture
Public method | ConvertAbsoluteToInterpreterCoord | Convert Absolute to Interpreter Coordinates
Public method | ConvertAbsoluteToMachine | Convert Absolute to Machine Coordinates
Public method | ConvertAbsToUserUnitsA | Takes ABS "A" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsB | Takes ABS "B" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsC | Takes ABS "C" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsX | Takes ABS "X" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsY | Takes ABS "Y" value and translates to Iterpreter User Units
Public method | ConvertAbsToUserUnitsZ | Takes ABS "Z" value and translates to Iterpreter User Units
Public method | Dispose | Releases the object resources
Public method | DoExecute | Internal Use only?
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecutePC | Calling this spawns a Windows PC Application by the specified name
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Protected method | Get_CanResume | Get KM_Interpreter possible to resume after a halt
Public method | Get_InterpretWin32ThreadID | Return the current Thread ID as a Win32 Identifier useful in comparing Thead IDs with Interpreter Worker Thread
Protected method | Get_ResumeDoSafeFeedZ | Get KM_Interpreter Safe Resume Z Feed to be performed
Protected method | Get_ResumeFeedRate | Get KM_Interpreter Safe Resume Feed Rate to be used
Protected method | Get_ResumeFeedSafeZ | Get KM_Interpreter Safe Resume Z Feed Rate to be used
Protected method | Get_ResumeMoveToSafeZ | Get KM_Interpreter Safe Z Motion to be performed or not
Protected method | Get_ResumeRestoreFeedRate | Get KM_Interpreter Safe Resume Feed Rate to be restored or not
Protected method | Get_ResumeSafeRelAbs | Get KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel
Protected method | Get_ResumeSafeSpindleCWCCW | Get KM_Interpreter Safe Resume Start Spindle Direction to be performed
Protected method | Get_ResumeSafeStartSpindle | Get KM_Interpreter Safe Resume Start Spindle to be performed
Protected method | Get_ResumeSafeZ | Get KM_Interpreter Safe Z height for Resume sequence
Protected method | Get_ResumeTraverseSafeX | Get KM_Interpreter XY Traverse Safe Motion to be performed
Protected method | Get_ResumeTraverseSafeY | Get KM_Interpreter Traverse Safe Motion Y Position
Protected method | Get_ResumeTraverseXY | Get KM_Interpreter XY Traverse Motion to be performed
Protected method | Get_ResumeZFeedRate | Get KM_Interpreter Safe Resume Z Feed Rate to be used
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Protected method | GetIsAbort | KM_Interpreter Abort Condition
Protected method | GetIsHalt | KM_Interpreter Halt Condition
Public method | GetMcodeAction | Gets an MCode Action definition
Public method | GetOrigin | Gets the Origin offset
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Halt | Halt Intpreter Execution
Public method | InchesToUserUnits | Takes in an inch value and returns the value in Interpreter's current units
Public method | InitializeInterpreter | Resets the interpreter params to the inital state
Public method | Interpret(String) | Interpret an entire File
Public method | Interpret(String, Int32, Int32, Int32) | Interpret a File with the functionality to only interpret a portion of the file (useful for resuming execution after a program stoppage)
Public method | InvokeAction | Invokes a preset "Action" Will need clarification on how to setup these Actions
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ReadAndSynchCurInterpreterPosition | Syncronizes the Interpreter Position to the current Axes Positions
Public method | ReadCurInterpreterPosition | Syncronizes the Interpreter Position to the current Axes Positions
Public method | ReadCurMachinePosition | Read Hardware and convert to Absolute Machine Coordinates
Public method | SaveVars | Saves Interpreter GCode Variables to disk in filename specified by VarsFile
Protected method | Set_CanResume | Set KM_Interpreter possible to resume after a halt
Protected method | Set_ResumeDoSafeFeedZ | Set KM_Interpreter Safe Resume Z Feed to be performed
Protected method | Set_ResumeFeedRate | Set KM_Interpreter Safe Resume Feed Rate to be used
Protected method | Set_ResumeFeedSafeZ | Set KM_Interpreter Safe Resume Z Feed Rate to be used
Protected method | Set_ResumeMoveToSafeZ | Set KM_Interpreter Safe Z Motion to be performed
Protected method | Set_ResumeRestoreFeedRate | Set KM_Interpreter Safe Resume Feed Rate to be restored or not
Protected method | Set_ResumeSafeRelAbs | Set KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel
Protected method | Set_ResumeSafeSpindleCWCCW | Set KM_Interpreter Safe Resume Start Spindle Direction to be performed
Protected method | Set_ResumeSafeStartSpindle | Set KM_Interpreter Safe Resume Start Spindle to be performed
Protected method | Set_ResumeSafeZ | Set KM_Interpreter Safe Z height for Resume sequence
Protected method | Set_ResumeTraverseSafeX | Set KM_Interpreter Traverse Safe Motion X Position
Protected method | Set_ResumeTraverseSafeY | Set KM_Interpreter Traverse Safe Motion Y Position
Protected method | Set_ResumeTraverseXY | Set KM_Interpreter XY Traverse Safe Motion to be performed
Protected method | Set_ResumeZFeedRate | Set KM_Interpreter Safe Resume Z Feed Rate to be used
Public method | SetMcodeAction | Sets an MCode Action definition
Public method | SetOrigin | Sets the origin offset
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UserUnitsToInches | Takes in a value as Interpreter's current units and returns the value in Inches
Top
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Abort Method

KM_InterpreterAbort Method

Abort Intpreter Execution

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Abort()
Public Sub Abort
public:
void Abort()
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ChangeFixtureNumber Method

KM_InterpreterChangeFixtureNumber Method

Set the current fixture

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ChangeFixtureNumber(
    int fixture
)
Public Function ChangeFixtureNumber (
    fixture As Integer
) As Integer
public:
int ChangeFixtureNumber(
    int fixture
)

Parameters

fixture Int32
Fixture Index

Return Value

Int32
0 if successful else error code
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsoluteToInterpreterCoord Method

KM_InterpreterConvertAbsoluteToInterpreterCoord Method

Convert Absolute to Interpreter Coordinates

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ConvertAbsoluteToInterpreterCoord(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    ref double xp,
    ref double yp,
    ref double zp,
    ref double ap,
    ref double bp,
    ref double cp
)
Public Sub ConvertAbsoluteToInterpreterCoord (
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    ByRef xp As Double,
    ByRef yp As Double,
    ByRef zp As Double,
    ByRef ap As Double,
    ByRef bp As Double,
    ByRef cp As Double
)
public:
void ConvertAbsoluteToInterpreterCoord(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    double% xp,
    double% yp,
    double% zp,
    double% ap,
    double% bp,
    double% cp
)

Parameters

x Double
X Passed in Absolute Coordinate
y Double
Y Passed in Absolute Coordinate
z Double
Z Passed in Absolute Coordinate
a Double
a Passed in Absolute Coordinate
b Double
b Passed in Absolute Coordinate
c Double
c Passed in Absolute Coordinate
xp Double
X returned Interpreter Coordinate
yp Double
Y returned Interpreter Coordinate
zp Double
Z returned Interpreter Coordinate
ap Double
a returned Interpreter Coordinate
bp Double
b returned Interpreter Coordinate
cp Double
c returned Interpreter Coordinate
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsoluteToMachine Method

KM_InterpreterConvertAbsoluteToMachine Method

Convert Absolute to Machine Coordinates

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ConvertAbsoluteToMachine(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    ref double xp,
    ref double yp,
    ref double zp,
    ref double ap,
    ref double bp,
    ref double cp
)
Public Sub ConvertAbsoluteToMachine (
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double,
    ByRef xp As Double,
    ByRef yp As Double,
    ByRef zp As Double,
    ByRef ap As Double,
    ByRef bp As Double,
    ByRef cp As Double
)
public:
void ConvertAbsoluteToMachine(
    double x,
    double y,
    double z,
    double a,
    double b,
    double c,
    double% xp,
    double% yp,
    double% zp,
    double% ap,
    double% bp,
    double% cp
)

Parameters

x Double
X Passed in Absolute Coordinate
y Double
Y Passed in Absolute Coordinate
z Double
Z Passed in Absolute Coordinate
a Double
a Passed in Absolute Coordinate
b Double
b Passed in Absolute Coordinate
c Double
c Passed in Absolute Coordinate
xp Double
X returned Machine Coordinate
yp Double
Y returned Machine Coordinate
zp Double
Z returned Machine Coordinate
ap Double
a returned Machine Coordinate
bp Double
b returned Machine Coordinate
cp Double
c returned Machine Coordinate
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsA Method

KM_InterpreterConvertAbsToUserUnitsA Method

Takes ABS "A" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsA(
    double a
)
Public Function ConvertAbsToUserUnitsA (
    a As Double
) As Double
public:
double ConvertAbsToUserUnitsA(
    double a
)

Parameters

a Double
ABS value

Return Value

Double
Current A value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsB Method

KM_InterpreterConvertAbsToUserUnitsB Method

Takes ABS "B" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsB(
    double b
)
Public Function ConvertAbsToUserUnitsB (
    b As Double
) As Double
public:
double ConvertAbsToUserUnitsB(
    double b
)

Parameters

b Double
ABS value

Return Value

Double
Current B value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsC Method

KM_InterpreterConvertAbsToUserUnitsC Method

Takes ABS "C" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsC(
    double c
)
Public Function ConvertAbsToUserUnitsC (
    c As Double
) As Double
public:
double ConvertAbsToUserUnitsC(
    double c
)

Parameters

c Double
ABS value

Return Value

Double
Current C value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsX Method

KM_InterpreterConvertAbsToUserUnitsX Method

Takes ABS "X" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsX(
    double x
)
Public Function ConvertAbsToUserUnitsX (
    x As Double
) As Double
public:
double ConvertAbsToUserUnitsX(
    double x
)

Parameters

x Double
ABS value

Return Value

Double
Current X value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsY Method

KM_InterpreterConvertAbsToUserUnitsY Method

Takes ABS "Y" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsY(
    double y
)
Public Function ConvertAbsToUserUnitsY (
    y As Double
) As Double
public:
double ConvertAbsToUserUnitsY(
    double y
)

Parameters

y Double
ABS value

Return Value

Double
Current Y value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ConvertAbsToUserUnitsZ Method

KM_InterpreterConvertAbsToUserUnitsZ Method

Takes ABS "Z" value and translates to Iterpreter User Units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ConvertAbsToUserUnitsZ(
    double z
)
Public Function ConvertAbsToUserUnitsZ (
    z As Double
) As Double
public:
double ConvertAbsToUserUnitsZ(
    double z
)

Parameters

z Double
ABS value

Return Value

Double
Current Z value in User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Dispose Method

KM_InterpreterDispose Method

Releases the object resources

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

KM_Interpreter Class


KM_Interpreter.DoExecute Method

KM_InterpreterDoExecute Method

Internal Use only?

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int DoExecute()
Public Function DoExecute As Integer
public:
int DoExecute()

Return Value

Int32
1 if successful
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ExecutePC Method

KM_InterpreterExecutePC Method

Calling this spawns a Windows PC Application by the specified name

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ExecutePC(
    string name
)
Public Function ExecutePC (
    name As String
) As Integer
public:
int ExecutePC(
    String^ name
)

Parameters

name String
Path Name of Executable

Return Value

Int32
1 if successful
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_CanResume Method

KM_InterpreterGet_CanResume Method

Get KM_Interpreter possible to resume after a halt

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_CanResume()
Protected Function Get_CanResume As Boolean
protected:
bool Get_CanResume()

Return Value

Boolean
true if resume sequence should be executed before beginning GCode
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_InterpretWin32ThreadID Method

KM_InterpreterGet_InterpretWin32ThreadID Method

Return the current Thread ID as a Win32 Identifier useful in comparing Thead IDs with Interpreter Worker Thread

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Get_InterpretWin32ThreadID()
Public Function Get_InterpretWin32ThreadID As Integer
public:
int Get_InterpretWin32ThreadID()

Return Value

Int32
Returns the current Thread ID
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeDoSafeFeedZ Method

KM_InterpreterGet_ResumeDoSafeFeedZ Method

Get KM_Interpreter Safe Resume Z Feed to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_ResumeDoSafeFeedZ()
Protected Function Get_ResumeDoSafeFeedZ As Boolean
protected:
bool Get_ResumeDoSafeFeedZ()

Return Value

Boolean
true if to be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeFeedRate Method

KM_InterpreterGet_ResumeFeedRate Method

Get KM_Interpreter Safe Resume Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeFeedRate()
Protected Function Get_ResumeFeedRate As Double
protected:
double Get_ResumeFeedRate()

Return Value

Double
Rate ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeFeedSafeZ Method

KM_InterpreterGet_ResumeFeedSafeZ Method

Get KM_Interpreter Safe Resume Z Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeFeedSafeZ()
Protected Function Get_ResumeFeedSafeZ As Double
protected:
double Get_ResumeFeedSafeZ()

Return Value

Double
Feed Rate in ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeMoveToSafeZ Method

KM_InterpreterGet_ResumeMoveToSafeZ Method

Get KM_Interpreter Safe Z Motion to be performed or not

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_ResumeMoveToSafeZ()
Protected Function Get_ResumeMoveToSafeZ As Boolean
protected:
bool Get_ResumeMoveToSafeZ()

Return Value

Boolean
true if motion is to be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeRestoreFeedRate Method

KM_InterpreterGet_ResumeRestoreFeedRate Method

Get KM_Interpreter Safe Resume Feed Rate to be restored or not

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_ResumeRestoreFeedRate()
Protected Function Get_ResumeRestoreFeedRate As Boolean
protected:
bool Get_ResumeRestoreFeedRate()

Return Value

Boolean
true if to be restored
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeSafeRelAbs Method

KM_InterpreterGet_ResumeSafeRelAbs Method

Get KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int Get_ResumeSafeRelAbs()
Protected Function Get_ResumeSafeRelAbs As Integer
protected:
int Get_ResumeSafeRelAbs()

Return Value

Int32
1=abs 0=rel
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeSafeSpindleCWCCW Method

KM_InterpreterGet_ResumeSafeSpindleCWCCW Method

Get KM_Interpreter Safe Resume Start Spindle Direction to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int Get_ResumeSafeSpindleCWCCW()
Protected Function Get_ResumeSafeSpindleCWCCW As Integer
protected:
int Get_ResumeSafeSpindleCWCCW()

Return Value

Int32
0=CW 1=CCW
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeSafeStartSpindle Method

KM_InterpreterGet_ResumeSafeStartSpindle Method

Get KM_Interpreter Safe Resume Start Spindle to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_ResumeSafeStartSpindle()
Protected Function Get_ResumeSafeStartSpindle As Boolean
protected:
bool Get_ResumeSafeStartSpindle()

Return Value

Boolean
true to perform Start Spindle
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeSafeZ Method

KM_InterpreterGet_ResumeSafeZ Method

Get KM_Interpreter Safe Z height for Resume sequence

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeSafeZ()
Protected Function Get_ResumeSafeZ As Double
protected:
double Get_ResumeSafeZ()

Return Value

Double
true if Safe Z Motion is to be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeTraverseSafeX Method

KM_InterpreterGet_ResumeTraverseSafeX Method

Get KM_Interpreter XY Traverse Safe Motion to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeTraverseSafeX()
Protected Function Get_ResumeTraverseSafeX As Double
protected:
double Get_ResumeTraverseSafeX()

Return Value

Double
x position in inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeTraverseSafeY Method

KM_InterpreterGet_ResumeTraverseSafeY Method

Get KM_Interpreter Traverse Safe Motion Y Position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeTraverseSafeY()
Protected Function Get_ResumeTraverseSafeY As Double
protected:
double Get_ResumeTraverseSafeY()

Return Value

Double
Y position in inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeTraverseXY Method

KM_InterpreterGet_ResumeTraverseXY Method

Get KM_Interpreter XY Traverse Motion to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool Get_ResumeTraverseXY()
Protected Function Get_ResumeTraverseXY As Boolean
protected:
bool Get_ResumeTraverseXY()

Return Value

Boolean
true to perform Traverse Motion
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Get_ResumeZFeedRate Method

KM_InterpreterGet_ResumeZFeedRate Method

Get KM_Interpreter Safe Resume Z Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected double Get_ResumeZFeedRate()
Protected Function Get_ResumeZFeedRate As Double
protected:
double Get_ResumeZFeedRate()

Return Value

Double
Feed Rate in ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.GetIsAbort Method

KM_InterpreterGetIsAbort Method

KM_Interpreter Abort Condition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool GetIsAbort()
Protected Function GetIsAbort As Boolean
protected:
bool GetIsAbort()

Return Value

Boolean
true if Aborted
See Also

Reference

KM_Interpreter Class


KM_Interpreter.GetIsHalt Method

KM_InterpreterGetIsHalt Method

KM_Interpreter Halt Condition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool GetIsHalt()
Protected Function GetIsHalt As Boolean
protected:
bool GetIsHalt()

Return Value

Boolean
true if Halted
See Also

Reference

KM_Interpreter Class


KM_Interpreter.GetMcodeAction Method

KM_InterpreterGetMcodeAction Method

Gets an MCode Action definition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void GetMcodeAction(
    int index,
    ref MCODE_TYPE type,
    ref double val1,
    ref double val2,
    ref double val3,
    ref double val4,
    ref double val5,
    ref string name
)
Public Sub GetMcodeAction (
    index As Integer,
    ByRef type As MCODE_TYPE,
    ByRef val1 As Double,
    ByRef val2 As Double,
    ByRef val3 As Double,
    ByRef val4 As Double,
    ByRef val5 As Double,
    ByRef name As String
)
public:
void GetMcodeAction(
    int index,
    MCODE_TYPE% type,
    double% val1,
    double% val2,
    double% val3,
    double% val4,
    double% val5,
    String^% name
)

Parameters

index Int32
mcode ex(M6 = 6)
type MCODE_TYPE
MCODE_TYPE for this action
val1 Double
double param 1 for action
val2 Double
double param 2 for action
val3 Double
double param 3 for action
val4 Double
double param 4 for action
val5 Double
double param 5 for action
name String
mcode name
See Also

Reference

KM_Interpreter Class


KM_Interpreter.GetOrigin Method

KM_InterpreterGetOrigin Method

Gets the Origin offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void GetOrigin(
    int index,
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c
)
Public Sub GetOrigin (
    index As Integer,
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double
)
public:
void GetOrigin(
    int index,
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c
)

Parameters

index Int32
Origin index - 0 for G92 offsets, 1-9 for fixture offsets
x Double
X offset
y Double
Y offset
z Double
Z offset
a Double
a offset
b Double
b offset
c Double
c offset
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Halt Method

KM_InterpreterHalt Method

Halt Intpreter Execution

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Halt()
Public Sub Halt
public:
void Halt()
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InchesToUserUnits Method

KM_InterpreterInchesToUserUnits Method

Takes in an inch value and returns the value in Interpreter's current units

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double InchesToUserUnits(
    double inches
)
Public Function InchesToUserUnits (
    inches As Double
) As Double
public:
double InchesToUserUnits(
    double inches
)

Parameters

inches Double
input inch value

Return Value

Double
Current User Units
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InitializeInterpreter Method

KM_InterpreterInitializeInterpreter Method

Resets the interpreter params to the inital state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void InitializeInterpreter()
Public Sub InitializeInterpreter
public:
void InitializeInterpreter()
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Interpret Method

KM_InterpreterInterpret Method

Overload List
 | Name | Description
Public method | Interpret(String) | Interpret an entire File
Public method | Interpret(String, Int32, Int32, Int32) | Interpret a File with the functionality to only interpret a portion of the file (useful for resuming execution after a program stoppage)
Top
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Interpret(String) Method

KM_InterpreterInterpret(String) Method

Interpret an entire File

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Interpret(
    string fname
)
Public Function Interpret (
    fname As String
) As Integer
public:
int Interpret(
    String^ fname
)

Parameters

fname String
Full path of the file to interpret

Return Value

Int32
Error Code
See Also

Reference

KM_Interpreter Class
Interpret Overload


KM_Interpreter.Interpret(String, Int32, Int32, Int32) Method

KM_InterpreterInterpret(String, Int32, Int32, Int32) Method

Interpret a File with the functionality to only interpret a portion of the file (useful for resuming execution after a program stoppage)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Interpret(
    string fname,
    int start,
    int end,
    int restart
)
Public Function Interpret (
    fname As String,
    start As Integer,
    end As Integer,
    restart As Integer
) As Integer
public:
int Interpret(
    String^ fname,
    int start,
    int end,
    int restart
)

Parameters

fname String
Full path of the file to interpret
start Int32
first line to execute
end Int32
Last line to execute
restart Int32
Reinitializes Interpreter Settings

Return Value

Int32
Error Code
See Also

Reference

KM_Interpreter Class
Interpret Overload


KM_Interpreter.InvokeAction Method

KM_InterpreterInvokeAction Method

Invokes a preset "Action" Will need clarification on how to setup these Actions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InvokeAction(
    int i,
    bool flushbeforeunbufferedoperation
)
Public Function InvokeAction (
    i As Integer,
    flushbeforeunbufferedoperation As Boolean
) As Integer
public:
int InvokeAction(
    int i,
    bool flushbeforeunbufferedoperation
)

Parameters

i Int32
Action index?
flushbeforeunbufferedoperation Boolean
Flush current operations before execution

Return Value

Int32
1 if successful
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ReadAndSynchCurInterpreterPosition Method

KM_InterpreterReadAndSynchCurInterpreterPosition Method

Syncronizes the Interpreter Position to the current Axes Positions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ReadAndSynchCurInterpreterPosition(
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c
)
Public Sub ReadAndSynchCurInterpreterPosition (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double
)
public:
void ReadAndSynchCurInterpreterPosition(
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c
)

Parameters

x Double
X sync'ed position
y Double
Y sync'ed position
z Double
Z sync'ed position
a Double
a sync'ed position
b Double
b sync'ed position
c Double
c sync'ed position
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ReadCurInterpreterPosition Method

KM_InterpreterReadCurInterpreterPosition Method

Syncronizes the Interpreter Position to the current Axes Positions

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ReadCurInterpreterPosition(
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c
)
Public Sub ReadCurInterpreterPosition (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double
)
public:
void ReadCurInterpreterPosition(
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c
)

Parameters

x Double
X sync'ed position
y Double
Y sync'ed position
z Double
Z sync'ed position
a Double
a sync'ed position
b Double
b sync'ed position
c Double
c sync'ed position
See Also

Reference

KM_Interpreter Class


KM_Interpreter.ReadCurMachinePosition Method

KM_InterpreterReadCurMachinePosition Method

Read Hardware and convert to Absolute Machine Coordinates

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void ReadCurMachinePosition(
    ref double x,
    ref double y,
    ref double z,
    ref double a,
    ref double b,
    ref double c
)
Public Sub ReadCurMachinePosition (
    ByRef x As Double,
    ByRef y As Double,
    ByRef z As Double,
    ByRef a As Double,
    ByRef b As Double,
    ByRef c As Double
)
public:
void ReadCurMachinePosition(
    double% x,
    double% y,
    double% z,
    double% a,
    double% b,
    double% c
)

Parameters

x Double
X returned Machine Coordinate
y Double
Y returned Machine Coordinate
z Double
Z returned Machine Coordinate
a Double
a returned Machine Coordinate
b Double
b returned Machine Coordinate
c Double
c returned Machine Coordinate
See Also

Reference

KM_Interpreter Class


KM_Interpreter.SaveVars Method

KM_InterpreterSaveVars Method

Saves Interpreter GCode Variables to disk in filename specified by VarsFile

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool SaveVars()
Public Function SaveVars As Boolean
public:
bool SaveVars()

Return Value

Boolean
Returns true if successful
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_CanResume Method

KM_InterpreterSet_CanResume Method

Set KM_Interpreter possible to resume after a halt

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_CanResume(
    bool value
)
Protected Sub Set_CanResume (
    value As Boolean
)
protected:
void Set_CanResume(
    bool value
)

Parameters

value Boolean
true if possible to resume
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeDoSafeFeedZ Method

KM_InterpreterSet_ResumeDoSafeFeedZ Method

Set KM_Interpreter Safe Resume Z Feed to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeDoSafeFeedZ(
    bool value
)
Protected Sub Set_ResumeDoSafeFeedZ (
    value As Boolean
)
protected:
void Set_ResumeDoSafeFeedZ(
    bool value
)

Parameters

value Boolean
true to perform Z feed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeFeedRate Method

KM_InterpreterSet_ResumeFeedRate Method

Set KM_Interpreter Safe Resume Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeFeedRate(
    double value
)
Protected Sub Set_ResumeFeedRate (
    value As Double
)
protected:
void Set_ResumeFeedRate(
    double value
)

Parameters

value Double
rate ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeFeedSafeZ Method

KM_InterpreterSet_ResumeFeedSafeZ Method

Set KM_Interpreter Safe Resume Z Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeFeedSafeZ(
    double value
)
Protected Sub Set_ResumeFeedSafeZ (
    value As Double
)
protected:
void Set_ResumeFeedSafeZ(
    double value
)

Parameters

value Double
Rate in ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeMoveToSafeZ Method

KM_InterpreterSet_ResumeMoveToSafeZ Method

Set KM_Interpreter Safe Z Motion to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeMoveToSafeZ(
    bool value
)
Protected Sub Set_ResumeMoveToSafeZ (
    value As Boolean
)
protected:
void Set_ResumeMoveToSafeZ(
    bool value
)

Parameters

value Boolean
true to perform Z feed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeRestoreFeedRate Method

KM_InterpreterSet_ResumeRestoreFeedRate Method

Set KM_Interpreter Safe Resume Feed Rate to be restored or not

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeRestoreFeedRate(
    bool value
)
Protected Sub Set_ResumeRestoreFeedRate (
    value As Boolean
)
protected:
void Set_ResumeRestoreFeedRate(
    bool value
)

Parameters

value Boolean
rate ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeSafeRelAbs Method

KM_InterpreterSet_ResumeSafeRelAbs Method

Set KM_Interpreter Safe Z Motion Relative vs Absolute setting 1=abs 0=rel

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeSafeRelAbs(
    int value
)
Protected Sub Set_ResumeSafeRelAbs (
    value As Integer
)
protected:
void Set_ResumeSafeRelAbs(
    int value
)

Parameters

value Int32
1=abs 0=rel
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeSafeSpindleCWCCW Method

KM_InterpreterSet_ResumeSafeSpindleCWCCW Method

Set KM_Interpreter Safe Resume Start Spindle Direction to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeSafeSpindleCWCCW(
    int value
)
Protected Sub Set_ResumeSafeSpindleCWCCW (
    value As Integer
)
protected:
void Set_ResumeSafeSpindleCWCCW(
    int value
)

Parameters

value Int32
0=CW 1=CCW
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeSafeStartSpindle Method

KM_InterpreterSet_ResumeSafeStartSpindle Method

Set KM_Interpreter Safe Resume Start Spindle to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeSafeStartSpindle(
    bool value
)
Protected Sub Set_ResumeSafeStartSpindle (
    value As Boolean
)
protected:
void Set_ResumeSafeStartSpindle(
    bool value
)

Parameters

value Boolean
true if Spindle Start should be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeSafeZ Method

KM_InterpreterSet_ResumeSafeZ Method

Set KM_Interpreter Safe Z height for Resume sequence

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeSafeZ(
    double value
)
Protected Sub Set_ResumeSafeZ (
    value As Double
)
protected:
void Set_ResumeSafeZ(
    double value
)

Parameters

value Double
true if Safe Z Motion is to be performed
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeTraverseSafeX Method

KM_InterpreterSet_ResumeTraverseSafeX Method

Set KM_Interpreter Traverse Safe Motion X Position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeTraverseSafeX(
    double value
)
Protected Sub Set_ResumeTraverseSafeX (
    value As Double
)
protected:
void Set_ResumeTraverseSafeX(
    double value
)

Parameters

value Double
X Position in inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeTraverseSafeY Method

KM_InterpreterSet_ResumeTraverseSafeY Method

Set KM_Interpreter Traverse Safe Motion Y Position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeTraverseSafeY(
    double value
)
Protected Sub Set_ResumeTraverseSafeY (
    value As Double
)
protected:
void Set_ResumeTraverseSafeY(
    double value
)

Parameters

value Double
Y Position in inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeTraverseXY Method

KM_InterpreterSet_ResumeTraverseXY Method

Set KM_Interpreter XY Traverse Safe Motion to be performed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeTraverseXY(
    bool value
)
Protected Sub Set_ResumeTraverseXY (
    value As Boolean
)
protected:
void Set_ResumeTraverseXY(
    bool value
)

Parameters

value Boolean
true to perform Traverse Motion
See Also

Reference

KM_Interpreter Class


KM_Interpreter.Set_ResumeZFeedRate Method

KM_InterpreterSet_ResumeZFeedRate Method

Set KM_Interpreter Safe Resume Z Feed Rate to be used

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void Set_ResumeZFeedRate(
    double value
)
Protected Sub Set_ResumeZFeedRate (
    value As Double
)
protected:
void Set_ResumeZFeedRate(
    double value
)

Parameters

value Double
rate ips
See Also

Reference

KM_Interpreter Class


KM_Interpreter.SetMcodeAction Method

KM_InterpreterSetMcodeAction Method

Sets an MCode Action definition

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetMcodeAction(
    int index,
    MCODE_TYPE type,
    double val1,
    double val2,
    double val3,
    double val4,
    double val5,
    string name
)
Public Sub SetMcodeAction (
    index As Integer,
    type As MCODE_TYPE,
    val1 As Double,
    val2 As Double,
    val3 As Double,
    val4 As Double,
    val5 As Double,
    name As String
)
public:
void SetMcodeAction(
    int index,
    MCODE_TYPE type,
    double val1,
    double val2,
    double val3,
    double val4,
    double val5,
    String^ name
)

Parameters

index Int32
mcode ex(M6 = 6)
type MCODE_TYPE
MCODE_TYPE for this action
val1 Double
double param 1 for action
val2 Double
double param 2 for action
val3 Double
double param 3 for action
val4 Double
double param 4 for action
val5 Double
double param 5 for action
name String
mcode name
See Also

Reference

KM_Interpreter Class


KM_Interpreter.SetOrigin Method

KM_InterpreterSetOrigin Method

Sets the origin offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetOrigin(
    int index,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c
)
Public Sub SetOrigin (
    index As Integer,
    x As Double,
    y As Double,
    z As Double,
    a As Double,
    b As Double,
    c As Double
)
public:
void SetOrigin(
    int index,
    double x,
    double y,
    double z,
    double a,
    double b,
    double c
)

Parameters

index Int32
Origin index - 0 for G92 offsets, 1-9 for fixture offsets
x Double
X offset
y Double
Y offset
z Double
Z offset
a Double
a offset
b Double
b offset
c Double
c offset
See Also

Reference

KM_Interpreter Class


KM_Interpreter.UserUnitsToInches Method

KM_InterpreterUserUnitsToInches Method

Takes in a value as Interpreter's current units and returns the value in Inches

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double UserUnitsToInches(
    double units
)
Public Function UserUnitsToInches (
    units As Double
) As Double
public:
double UserUnitsToInches(
    double units
)

Parameters

units Double
input unit value

Return Value

Double
Inches
See Also

Reference

KM_Interpreter Class


KM_Interpreter Events

The KM_Interpreter type exposes the following members.

Events
 | Name | Description
Public event | InterpreterCompleted | Event handler to signal that Interpreter has completed
Public event | InterpreterStatusUpdated | Event handler to signal that Interpreter Status has been updated
Public event | InterpreterUserCallbackRequested | Event handler to signal that a User Callback has been issued Blocks interpretation until handled by subscriber(s)
Public event | InterpreterUserMCodeCallbackRequested | Event handler to signal that a User MCode Callback has been issued Blocks interpretation until handled by subscriber(s)
Top
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterCompleted Event

KM_InterpreterInterpreterCompleted Event

Event handler to signal that Interpreter has completed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_InterpreterKM_GCodeInterpreterCompleteHandler InterpreterCompleted
Public Event InterpreterCompleted As KM_InterpreterKM_GCodeInterpreterCompleteHandler
public:
 event KM_InterpreterKM_GCodeInterpreterCompleteHandler^ InterpreterCompleted {
    void add (KM_InterpreterKM_GCodeInterpreterCompleteHandler^ value);
    void remove (KM_InterpreterKM_GCodeInterpreterCompleteHandler^ value);
}

Value

KM_InterpreterKM_GCodeInterpreterCompleteHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterStatusUpdated Event

KM_InterpreterInterpreterStatusUpdated Event

Event handler to signal that Interpreter Status has been updated

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_InterpreterKM_GCodeInterpreterStatusHandler InterpreterStatusUpdated
Public Event InterpreterStatusUpdated As KM_InterpreterKM_GCodeInterpreterStatusHandler
public:
 event KM_InterpreterKM_GCodeInterpreterStatusHandler^ InterpreterStatusUpdated {
    void add (KM_InterpreterKM_GCodeInterpreterStatusHandler^ value);
    void remove (KM_InterpreterKM_GCodeInterpreterStatusHandler^ value);
}

Value

KM_InterpreterKM_GCodeInterpreterStatusHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterUserCallbackRequested Event

KM_InterpreterInterpreterUserCallbackRequested Event

Event handler to signal that a User Callback has been issued Blocks interpretation until handled by subscriber(s)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_InterpreterKM_GCodeInterpreterUserCallbackHandler InterpreterUserCallbackRequested
Public Event InterpreterUserCallbackRequested As KM_InterpreterKM_GCodeInterpreterUserCallbackHandler
public:
 event KM_InterpreterKM_GCodeInterpreterUserCallbackHandler^ InterpreterUserCallbackRequested {
    void add (KM_InterpreterKM_GCodeInterpreterUserCallbackHandler^ value);
    void remove (KM_InterpreterKM_GCodeInterpreterUserCallbackHandler^ value);
}

Value

KM_InterpreterKM_GCodeInterpreterUserCallbackHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterUserMCodeCallbackRequested Event

KM_InterpreterInterpreterUserMCodeCallbackRequested Event

Event handler to signal that a User MCode Callback has been issued Blocks interpretation until handled by subscriber(s)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public event KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler InterpreterUserMCodeCallbackRequested
Public Event InterpreterUserMCodeCallbackRequested As KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler
public:
 event KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler^ InterpreterUserMCodeCallbackRequested {
    void add (KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler^ value);
    void remove (KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler^ value);
}

Value

KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter Fields

The KM_Interpreter type exposes the following members.

Fields
 | Name | Description
Protected field | _ErrorLength | Maximum allowed return error string length
Protected field | _InstanceHandle | CCoordMotion class instance pointer
Protected field | _Loaded | Flag to determine that this object has been properly initialized
Protected field | _SetupParams | Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run
Protected field | InterpreterCompletedHandler | Internal Interpreter Complete callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterStatusUpdatedHandler | Internal Interpreter Status callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterUserCallbackRequestedHandler | Internal Interpreter UserCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Protected field | InterpreterUserMCodeCallbackRequestedHandler | Internal Interpreter UserMcodeCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed
Top
See Also

Reference

KM_Interpreter Class


KM_Interpreter._ErrorLength Field

KM_Interpreter_ErrorLength Field

Maximum allowed return error string length

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int _ErrorLength
Protected _ErrorLength As Integer
protected:
int _ErrorLength

Field Value

Int32
See Also

Reference

KM_Interpreter Class


KM_Interpreter._InstanceHandle Field

KM_Interpreter_InstanceHandle Field

CCoordMotion class instance pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected IntPtr _InstanceHandle
Protected _InstanceHandle As IntPtr
protected:
IntPtr _InstanceHandle

Field Value

IntPtr
See Also

Reference

KM_Interpreter Class


KM_Interpreter._Loaded Field

KM_Interpreter_Loaded Field

Flag to determine that this object has been properly initialized

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected bool _Loaded
Protected _Loaded As Boolean
protected:
bool _Loaded

Field Value

Boolean
See Also

Reference

KM_Interpreter Class


KM_Interpreter._SetupParams Field

KM_Interpreter_SetupParams Field

Direct Access to the EMC Setup Parameters Use caution when setting any of these properties during run

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_InterpreterKM_Interpreter_SetupParams _SetupParams
Protected _SetupParams As KM_InterpreterKM_Interpreter_SetupParams
protected:
KM_InterpreterKM_Interpreter_SetupParams^ _SetupParams

Field Value

KM_InterpreterKM_Interpreter_SetupParams
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterCompletedHandler Field

KM_InterpreterInterpreterCompletedHandler Field

Internal Interpreter Complete callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_InterpreterKM_GCodeInterpreterCompleteHandler InterpreterCompletedHandler
Protected InterpreterCompletedHandler As KM_InterpreterKM_GCodeInterpreterCompleteHandler
protected:
KM_InterpreterKM_GCodeInterpreterCompleteHandler^ InterpreterCompletedHandler

Field Value

KM_InterpreterKM_GCodeInterpreterCompleteHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterStatusUpdatedHandler Field

KM_InterpreterInterpreterStatusUpdatedHandler Field

Internal Interpreter Status callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_InterpreterKM_GCodeInterpreterStatusHandler InterpreterStatusUpdatedHandler
Protected InterpreterStatusUpdatedHandler As KM_InterpreterKM_GCodeInterpreterStatusHandler
protected:
KM_InterpreterKM_GCodeInterpreterStatusHandler^ InterpreterStatusUpdatedHandler

Field Value

KM_InterpreterKM_GCodeInterpreterStatusHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterUserCallbackRequestedHandler Field

KM_InterpreterInterpreterUserCallbackRequestedHandler Field

Internal Interpreter UserCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_InterpreterKM_GCodeInterpreterUserCallbackHandler InterpreterUserCallbackRequestedHandler
Protected InterpreterUserCallbackRequestedHandler As KM_InterpreterKM_GCodeInterpreterUserCallbackHandler
protected:
KM_InterpreterKM_GCodeInterpreterUserCallbackHandler^ InterpreterUserCallbackRequestedHandler

Field Value

KM_InterpreterKM_GCodeInterpreterUserCallbackHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.InterpreterUserMCodeCallbackRequestedHandler Field

KM_InterpreterInterpreterUserMCodeCallbackRequestedHandler Field

Internal Interpreter UserMcodeCallback callback handler for the GCodeInterpreter.cpp class this delegate for the callback prevents the Garbage Collector from releasing the unmanaged function pointer from being destroyed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler InterpreterUserMCodeCallbackRequestedHandler
Protected InterpreterUserMCodeCallbackRequestedHandler As KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler
protected:
KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler^ InterpreterUserMCodeCallbackRequestedHandler

Field Value

KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler
See Also

Reference

KM_Interpreter Class


KM_Interpreter.KM_GCodeInterpreterCompleteHandler Delegate

KM_InterpreterKM_GCodeInterpreterCompleteHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netG_COMPLETE_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_GCodeInterpreterCompleteHandler(
    int status,
    int lineno,
    int sequence_number,
    string err
)
Public Delegate Sub KM_GCodeInterpreterCompleteHandler (
    status As Integer,
    lineno As Integer,
    sequence_number As Integer,
    err As String
)
public delegate void KM_GCodeInterpreterCompleteHandler(
    int status,
    int lineno,
    int sequence_number,
    String^ err
)

Parameters

status Int32
Exit Status Code
lineno Int32
Final processed line number
sequence_number Int32
Block sequence
err String
Error message ( if any )
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter.KM_GCodeInterpreterStatusHandler Delegate

KM_InterpreterKM_GCodeInterpreterStatusHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netG_STATUS_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_GCodeInterpreterStatusHandler(
    int lineno,
    string msg
)
Public Delegate Sub KM_GCodeInterpreterStatusHandler (
    lineno As Integer,
    msg As String
)
public delegate void KM_GCodeInterpreterStatusHandler(
    int lineno,
    String^ msg
)

Parameters

lineno Int32
current line number of the interpreted block
msg String
Block Data
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter.KM_GCodeInterpreterUserCallbackHandler Delegate

KM_InterpreterKM_GCodeInterpreterUserCallbackHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netG_USER_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KM_GCodeInterpreterUserCallbackHandler(
    string msg
)
Public Delegate Sub KM_GCodeInterpreterUserCallbackHandler (
    msg As String
)
public delegate void KM_GCodeInterpreterUserCallbackHandler(
    String^ msg
)

Parameters

msg String
Interpreted User Callback Message
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter.KM_GCodeInterpreterUserMcodeCallbackHandler Delegate

KM_InterpreterKM_GCodeInterpreterUserMcodeCallbackHandler Delegate

Delegate reperesenting the KM_dotNet_Interop netG_USER_MCODE_CALLBACK Function Pointer

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate int KM_GCodeInterpreterUserMcodeCallbackHandler(
    int code
)
Public Delegate Function KM_GCodeInterpreterUserMcodeCallbackHandler (
    code As Integer
) As Integer
public delegate int KM_GCodeInterpreterUserMcodeCallbackHandler(
    int code
)

Parameters

code Int32
Interpreted User MCODE Callback code

Return Value

Int32
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter.KM_Interpreter_SetupParams Class

KM_InterpreterKM_Interpreter_SetupParams Class

Direct settings access for the EMC internal settings Warning, use at own risk Make sure to examine the Interpreter.cpp and related files to ensure you are aware of the reprecutions when using these parameters
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_InterpreterKM_Interpreter_SetupParams

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_Interpreter_SetupParams
Public Class KM_Interpreter_SetupParams
public ref class KM_Interpreter_SetupParams

The KM_InterpreterKM_Interpreter_SetupParams type exposes the following members.

Constructors
 | Name | Description
Public method | KM_InterpreterKM_Interpreter_SetupParams | Constructor for GCode interpreter internal setup parameters interface
Top
Properties
 | Name | Description
Public property | A_AxisOffset | A Axis Offset
Public property | A_AxisPosition | Current A Axis Positon
Public property | A_OriginOffset | A axis Origin Offset
Public property | Active_GCodes | All currently active G codes
Public property | Active_MCodes | All currently active M codes
Public property | Active_Settings | Need clarification
Public property | AllowSpindleSpeedOverride | Gets/sets whether to allow spindle feed override
Public property | B_AxisOffset | B Axis Offset
Public property | B_AxisPosition | Current B Axis Positon
Public property | B_OriginOffset | B axis Origin Offset
Public property | block_d_flag | Gets d flag (d word present) in current GCode Block
Public property | block_d_number | Gets d number (d word) in current GCode Block
Public property | block_p_flag | Gets p flag (p word present) in current GCode Block
Public property | block_p_number | Gets p number (p word) in current GCode Block
Public property | block_q_flag | Gets q flag (q word present) in current GCode Block
Public property | block_q_number | Gets q number (q word) in current GCode Block
Public property | block_r_flag | Gets r flag (r word present) in current GCode Block
Public property | block_r_number | Gets r number (r word) in current GCode Block
Public property | BlockDelete | Enable/Disable Block Delete
Public property | C_AxisOffset | C Axis Offset
Public property | C_AxisPosition | Current C Axis Positon
Public property | C_OriginOffset | C axis Origin Offset
Public property | ControlMode | Cannon Control Mode CANON_EXACT_STOP = 1, CANON_EXACT_PATH = 2, CANON_CONTINUOUS = 3
Public property | CurrentLine | Current line number of the file being interpreted
Public property | CurrentMotionMode | Current G code for motion
Public property | CurrentToolSlot | Tool Changer slot number of current tool
Public property | Cycle_CC | Gets/sets canned Cycle C value
Public property | Cycle_I | Gets/sets canned Cycle I value
Public property | Cycle_J | Gets/sets canned Cycle J value
Public property | Cycle_K | Gets/sets canned Cycle K value
Public property | Cycle_L | Gets/sets canned Cycle L value
Public property | Cycle_P | Gets/sets canned Cycle P value
Public property | Cycle_Q | Gets/sets canned Cycle Q value
Public property | Cycle_R | Gets/sets canned Cycle R value
Public property | Cycle_RetractMode | Gets/sets canned Retract Mode R_PLANE = 0, OLD_Z = 1
Public property | Cycle_Z | Gets/sets canned Cycle Z value
Public property | DistanceMode | Unit distance mode MODE_ABSOLUTE = 0, MODE_INCREMENTAL = 1
Public property | FeedMode | G_93 (inverse time) or G_94 units/min
Public property | FeedRate | Current FeedRate
Public property | FileName | Current File name being interpreted
Public property | FloodCoolantOn | Flood Coolant State from Interpreter
Public property | LengthUnits | Canon Length Units CANON_UNITS_INCHES = 1, CANON_UNITS_MM = 2, CANON_UNITS_CM = 3
Public property | LineLength | Character length of the current line
Public property | LineText | Text of the currently interpreted line
Public property | MistCoolantOn | Gets and sets whether Mist Coolant is on
Public property | OriginIndex | Origin Index G54, 55, etc...
Public property | PercentFlag | Flags true if the file had a percentage sign
Public property | ProbeComplete | Gets and sets whether a probe operation is complete
Public property | ProgramX | Program's X position
Public property | ProgramY | Program's Y position
Public property | RadiusComp | Radius compensation mode
Public property | RadiusCompSide | Radius compensation side CANON_SIDE_RIGHT = 1, CANON_SIDE_LEFT = 2, CANON_SIDE_OFF = 3
Public property | RadiusCompValue | Radius compensation value
Public property | SelectedToolSlot | Tool slot selected but not active
Public property | SequenceNumber | Current sequence of the file being interpreted
Public property | SpindleDirection | Spindle rotation direction CANON_STOPPED = 1, CANON_CLOCKWISE = 2, CANON_COUNTERCLOCKWISE = 3
Public property | SpindleSpeed | Current Spindle Speed
Public property | ToolLengthOffset | Current tool length offset
Public property | ToolLengthOffsetIndex | Row in tool table for current Length Offset
Public property | ToolXOffset | Current tool X offset
Public property | ToolYOffset | Current tool Y offset
Public property | TraverseSpeed | Spped to use during G00 traverse operations
Public property | WorkPlane | Canon Work Plane CANON_PLANE_XY = 1, CANON_PLANE_YZ = 2, CANON_PLANE_XZ = 3
Public property | X_AxisOffset | X Axis Offset
Public property | X_AxisPosition | Current X Axis Positon
Public property | X_OriginOffset | X axis Origin Offset
Public property | Y_AxisOffset | Y Axis Offset
Public property | Y_AxisPosition | Current Y Axis Positon
Public property | Y_OriginOffset | Y axis Origin Offset
Public property | Z_AxisOffset | Z Axis Offset
Public property | Z_AxisPosition | Current Z Axis Positon
Public property | Z_OriginOffset | Z axis Origin Offset
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameter | Get GCode parameter by index.
Public method | GetTool | Get info on specific tool
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetParameter | Set parameter value.
Public method | SetTool | Updates the given tool table location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KMotion_dotNet Namespace


KM_Interpreter.KM_Interpreter_SetupParams Constructor

KM_InterpreterKM_Interpreter_SetupParams Constructor

Constructor for GCode interpreter internal setup parameters interface

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_Interpreter_SetupParams(
    IntPtr handle
)
Public Sub New (
    handle As IntPtr
)
public:
KM_Interpreter_SetupParams(
    IntPtr handle
)

Parameters

handle IntPtr
Associated Interpreter Handle
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter_SetupParams Properties

The KM_InterpreterKM_Interpreter_SetupParams type exposes the following members.

Properties
 | Name | Description
Public property | A_AxisOffset | A Axis Offset
Public property | A_AxisPosition | Current A Axis Positon
Public property | A_OriginOffset | A axis Origin Offset
Public property | Active_GCodes | All currently active G codes
Public property | Active_MCodes | All currently active M codes
Public property | Active_Settings | Need clarification
Public property | AllowSpindleSpeedOverride | Gets/sets whether to allow spindle feed override
Public property | B_AxisOffset | B Axis Offset
Public property | B_AxisPosition | Current B Axis Positon
Public property | B_OriginOffset | B axis Origin Offset
Public property | block_d_flag | Gets d flag (d word present) in current GCode Block
Public property | block_d_number | Gets d number (d word) in current GCode Block
Public property | block_p_flag | Gets p flag (p word present) in current GCode Block
Public property | block_p_number | Gets p number (p word) in current GCode Block
Public property | block_q_flag | Gets q flag (q word present) in current GCode Block
Public property | block_q_number | Gets q number (q word) in current GCode Block
Public property | block_r_flag | Gets r flag (r word present) in current GCode Block
Public property | block_r_number | Gets r number (r word) in current GCode Block
Public property | BlockDelete | Enable/Disable Block Delete
Public property | C_AxisOffset | C Axis Offset
Public property | C_AxisPosition | Current C Axis Positon
Public property | C_OriginOffset | C axis Origin Offset
Public property | ControlMode | Cannon Control Mode CANON_EXACT_STOP = 1, CANON_EXACT_PATH = 2, CANON_CONTINUOUS = 3
Public property | CurrentLine | Current line number of the file being interpreted
Public property | CurrentMotionMode | Current G code for motion
Public property | CurrentToolSlot | Tool Changer slot number of current tool
Public property | Cycle_CC | Gets/sets canned Cycle C value
Public property | Cycle_I | Gets/sets canned Cycle I value
Public property | Cycle_J | Gets/sets canned Cycle J value
Public property | Cycle_K | Gets/sets canned Cycle K value
Public property | Cycle_L | Gets/sets canned Cycle L value
Public property | Cycle_P | Gets/sets canned Cycle P value
Public property | Cycle_Q | Gets/sets canned Cycle Q value
Public property | Cycle_R | Gets/sets canned Cycle R value
Public property | Cycle_RetractMode | Gets/sets canned Retract Mode R_PLANE = 0, OLD_Z = 1
Public property | Cycle_Z | Gets/sets canned Cycle Z value
Public property | DistanceMode | Unit distance mode MODE_ABSOLUTE = 0, MODE_INCREMENTAL = 1
Public property | FeedMode | G_93 (inverse time) or G_94 units/min
Public property | FeedRate | Current FeedRate
Public property | FileName | Current File name being interpreted
Public property | FloodCoolantOn | Flood Coolant State from Interpreter
Public property | LengthUnits | Canon Length Units CANON_UNITS_INCHES = 1, CANON_UNITS_MM = 2, CANON_UNITS_CM = 3
Public property | LineLength | Character length of the current line
Public property | LineText | Text of the currently interpreted line
Public property | MistCoolantOn | Gets and sets whether Mist Coolant is on
Public property | OriginIndex | Origin Index G54, 55, etc...
Public property | PercentFlag | Flags true if the file had a percentage sign
Public property | ProbeComplete | Gets and sets whether a probe operation is complete
Public property | ProgramX | Program's X position
Public property | ProgramY | Program's Y position
Public property | RadiusComp | Radius compensation mode
Public property | RadiusCompSide | Radius compensation side CANON_SIDE_RIGHT = 1, CANON_SIDE_LEFT = 2, CANON_SIDE_OFF = 3
Public property | RadiusCompValue | Radius compensation value
Public property | SelectedToolSlot | Tool slot selected but not active
Public property | SequenceNumber | Current sequence of the file being interpreted
Public property | SpindleDirection | Spindle rotation direction CANON_STOPPED = 1, CANON_CLOCKWISE = 2, CANON_COUNTERCLOCKWISE = 3
Public property | SpindleSpeed | Current Spindle Speed
Public property | ToolLengthOffset | Current tool length offset
Public property | ToolLengthOffsetIndex | Row in tool table for current Length Offset
Public property | ToolXOffset | Current tool X offset
Public property | ToolYOffset | Current tool Y offset
Public property | TraverseSpeed | Spped to use during G00 traverse operations
Public property | WorkPlane | Canon Work Plane CANON_PLANE_XY = 1, CANON_PLANE_YZ = 2, CANON_PLANE_XZ = 3
Public property | X_AxisOffset | X Axis Offset
Public property | X_AxisPosition | Current X Axis Positon
Public property | X_OriginOffset | X axis Origin Offset
Public property | Y_AxisOffset | Y Axis Offset
Public property | Y_AxisPosition | Current Y Axis Positon
Public property | Y_OriginOffset | Y axis Origin Offset
Public property | Z_AxisOffset | Z Axis Offset
Public property | Z_AxisPosition | Current Z Axis Positon
Public property | Z_OriginOffset | Z axis Origin Offset
Top
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.A_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsA_AxisOffset Property

A Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double A_AxisOffset { get; set; }
Public Property A_AxisOffset As Double
    Get
    Set
public:
property double A_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.A_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsA_AxisPosition Property

Current A Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double A_AxisPosition { get; set; }
Public Property A_AxisPosition As Double
    Get
    Set
public:
property double A_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.A_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsA_OriginOffset Property

A axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double A_OriginOffset { get; set; }
Public Property A_OriginOffset As Double
    Get
    Set
public:
property double A_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Active_GCodes Property

KM_InterpreterKM_Interpreter_SetupParamsActive_GCodes Property

All currently active G codes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public List<string> Active_GCodes { get; }
Public ReadOnly Property Active_GCodes As List(Of String)
    Get
public:
property List<String^>^ Active_GCodes {
    List<String^>^ get ();
}

Property Value

List String
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Active_MCodes Property

KM_InterpreterKM_Interpreter_SetupParamsActive_MCodes Property

All currently active M codes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public List<string> Active_MCodes { get; }
Public ReadOnly Property Active_MCodes As List(Of String)
    Get
public:
property List<String^>^ Active_MCodes {
    List<String^>^ get ();
}

Property Value

List String
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Active_Settings Property

KM_InterpreterKM_Interpreter_SetupParamsActive_Settings Property

Need clarification

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double[] Active_Settings { get; }
Public ReadOnly Property Active_Settings As Double()
    Get
public:
property array<double>^ Active_Settings {
    array<double>^ get ();
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.AllowSpindleSpeedOverride Property

KM_InterpreterKM_Interpreter_SetupParamsAllowSpindleSpeedOverride Property

Gets/sets whether to allow spindle feed override

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool AllowSpindleSpeedOverride { get; set; }
Public Property AllowSpindleSpeedOverride As Boolean
    Get
    Set
public:
property bool AllowSpindleSpeedOverride {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.B_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsB_AxisOffset Property

B Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double B_AxisOffset { get; set; }
Public Property B_AxisOffset As Double
    Get
    Set
public:
property double B_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.B_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsB_AxisPosition Property

Current B Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double B_AxisPosition { get; set; }
Public Property B_AxisPosition As Double
    Get
    Set
public:
property double B_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.B_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsB_OriginOffset Property

B axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double B_OriginOffset { get; set; }
Public Property B_OriginOffset As Double
    Get
    Set
public:
property double B_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_d_flag Property

KM_InterpreterKM_Interpreter_SetupParamsblock_d_flag Property

Gets d flag (d word present) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool block_d_flag { get; }
Public ReadOnly Property block_d_flag As Boolean
    Get
public:
property bool block_d_flag {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_d_number Property

KM_InterpreterKM_Interpreter_SetupParamsblock_d_number Property

Gets d number (d word) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double block_d_number { get; }
Public ReadOnly Property block_d_number As Double
    Get
public:
property double block_d_number {
    double get ();
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_p_flag Property

KM_InterpreterKM_Interpreter_SetupParamsblock_p_flag Property

Gets p flag (p word present) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool block_p_flag { get; }
Public ReadOnly Property block_p_flag As Boolean
    Get
public:
property bool block_p_flag {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_p_number Property

KM_InterpreterKM_Interpreter_SetupParamsblock_p_number Property

Gets p number (p word) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double block_p_number { get; }
Public ReadOnly Property block_p_number As Double
    Get
public:
property double block_p_number {
    double get ();
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_q_flag Property

KM_InterpreterKM_Interpreter_SetupParamsblock_q_flag Property

Gets q flag (q word present) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool block_q_flag { get; }
Public ReadOnly Property block_q_flag As Boolean
    Get
public:
property bool block_q_flag {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_q_number Property

KM_InterpreterKM_Interpreter_SetupParamsblock_q_number Property

Gets q number (q word) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double block_q_number { get; }
Public ReadOnly Property block_q_number As Double
    Get
public:
property double block_q_number {
    double get ();
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_r_flag Property

KM_InterpreterKM_Interpreter_SetupParamsblock_r_flag Property

Gets r flag (r word present) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool block_r_flag { get; }
Public ReadOnly Property block_r_flag As Boolean
    Get
public:
property bool block_r_flag {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.block_r_number Property

KM_InterpreterKM_Interpreter_SetupParamsblock_r_number Property

Gets r number (r word) in current GCode Block

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double block_r_number { get; }
Public ReadOnly Property block_r_number As Double
    Get
public:
property double block_r_number {
    double get ();
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.BlockDelete Property

KM_InterpreterKM_Interpreter_SetupParamsBlockDelete Property

Enable/Disable Block Delete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool BlockDelete { get; set; }
Public Property BlockDelete As Boolean
    Get
    Set
public:
property bool BlockDelete {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.C_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsC_AxisOffset Property

C Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double C_AxisOffset { get; set; }
Public Property C_AxisOffset As Double
    Get
    Set
public:
property double C_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.C_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsC_AxisPosition Property

Current C Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double C_AxisPosition { get; set; }
Public Property C_AxisPosition As Double
    Get
    Set
public:
property double C_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.C_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsC_OriginOffset Property

C axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double C_OriginOffset { get; set; }
Public Property C_OriginOffset As Double
    Get
    Set
public:
property double C_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ControlMode Property

KM_InterpreterKM_Interpreter_SetupParamsControlMode Property

Cannon Control Mode
CANON_EXACT_STOP = 1,
CANON_EXACT_PATH = 2,
CANON_CONTINUOUS = 3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public CANON_MOTION_MODE ControlMode { get; set; }
Public Property ControlMode As CANON_MOTION_MODE
    Get
    Set
public:
property CANON_MOTION_MODE ControlMode {
    CANON_MOTION_MODE get ();
    void set (CANON_MOTION_MODE value);
}

Property Value

CANON_MOTION_MODE
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.CurrentLine Property

KM_InterpreterKM_Interpreter_SetupParamsCurrentLine Property

Current line number of the file being interpreted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int CurrentLine { get; set; }
Public Property CurrentLine As Integer
    Get
    Set
public:
property int CurrentLine {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.CurrentMotionMode Property

KM_InterpreterKM_Interpreter_SetupParamsCurrentMotionMode Property

Current G code for motion

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int CurrentMotionMode { get; set; }
Public Property CurrentMotionMode As Integer
    Get
    Set
public:
property int CurrentMotionMode {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.CurrentToolSlot Property

KM_InterpreterKM_Interpreter_SetupParamsCurrentToolSlot Property

Tool Changer slot number of current tool

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int CurrentToolSlot { get; set; }
Public Property CurrentToolSlot As Integer
    Get
    Set
public:
property int CurrentToolSlot {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_CC Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_CC Property

Gets/sets canned Cycle C value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_CC { get; set; }
Public Property Cycle_CC As Double
    Get
    Set
public:
property double Cycle_CC {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_I Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_I Property

Gets/sets canned Cycle I value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_I { get; set; }
Public Property Cycle_I As Double
    Get
    Set
public:
property double Cycle_I {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_J Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_J Property

Gets/sets canned Cycle J value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_J { get; set; }
Public Property Cycle_J As Double
    Get
    Set
public:
property double Cycle_J {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_K Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_K Property

Gets/sets canned Cycle K value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_K { get; set; }
Public Property Cycle_K As Double
    Get
    Set
public:
property double Cycle_K {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_L Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_L Property

Gets/sets canned Cycle L value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_L { get; set; }
Public Property Cycle_L As Double
    Get
    Set
public:
property double Cycle_L {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_P Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_P Property

Gets/sets canned Cycle P value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_P { get; set; }
Public Property Cycle_P As Double
    Get
    Set
public:
property double Cycle_P {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_Q Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_Q Property

Gets/sets canned Cycle Q value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_Q { get; set; }
Public Property Cycle_Q As Double
    Get
    Set
public:
property double Cycle_Q {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_R Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_R Property

Gets/sets canned Cycle R value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_R { get; set; }
Public Property Cycle_R As Double
    Get
    Set
public:
property double Cycle_R {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_RetractMode Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_RetractMode Property

Gets/sets canned Retract Mode R_PLANE = 0, OLD_Z = 1

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public RETRACT_MODE Cycle_RetractMode { get; set; }
Public Property Cycle_RetractMode As RETRACT_MODE
    Get
    Set
public:
property RETRACT_MODE Cycle_RetractMode {
    RETRACT_MODE get ();
    void set (RETRACT_MODE value);
}

Property Value

RETRACT_MODE
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Cycle_Z Property

KM_InterpreterKM_Interpreter_SetupParamsCycle_Z Property

Gets/sets canned Cycle Z value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Cycle_Z { get; set; }
Public Property Cycle_Z As Double
    Get
    Set
public:
property double Cycle_Z {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.DistanceMode Property

KM_InterpreterKM_Interpreter_SetupParamsDistanceMode Property

Unit distance mode MODE_ABSOLUTE = 0, MODE_INCREMENTAL = 1

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public DISTANCE_MODE DistanceMode { get; set; }
Public Property DistanceMode As DISTANCE_MODE
    Get
    Set
public:
property DISTANCE_MODE DistanceMode {
    DISTANCE_MODE get ();
    void set (DISTANCE_MODE value);
}

Property Value

DISTANCE_MODE
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.FeedMode Property

KM_InterpreterKM_Interpreter_SetupParamsFeedMode Property

G_93 (inverse time) or G_94 units/min

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int FeedMode { get; set; }
Public Property FeedMode As Integer
    Get
    Set
public:
property int FeedMode {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.FeedRate Property

KM_InterpreterKM_Interpreter_SetupParamsFeedRate Property

Current FeedRate

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FeedRate { get; set; }
Public Property FeedRate As Double
    Get
    Set
public:
property double FeedRate {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.FileName Property

KM_InterpreterKM_Interpreter_SetupParamsFileName Property

Current File name being interpreted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}

Property Value

String
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.FloodCoolantOn Property

KM_InterpreterKM_Interpreter_SetupParamsFloodCoolantOn Property

Flood Coolant State from Interpreter

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool FloodCoolantOn { get; set; }
Public Property FloodCoolantOn As Boolean
    Get
    Set
public:
property bool FloodCoolantOn {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.LengthUnits Property

KM_InterpreterKM_Interpreter_SetupParamsLengthUnits Property

Canon Length Units
CANON_UNITS_INCHES = 1,
CANON_UNITS_MM = 2,
CANON_UNITS_CM = 3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public CANON_UNITS LengthUnits { get; set; }
Public Property LengthUnits As CANON_UNITS
    Get
    Set
public:
property CANON_UNITS LengthUnits {
    CANON_UNITS get ();
    void set (CANON_UNITS value);
}

Property Value

CANON_UNITS
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.LineLength Property

KM_InterpreterKM_Interpreter_SetupParamsLineLength Property

Character length of the current line

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int LineLength { get; }
Public ReadOnly Property LineLength As Integer
    Get
public:
property int LineLength {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.LineText Property

KM_InterpreterKM_Interpreter_SetupParamsLineText Property

Text of the currently interpreted line

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string LineText { get; }
Public ReadOnly Property LineText As String
    Get
public:
property String^ LineText {
    String^ get ();
}

Property Value

String
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.MistCoolantOn Property

KM_InterpreterKM_Interpreter_SetupParamsMistCoolantOn Property

Gets and sets whether Mist Coolant is on

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool MistCoolantOn { get; set; }
Public Property MistCoolantOn As Boolean
    Get
    Set
public:
property bool MistCoolantOn {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.OriginIndex Property

KM_InterpreterKM_Interpreter_SetupParamsOriginIndex Property

Origin Index G54, 55, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OriginIndex { get; set; }
Public Property OriginIndex As Integer
    Get
    Set
public:
property int OriginIndex {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.PercentFlag Property

KM_InterpreterKM_Interpreter_SetupParamsPercentFlag Property

Flags true if the file had a percentage sign

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool PercentFlag { get; }
Public ReadOnly Property PercentFlag As Boolean
    Get
public:
property bool PercentFlag {
    bool get ();
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ProbeComplete Property

KM_InterpreterKM_Interpreter_SetupParamsProbeComplete Property

Gets and sets whether a probe operation is complete

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ProbeComplete { get; set; }
Public Property ProbeComplete As Boolean
    Get
    Set
public:
property bool ProbeComplete {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ProgramX Property

KM_InterpreterKM_Interpreter_SetupParamsProgramX Property

Program's X position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ProgramX { get; set; }
Public Property ProgramX As Double
    Get
    Set
public:
property double ProgramX {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ProgramY Property

KM_InterpreterKM_Interpreter_SetupParamsProgramY Property

Program's Y position

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ProgramY { get; set; }
Public Property ProgramY As Double
    Get
    Set
public:
property double ProgramY {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.RadiusComp Property

KM_InterpreterKM_Interpreter_SetupParamsRadiusComp Property

Radius compensation mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int RadiusComp { get; set; }
Public Property RadiusComp As Integer
    Get
    Set
public:
property int RadiusComp {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.RadiusCompSide Property

KM_InterpreterKM_Interpreter_SetupParamsRadiusCompSide Property

Radius compensation side
CANON_SIDE_RIGHT = 1,
CANON_SIDE_LEFT = 2,
CANON_SIDE_OFF = 3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public CANON_SIDE RadiusCompSide { get; set; }
Public Property RadiusCompSide As CANON_SIDE
    Get
    Set
public:
property CANON_SIDE RadiusCompSide {
    CANON_SIDE get ();
    void set (CANON_SIDE value);
}

Property Value

CANON_SIDE
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.RadiusCompValue Property

KM_InterpreterKM_Interpreter_SetupParamsRadiusCompValue Property

Radius compensation value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double RadiusCompValue { get; set; }
Public Property RadiusCompValue As Double
    Get
    Set
public:
property double RadiusCompValue {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SelectedToolSlot Property

KM_InterpreterKM_Interpreter_SetupParamsSelectedToolSlot Property

Tool slot selected but not active

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SelectedToolSlot { get; set; }
Public Property SelectedToolSlot As Integer
    Get
    Set
public:
property int SelectedToolSlot {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SequenceNumber Property

KM_InterpreterKM_Interpreter_SetupParamsSequenceNumber Property

Current sequence of the file being interpreted

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SequenceNumber { get; }
Public ReadOnly Property SequenceNumber As Integer
    Get
public:
property int SequenceNumber {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SpindleDirection Property

KM_InterpreterKM_Interpreter_SetupParamsSpindleDirection Property

Spindle rotation direction
CANON_STOPPED = 1,
CANON_CLOCKWISE = 2,
CANON_COUNTERCLOCKWISE = 3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public CANON_DIRECTION SpindleDirection { get; set; }
Public Property SpindleDirection As CANON_DIRECTION
    Get
    Set
public:
property CANON_DIRECTION SpindleDirection {
    CANON_DIRECTION get ();
    void set (CANON_DIRECTION value);
}

Property Value

CANON_DIRECTION
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SpindleSpeed Property

KM_InterpreterKM_Interpreter_SetupParamsSpindleSpeed Property

Current Spindle Speed

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double SpindleSpeed { get; set; }
Public Property SpindleSpeed As Double
    Get
    Set
public:
property double SpindleSpeed {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ToolLengthOffset Property

KM_InterpreterKM_Interpreter_SetupParamsToolLengthOffset Property

Current tool length offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ToolLengthOffset { get; set; }
Public Property ToolLengthOffset As Double
    Get
    Set
public:
property double ToolLengthOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ToolLengthOffsetIndex Property

KM_InterpreterKM_Interpreter_SetupParamsToolLengthOffsetIndex Property

Row in tool table for current Length Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ToolLengthOffsetIndex { get; set; }
Public Property ToolLengthOffsetIndex As Integer
    Get
    Set
public:
property int ToolLengthOffsetIndex {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ToolXOffset Property

KM_InterpreterKM_Interpreter_SetupParamsToolXOffset Property

Current tool X offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ToolXOffset { get; set; }
Public Property ToolXOffset As Double
    Get
    Set
public:
property double ToolXOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.ToolYOffset Property

KM_InterpreterKM_Interpreter_SetupParamsToolYOffset Property

Current tool Y offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double ToolYOffset { get; set; }
Public Property ToolYOffset As Double
    Get
    Set
public:
property double ToolYOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.TraverseSpeed Property

KM_InterpreterKM_Interpreter_SetupParamsTraverseSpeed Property

Spped to use during G00 traverse operations

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TraverseSpeed { get; set; }
Public Property TraverseSpeed As Double
    Get
    Set
public:
property double TraverseSpeed {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.WorkPlane Property

KM_InterpreterKM_Interpreter_SetupParamsWorkPlane Property

Canon Work Plane
CANON_PLANE_XY = 1,
CANON_PLANE_YZ = 2,
CANON_PLANE_XZ = 3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public CANON_PLANE WorkPlane { get; set; }
Public Property WorkPlane As CANON_PLANE
    Get
    Set
public:
property CANON_PLANE WorkPlane {
    CANON_PLANE get ();
    void set (CANON_PLANE value);
}

Property Value

CANON_PLANE
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.X_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsX_AxisOffset Property

X Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double X_AxisOffset { get; set; }
Public Property X_AxisOffset As Double
    Get
    Set
public:
property double X_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.X_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsX_AxisPosition Property

Current X Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double X_AxisPosition { get; set; }
Public Property X_AxisPosition As Double
    Get
    Set
public:
property double X_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.X_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsX_OriginOffset Property

X axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double X_OriginOffset { get; set; }
Public Property X_OriginOffset As Double
    Get
    Set
public:
property double X_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Y_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsY_AxisOffset Property

Y Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Y_AxisOffset { get; set; }
Public Property Y_AxisOffset As Double
    Get
    Set
public:
property double Y_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Y_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsY_AxisPosition Property

Current Y Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Y_AxisPosition { get; set; }
Public Property Y_AxisPosition As Double
    Get
    Set
public:
property double Y_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Y_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsY_OriginOffset Property

Y axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Y_OriginOffset { get; set; }
Public Property Y_OriginOffset As Double
    Get
    Set
public:
property double Y_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Z_AxisOffset Property

KM_InterpreterKM_Interpreter_SetupParamsZ_AxisOffset Property

Z Axis Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Z_AxisOffset { get; set; }
Public Property Z_AxisOffset As Double
    Get
    Set
public:
property double Z_AxisOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Z_AxisPosition Property

KM_InterpreterKM_Interpreter_SetupParamsZ_AxisPosition Property

Current Z Axis Positon

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Z_AxisPosition { get; set; }
Public Property Z_AxisPosition As Double
    Get
    Set
public:
property double Z_AxisPosition {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.Z_OriginOffset Property

KM_InterpreterKM_Interpreter_SetupParamsZ_OriginOffset Property

Z axis Origin Offset

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double Z_OriginOffset { get; set; }
Public Property Z_OriginOffset As Double
    Get
    Set
public:
property double Z_OriginOffset {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter_SetupParams Methods

The KM_InterpreterKM_Interpreter_SetupParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameter | Get GCode parameter by index.
Public method | GetTool | Get info on specific tool
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetParameter | Set parameter value.
Public method | SetTool | Updates the given tool table location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.GetParameter Method

KM_InterpreterKM_Interpreter_SetupParamsGetParameter Method

Get GCode parameter by index.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetParameter(
    int index
)
Public Function GetParameter (
    index As Integer
) As Double
public:
double GetParameter(
    int index
)

Parameters

index Int32
Parameter index.

Return Value

Double
Parameter value.
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.GetTool Method

KM_InterpreterKM_Interpreter_SetupParamsGetTool Method

Get info on specific tool

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void GetTool(
    int index,
    ref int slot,
    ref int ID,
    ref double length,
    ref double diameter,
    ref double xoffset,
    ref double yoffset
)
Public Sub GetTool (
    index As Integer,
    ByRef slot As Integer,
    ByRef ID As Integer,
    ByRef length As Double,
    ByRef diameter As Double,
    ByRef xoffset As Double,
    ByRef yoffset As Double
)
public:
void GetTool(
    int index,
    int% slot,
    int% ID,
    double% length,
    double% diameter,
    double% xoffset,
    double% yoffset
)

Parameters

index Int32
Table Index
slot Int32
Tool changer slot referenced in GCode as 2 digit number
ID Int32
Tool ID referenced in GCode as 4 digit number
length Double
Tool Length Offset
diameter Double
Tool Diameter Offset
xoffset Double
Tool X Offset
yoffset Double
Tool Y Offset
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SetParameter Method

KM_InterpreterKM_Interpreter_SetupParamsSetParameter Method

Set parameter value.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool SetParameter(
    int index,
    double value
)
Public Function SetParameter (
    index As Integer,
    value As Double
) As Boolean
public:
bool SetParameter(
    int index,
    double value
)

Parameters

index Int32
Index of parameter.
value Double
Value of parameter.

Return Value

Boolean
True is successful.
Remarks
Will return false if out of range.
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_Interpreter.KM_Interpreter_SetupParams.SetTool Method

KM_InterpreterKM_Interpreter_SetupParamsSetTool Method

Updates the given tool table location

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetTool(
    int index,
    int slot,
    int id,
    double length,
    double diameter,
    double xoffset,
    double yoffset
)
Public Sub SetTool (
    index As Integer,
    slot As Integer,
    id As Integer,
    length As Double,
    diameter As Double,
    xoffset As Double,
    yoffset As Double
)
public:
void SetTool(
    int index,
    int slot,
    int id,
    double length,
    double diameter,
    double xoffset,
    double yoffset
)

Parameters

index Int32
Table Index
slot Int32
Tool changer slot referenced in GCode as 2 digit number
id Int32
Tool ID referenced in GCode as 4 digit number
length Double
Tool Length Offset
diameter Double
Tool Diameter Offset
xoffset Double
Tool X Offset
yoffset Double
Tool Y Offset
See Also

Reference

KM_InterpreterKM_Interpreter_SetupParams Class


KM_IO Class

IO class for KM_Controller Use to control a single point(bit) of IO Currently supported IO: Digital Input, Digital Output
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_IO

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_IO
Public Class KM_IO
public ref class KM_IO

The KM_IO type exposes the following members.

Constructors
 | Name | Description
Public method | KM_IO | Primary Construtor for IO object
Top
Properties
 | Name | Description
Public property | ID | Bit Number
Public property | IOType | Direction of IO
Public property | Name | Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAnalogValue | Reads the digital expression of an analog value
Public method | GetDigitalValue | Gets the current status of a point of IO
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAnalogValue | Sets the output level of an analog output
Public method | SetDigitalValue | Sets the value if the IOType is Digital output Otherwise will throw an exception
Public method | Toggle | Toggle a Digital Output Bit
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Protected method | UpdateIOType | Uptdates the IO direction
Top
Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _ID | Bit Number
Protected field | _IOType | Direction of IO Only Digital Input and Digital Output Are currently supported
Protected field | _Name | Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...
Top
See Also

Reference

KMotion_dotNet Namespace


KM_IO Constructor

Primary Construtor for IO object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_IO(
    KM_Controller controller,
    int id,
    string name,
    IO_TYPE iotype
)
Public Sub New (
    controller As KM_Controller,
    id As Integer,
    name As String,
    iotype As IO_TYPE
)
public:
KM_IO(
    KM_Controller^ controller,
    int id,
    String^ name,
    IO_TYPE iotype
)

Parameters

controller KM_Controller
KM_Controller object to associate the I Owith
id Int32
Bit Number
name String
Call Name
iotype IO_TYPE
Sets the IO direction
See Also

Reference

KM_IO Class


KM_IO Properties

The KM_IO type exposes the following members.

Properties
 | Name | Description
Public property | ID | Bit Number
Public property | IOType | Direction of IO
Public property | Name | Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...
Top
See Also

Reference

KM_IO Class


KM_IO.ID Property

KM_IOID Property

Bit Number

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Int32
See Also

Reference

KM_IO Class


KM_IO.IOType Property

KM_IOIOType Property

Direction of IO

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public IO_TYPE IOType { get; set; }
Public Property IOType As IO_TYPE
    Get
    Set
public:
property IO_TYPE IOType {
    IO_TYPE get ();
    void set (IO_TYPE value);
}

Property Value

IO_TYPE
See Also

Reference

KM_IO Class


KM_IO.Name Property

KM_IOName Property

Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

String
See Also

Reference

KM_IO Class


KM_IO Methods

The KM_IO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAnalogValue | Reads the digital expression of an analog value
Public method | GetDigitalValue | Gets the current status of a point of IO
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetAnalogValue | Sets the output level of an analog output
Public method | SetDigitalValue | Sets the value if the IOType is Digital output Otherwise will throw an exception
Public method | Toggle | Toggle a Digital Output Bit
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Protected method | UpdateIOType | Uptdates the IO direction
Top
See Also

Reference

KM_IO Class


KM_IO.GetAnalogValue Method

KM_IOGetAnalogValue Method

Reads the digital expression of an analog value

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetAnalogValue()
Public Function GetAnalogValue As Integer
public:
int GetAnalogValue()

Return Value

Int32
-2048...2047
See Also

Reference

KM_IO Class


KM_IO.GetDigitalValue Method

KM_IOGetDigitalValue Method

Gets the current status of a point of IO

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool GetDigitalValue()
Public Function GetDigitalValue As Boolean
public:
bool GetDigitalValue()

Return Value

Boolean
Current digital value
See Also

Reference

KM_IO Class


KM_IO.SetAnalogValue Method

KM_IOSetAnalogValue Method

Sets the output level of an analog output

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetAnalogValue(
    int value
)
Public Sub SetAnalogValue (
    value As Integer
)
public:
void SetAnalogValue(
    int value
)

Parameters

value Int32
-2048...2047
See Also

Reference

KM_IO Class


KM_IO.SetDigitalValue Method

KM_IOSetDigitalValue Method

Sets the value if the IOType is Digital output Otherwise will throw an exception

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetDigitalValue(
    bool value
)
Public Sub SetDigitalValue (
    value As Boolean
)
public:
void SetDigitalValue(
    bool value
)

Parameters

value Boolean
new value for IO point
See Also

Reference

KM_IO Class


KM_IO.Toggle Method

KM_IOToggle Method

Toggle a Digital Output Bit

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void Toggle()
Public Sub Toggle
public:
void Toggle()
See Also

Reference

KM_IO Class


KM_IO.UpdateIOType Method

KM_IOUpdateIOType Method

Uptdates the IO direction

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected void UpdateIOType()
Protected Sub UpdateIOType
protected:
void UpdateIOType()
See Also

Reference

KM_IO Class


KM_IO Fields

The KM_IO type exposes the following members.

Fields
 | Name | Description
Protected field | _Controller | KM_Controller Object for used for device access
Protected field | _ID | Bit Number
Protected field | _IOType | Direction of IO Only Digital Input and Digital Output Are currently supported
Protected field | _Name | Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...
Top
See Also

Reference

KM_IO Class


KM_IO._Controller Field

KM_IO_Controller Field

KM_Controller Object for used for device access

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected KM_Controller _Controller
Protected _Controller As KM_Controller
protected:
KM_Controller^ _Controller

Field Value

KM_Controller
See Also

Reference

KM_IO Class


KM_IO._ID Field

KM_IO_ID Field

Bit Number

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected int _ID
Protected _ID As Integer
protected:
int _ID

Field Value

Int32
See Also

Reference

KM_IO Class


KM_IO._IOType Field

KM_IO_IOType Field

Direction of IO Only Digital Input and Digital Output Are currently supported

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected IO_TYPE _IOType
Protected _IOType As IO_TYPE
protected:
IO_TYPE _IOType

Field Value

IO_TYPE
See Also

Reference

KM_IO Class


KM_IO._Name Field

KM_IO_Name Field

Call Name Use to describe what the IO controls i.e. Start Button, Clamp Pneumatic, etc...

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
protected string _Name
Protected _Name As String
protected:
String^ _Name

Field Value

String
See Also

Reference

KM_IO Class


KM_MainStatus Structure

Bulk status record uploaded from KFLOP
Inheritance Hierarchy
SystemObject
SystemValueType
KMotion_dotNetKM_MainStatus

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public struct KM_MainStatus
Public Structure KM_MainStatus
public value class KM_MainStatus

The KM_MainStatus type exposes the following members.

Properties
 | Name | Description
Public property | ADC | Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)
Public property | AxisDone | Bulk status record Current axis completes
Public property | BitsDirection | Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)
Public property | BitsDirection200 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output
Public property | BitsDirection280 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output
Public property | BitsState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public property | BitsState200 | Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200
Public property | DAC | Bulk status record DAC values (8 Kanalog)
Public property | Destination | Bulk status record Axis Commanded Destinations
Public property | Enables | Bulk status record Current axis enables
Public property | HRPWM | Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths
Public property | HRPWMPeriod01 | Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)
Public property | HRPWMPeriod2 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)
Public property | HRPWMPeriod3 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)
Public property | InputModes | Bulk status record feedback selected input modes Axes 0-3
Public property | InputModes2 | Bulk status record feedback selected input modes #2 Axes 4-7
Public property | InputModes3 | Bulk status record feedback selected input modes #3 Axes 8-11
Public property | InputModes4 | Bulk status record feedback selected input modes #4 Axes 12-15
Public property | KanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public property | KanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public property | Kogna_ADC | Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)
Public property | Kogna_DAC | Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)
Public property | Kogna_PWM | Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs
Public property | Kogna_PWM_Enables | Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs
Public property | Kogna_PWM_Prescale | Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs
Public property | OutputChan0 | Bulk status record Axis First output channel specified
Public property | OutputModes | Bulk status record feedback selected output modes Axes 0-3
Public property | OutputModes2 | Bulk status record feedback selected output modes #2 Axes 4-7
Public property | OutputModes3 | Bulk status record feedback selected output modes #3 Axes 8-11
Public property | OutputModes4 | Bulk status record feedback selected output modes #4 Axes 11-15
Public property | PC_comm | Bulk status record KFLOP-PC 8 Communication variables 100-107
Public property | PinMuxModes | Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public property | Position | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public property | PWM | Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)
Public property | RunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public property | SnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public property | SnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public property | SnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public property | SnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public property | StopImmediateState | Bulk status record current StopImmediate (feedhold) state
Public property | ThreadActive | Bulk status record Current Thread Execution State
Public property | TicksAtUpdate | Bulk status record Windows Time when status was updates (millisec since Windows Started)
Public property | TimeStamp | Bulk status record Time Stamp in seconds of when status was acquired
Public property | VersionAndSize | Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words
Public property | VirtualBits | Bulk status record Virtual bits packed 16 per word 48-63
Public property | VirtualBitsEx0 | Bulk status record Extended Virtual bits packed 32 per word 1024-1055
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetADC | Bulk status record ADC values (Kanalog)
Public method | GetAxisComplete | Bulk status record Current axis completes
Public method | GetAxisEnabled | Bulk status record Current axis enables
Public method | GetBitDirection200 | Bulk status record Current Kogna 24 IO Bit directions for Bits 200-223(inputs vs outputs)
Public method | GetBitDirection280 | Bulk status record Current Kogna 10 IO Bit directions for Bits 280-289(inputs vs outputs)
Public method | GetBitState200 | Bulk status record Current Kogna 90 IO Bit states (Bits 200-289)
Public method | GetDAC | Bulk status record DAC values (Kanalog)
Public method | GetDestination | Bulk status record Axis Commanded Destinations
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetInputMode | Bulk status record feedback selected 4-bit input mode
Public method | GetKanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public method | GetKanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public method | GetKFlopBitDirection | Bulk status record Current KFLOP/Kogna 64 IO Bit directions (inputs vs outputs)
Public method | GetKFlopBitState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public method | GetKognaADC | Bulk status record Current Kogna ADC
Public method | GetKognaDAC | Bulk status record Current Kogna DAC
Public method | GetKognaHRPWM | Bulk status record Current Kogna Hi-Res 12-bit PWM pulse setting
Public method | GetKognaPWM | Bulk status record Current Kogna 8-bit PWM pulse setting
Public method | GetKognaPWMEnables | Bulk status record Current Kogna 8-bit PWM Enables
Public method | GetOutputChannel0 | Bulk status record Axis First output channel specified
Public method | GetOutputMode | Bulk status record 4-bit output mode
Public method | GetPC_comm | Bulk status record Current PC-KFLOP Comm regs
Public method | GetPinMuxModes | Bulk status record Current Kogna 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public method | GetPosition | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public method | GetPWM | Bulk status record PWM values (SnapAmp)
Public method | GetRunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public method | GetSnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public method | GetSnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public method | GetSnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public method | GetSnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public method | GetThreadActive | Bulk status record Current Thread Execution State
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVirtualBits | Bulk status record Current Virtual Bit States
Public method | GetVirtualBitsEx0 | Bulk status record Current Extended Virtual Bit States
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | _TicksAtUpdate | Time in milliseconds since Windows Started where Status record was last uploaded Note: rolls over every 49 days
Public field | MainStatus | This structure matches exactly the binary form as the Kogna/KFLOP MAIN_STATUS Structure so it can be uploaded as a binary image.
Top
See Also

Reference

KMotion_dotNet Namespace


KM_MainStatus Properties

The KM_MainStatus type exposes the following members.

Properties
 | Name | Description
Public property | ADC | Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)
Public property | AxisDone | Bulk status record Current axis completes
Public property | BitsDirection | Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)
Public property | BitsDirection200 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output
Public property | BitsDirection280 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output
Public property | BitsState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public property | BitsState200 | Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200
Public property | DAC | Bulk status record DAC values (8 Kanalog)
Public property | Destination | Bulk status record Axis Commanded Destinations
Public property | Enables | Bulk status record Current axis enables
Public property | HRPWM | Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths
Public property | HRPWMPeriod01 | Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)
Public property | HRPWMPeriod2 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)
Public property | HRPWMPeriod3 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)
Public property | InputModes | Bulk status record feedback selected input modes Axes 0-3
Public property | InputModes2 | Bulk status record feedback selected input modes #2 Axes 4-7
Public property | InputModes3 | Bulk status record feedback selected input modes #3 Axes 8-11
Public property | InputModes4 | Bulk status record feedback selected input modes #4 Axes 12-15
Public property | KanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public property | KanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public property | Kogna_ADC | Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)
Public property | Kogna_DAC | Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)
Public property | Kogna_PWM | Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs
Public property | Kogna_PWM_Enables | Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs
Public property | Kogna_PWM_Prescale | Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs
Public property | OutputChan0 | Bulk status record Axis First output channel specified
Public property | OutputModes | Bulk status record feedback selected output modes Axes 0-3
Public property | OutputModes2 | Bulk status record feedback selected output modes #2 Axes 4-7
Public property | OutputModes3 | Bulk status record feedback selected output modes #3 Axes 8-11
Public property | OutputModes4 | Bulk status record feedback selected output modes #4 Axes 11-15
Public property | PC_comm | Bulk status record KFLOP-PC 8 Communication variables 100-107
Public property | PinMuxModes | Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public property | Position | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public property | PWM | Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)
Public property | RunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public property | SnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public property | SnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public property | SnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public property | SnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public property | StopImmediateState | Bulk status record current StopImmediate (feedhold) state
Public property | ThreadActive | Bulk status record Current Thread Execution State
Public property | TicksAtUpdate | Bulk status record Windows Time when status was updates (millisec since Windows Started)
Public property | TimeStamp | Bulk status record Time Stamp in seconds of when status was acquired
Public property | VersionAndSize | Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words
Public property | VirtualBits | Bulk status record Virtual bits packed 16 per word 48-63
Public property | VirtualBitsEx0 | Bulk status record Extended Virtual bits packed 32 per word 1024-1055
Top
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.ADC Property

KM_MainStatusADC Property

Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] ADC { get; }
Public ReadOnly Property ADC As Integer()
    Get
public:
property array<int>^ ADC {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.AxisDone Property

KM_MainStatusAxisDone Property

Bulk status record Current axis completes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int AxisDone { get; }
Public ReadOnly Property AxisDone As Integer
    Get
public:
property int AxisDone {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.BitsDirection Property

KM_MainStatusBitsDirection Property

Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsDirection { get; }
Public ReadOnly Property BitsDirection As Integer()
    Get
public:
property array<int>^ BitsDirection {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.BitsDirection200 Property

KM_MainStatusBitsDirection200 Property

Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BitsDirection200 { get; }
Public ReadOnly Property BitsDirection200 As Integer
    Get
public:
property int BitsDirection200 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.BitsDirection280 Property

KM_MainStatusBitsDirection280 Property

Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BitsDirection280 { get; }
Public ReadOnly Property BitsDirection280 As Integer
    Get
public:
property int BitsDirection280 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.BitsState Property

KM_MainStatusBitsState Property

Bulk status record Current KFLOP/Kogna 64 IO Bit states

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsState { get; }
Public ReadOnly Property BitsState As Integer()
    Get
public:
property array<int>^ BitsState {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.BitsState200 Property

KM_MainStatusBitsState200 Property

Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsState200 { get; }
Public ReadOnly Property BitsState200 As Integer()
    Get
public:
property array<int>^ BitsState200 {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.DAC Property

KM_MainStatusDAC Property

Bulk status record DAC values (8 Kanalog)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] DAC { get; }
Public ReadOnly Property DAC As Integer()
    Get
public:
property array<int>^ DAC {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Destination Property

KM_MainStatusDestination Property

Bulk status record Axis Commanded Destinations

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double[] Destination { get; }
Public ReadOnly Property Destination As Double()
    Get
public:
property array<double>^ Destination {
    array<double>^ get ();
}

Property Value

Double
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Enables Property

KM_MainStatusEnables Property

Bulk status record Current axis enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Enables { get; }
Public ReadOnly Property Enables As Integer
    Get
public:
property int Enables {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.HRPWM Property

KM_MainStatusHRPWM Property

Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort[] HRPWM { get; }
Public ReadOnly Property HRPWM As UShort()
    Get
public:
property array<unsigned short>^ HRPWM {
    array<unsigned short>^ get ();
}

Property Value

UInt16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.HRPWMPeriod01 Property

KM_MainStatusHRPWMPeriod01 Property

Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod01 { get; }
Public ReadOnly Property HRPWMPeriod01 As UShort
    Get
public:
property unsigned short HRPWMPeriod01 {
    unsigned short get ();
}

Property Value

UInt16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.HRPWMPeriod2 Property

KM_MainStatusHRPWMPeriod2 Property

Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod2 { get; }
Public ReadOnly Property HRPWMPeriod2 As UShort
    Get
public:
property unsigned short HRPWMPeriod2 {
    unsigned short get ();
}

Property Value

UInt16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.HRPWMPeriod3 Property

KM_MainStatusHRPWMPeriod3 Property

Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod3 { get; }
Public ReadOnly Property HRPWMPeriod3 As UShort
    Get
public:
property unsigned short HRPWMPeriod3 {
    unsigned short get ();
}

Property Value

UInt16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.InputModes Property

KM_MainStatusInputModes Property

Bulk status record feedback selected input modes Axes 0-3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes { get; }
Public ReadOnly Property InputModes As Integer
    Get
public:
property int InputModes {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.InputModes2 Property

KM_MainStatusInputModes2 Property

Bulk status record feedback selected input modes #2 Axes 4-7

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes2 { get; }
Public ReadOnly Property InputModes2 As Integer
    Get
public:
property int InputModes2 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.InputModes3 Property

KM_MainStatusInputModes3 Property

Bulk status record feedback selected input modes #3 Axes 8-11

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes3 { get; }
Public ReadOnly Property InputModes3 As Integer
    Get
public:
property int InputModes3 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.InputModes4 Property

KM_MainStatusInputModes4 Property

Bulk status record feedback selected input modes #4 Axes 12-15

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes4 { get; }
Public ReadOnly Property InputModes4 As Integer
    Get
public:
property int InputModes4 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.KanalogBitsStateInputs Property

KM_MainStatusKanalogBitsStateInputs Property

Bulk status record Current Kanalog Input Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int KanalogBitsStateInputs { get; }
Public ReadOnly Property KanalogBitsStateInputs As Integer
    Get
public:
property int KanalogBitsStateInputs {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.KanalogBitsStateOutputs Property

KM_MainStatusKanalogBitsStateOutputs Property

Bulk status record Current Kanalog Output Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int KanalogBitsStateOutputs { get; }
Public ReadOnly Property KanalogBitsStateOutputs As Integer
    Get
public:
property int KanalogBitsStateOutputs {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Kogna_ADC Property

KM_MainStatusKogna_ADC Property

Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public short[] Kogna_ADC { get; }
Public ReadOnly Property Kogna_ADC As Short()
    Get
public:
property array<short>^ Kogna_ADC {
    array<short>^ get ();
}

Property Value

Int16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Kogna_DAC Property

KM_MainStatusKogna_DAC Property

Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public short[] Kogna_DAC { get; }
Public ReadOnly Property Kogna_DAC As Short()
    Get
public:
property array<short>^ Kogna_DAC {
    array<short>^ get ();
}

Property Value

Int16
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Kogna_PWM Property

KM_MainStatusKogna_PWM Property

Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] Kogna_PWM { get; }
Public ReadOnly Property Kogna_PWM As Byte()
    Get
public:
property array<unsigned char>^ Kogna_PWM {
    array<unsigned char>^ get ();
}

Property Value

Byte
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Kogna_PWM_Enables Property

KM_MainStatusKogna_PWM_Enables Property

Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] Kogna_PWM_Enables { get; }
Public ReadOnly Property Kogna_PWM_Enables As Byte()
    Get
public:
property array<unsigned char>^ Kogna_PWM_Enables {
    array<unsigned char>^ get ();
}

Property Value

Byte
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Kogna_PWM_Prescale Property

KM_MainStatusKogna_PWM_Prescale Property

Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte Kogna_PWM_Prescale { get; }
Public ReadOnly Property Kogna_PWM_Prescale As Byte
    Get
public:
property unsigned char Kogna_PWM_Prescale {
    unsigned char get ();
}

Property Value

Byte
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.OutputChan0 Property

KM_MainStatusOutputChan0 Property

Bulk status record Axis First output channel specified

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] OutputChan0 { get; }
Public ReadOnly Property OutputChan0 As Byte()
    Get
public:
property array<unsigned char>^ OutputChan0 {
    array<unsigned char>^ get ();
}

Property Value

Byte
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.OutputModes Property

KM_MainStatusOutputModes Property

Bulk status record feedback selected output modes Axes 0-3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes { get; }
Public ReadOnly Property OutputModes As Integer
    Get
public:
property int OutputModes {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.OutputModes2 Property

KM_MainStatusOutputModes2 Property

Bulk status record feedback selected output modes #2 Axes 4-7

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes2 { get; }
Public ReadOnly Property OutputModes2 As Integer
    Get
public:
property int OutputModes2 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.OutputModes3 Property

KM_MainStatusOutputModes3 Property

Bulk status record feedback selected output modes #3 Axes 8-11

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes3 { get; }
Public ReadOnly Property OutputModes3 As Integer
    Get
public:
property int OutputModes3 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.OutputModes4 Property

KM_MainStatusOutputModes4 Property

Bulk status record feedback selected output modes #4 Axes 11-15

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes4 { get; }
Public ReadOnly Property OutputModes4 As Integer
    Get
public:
property int OutputModes4 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.PC_comm Property

KM_MainStatusPC_comm Property

Bulk status record KFLOP-PC 8 Communication variables 100-107

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] PC_comm { get; }
Public ReadOnly Property PC_comm As Integer()
    Get
public:
property array<int>^ PC_comm {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.PinMuxModes Property

KM_MainStatusPinMuxModes Property

Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int PinMuxModes { get; }
Public ReadOnly Property PinMuxModes As Integer
    Get
public:
property int PinMuxModes {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.Position Property

KM_MainStatusPosition Property

Bulk status record Axis Measured positions (Encoder or other sensing device)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double[] Position { get; }
Public ReadOnly Property Position As Double()
    Get
public:
property array<double>^ Position {
    array<double>^ get ();
}

Property Value

Double
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.PWM Property

KM_MainStatusPWM Property

Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] PWM { get; }
Public ReadOnly Property PWM As Integer()
    Get
public:
property array<int>^ PWM {
    array<int>^ get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.RunOnStartUp Property

KM_MainStatusRunOnStartUp Property

Bulk status record Current Boot Thread Startup Enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int RunOnStartUp { get; }
Public ReadOnly Property RunOnStartUp As Integer
    Get
public:
property int RunOnStartUp {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.SnapBitsDirection0 Property

KM_MainStatusSnapBitsDirection0 Property

Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsDirection0 { get; }
Public ReadOnly Property SnapBitsDirection0 As Integer
    Get
public:
property int SnapBitsDirection0 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.SnapBitsDirection1 Property

KM_MainStatusSnapBitsDirection1 Property

Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsDirection1 { get; }
Public ReadOnly Property SnapBitsDirection1 As Integer
    Get
public:
property int SnapBitsDirection1 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.SnapBitsState0 Property

KM_MainStatusSnapBitsState0 Property

Bulk status record Current SnapAmp #0 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsState0 { get; }
Public ReadOnly Property SnapBitsState0 As Integer
    Get
public:
property int SnapBitsState0 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.SnapBitsState1 Property

KM_MainStatusSnapBitsState1 Property

Bulk status record Current SnapAmp #1 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsState1 { get; }
Public ReadOnly Property SnapBitsState1 As Integer
    Get
public:
property int SnapBitsState1 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.StopImmediateState Property

KM_MainStatusStopImmediateState Property

Bulk status record current StopImmediate (feedhold) state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int StopImmediateState { get; }
Public ReadOnly Property StopImmediateState As Integer
    Get
public:
property int StopImmediateState {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.ThreadActive Property

KM_MainStatusThreadActive Property

Bulk status record Current Thread Execution State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ThreadActive { get; }
Public ReadOnly Property ThreadActive As Integer
    Get
public:
property int ThreadActive {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.TicksAtUpdate Property

KM_MainStatusTicksAtUpdate Property

Bulk status record Windows Time when status was updates (millisec since Windows Started)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int TicksAtUpdate { get; }
Public ReadOnly Property TicksAtUpdate As Integer
    Get
public:
property int TicksAtUpdate {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.TimeStamp Property

KM_MainStatusTimeStamp Property

Bulk status record Time Stamp in seconds of when status was acquired

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TimeStamp { get; }
Public ReadOnly Property TimeStamp As Double
    Get
public:
property double TimeStamp {
    double get ();
}

Property Value

Double
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.VersionAndSize Property

KM_MainStatusVersionAndSize Property

Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int VersionAndSize { get; }
Public ReadOnly Property VersionAndSize As Integer
    Get
public:
property int VersionAndSize {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.VirtualBits Property

KM_MainStatusVirtualBits Property

Bulk status record Virtual bits packed 16 per word 48-63

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int VirtualBits { get; }
Public ReadOnly Property VirtualBits As Integer
    Get
public:
property int VirtualBits {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.VirtualBitsEx0 Property

KM_MainStatusVirtualBitsEx0 Property

Bulk status record Extended Virtual bits packed 32 per word 1024-1055

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int VirtualBitsEx0 { get; }
Public ReadOnly Property VirtualBitsEx0 As Integer
    Get
public:
property int VirtualBitsEx0 {
    int get ();
}

Property Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus Methods

The KM_MainStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetADC | Bulk status record ADC values (Kanalog)
Public method | GetAxisComplete | Bulk status record Current axis completes
Public method | GetAxisEnabled | Bulk status record Current axis enables
Public method | GetBitDirection200 | Bulk status record Current Kogna 24 IO Bit directions for Bits 200-223(inputs vs outputs)
Public method | GetBitDirection280 | Bulk status record Current Kogna 10 IO Bit directions for Bits 280-289(inputs vs outputs)
Public method | GetBitState200 | Bulk status record Current Kogna 90 IO Bit states (Bits 200-289)
Public method | GetDAC | Bulk status record DAC values (Kanalog)
Public method | GetDestination | Bulk status record Axis Commanded Destinations
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetInputMode | Bulk status record feedback selected 4-bit input mode
Public method | GetKanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public method | GetKanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public method | GetKFlopBitDirection | Bulk status record Current KFLOP/Kogna 64 IO Bit directions (inputs vs outputs)
Public method | GetKFlopBitState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public method | GetKognaADC | Bulk status record Current Kogna ADC
Public method | GetKognaDAC | Bulk status record Current Kogna DAC
Public method | GetKognaHRPWM | Bulk status record Current Kogna Hi-Res 12-bit PWM pulse setting
Public method | GetKognaPWM | Bulk status record Current Kogna 8-bit PWM pulse setting
Public method | GetKognaPWMEnables | Bulk status record Current Kogna 8-bit PWM Enables
Public method | GetOutputChannel0 | Bulk status record Axis First output channel specified
Public method | GetOutputMode | Bulk status record 4-bit output mode
Public method | GetPC_comm | Bulk status record Current PC-KFLOP Comm regs
Public method | GetPinMuxModes | Bulk status record Current Kogna 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public method | GetPosition | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public method | GetPWM | Bulk status record PWM values (SnapAmp)
Public method | GetRunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public method | GetSnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public method | GetSnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public method | GetSnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public method | GetSnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public method | GetThreadActive | Bulk status record Current Thread Execution State
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVirtualBits | Bulk status record Current Virtual Bit States
Public method | GetVirtualBitsEx0 | Bulk status record Current Extended Virtual Bit States
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetADC Method

KM_MainStatusGetADC Method

Bulk status record ADC values (Kanalog)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetADC(
    int index
)
Public Function GetADC (
    index As Integer
) As Integer
public:
int GetADC(
    int index
)

Parameters

index Int32
channel number to get

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetAxisComplete Method

KM_MainStatusGetAxisComplete Method

Bulk status record Current axis completes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetAxisComplete(
    int axischannel
)
Public Function GetAxisComplete (
    axischannel As Integer
) As Integer
public:
int GetAxisComplete(
    int axischannel
)

Parameters

axischannel Int32
Axis Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetAxisEnabled Method

KM_MainStatusGetAxisEnabled Method

Bulk status record Current axis enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetAxisEnabled(
    int axischannel
)
Public Function GetAxisEnabled (
    axischannel As Integer
) As Integer
public:
int GetAxisEnabled(
    int axischannel
)

Parameters

axischannel Int32
Axis Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetBitDirection200 Method

KM_MainStatusGetBitDirection200 Method

Bulk status record Current Kogna 24 IO Bit directions for Bits 200-223(inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetBitDirection200(
    int index
)
Public Function GetBitDirection200 (
    index As Integer
) As Integer
public:
int GetBitDirection200(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value 0=input 1=output
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetBitDirection280 Method

KM_MainStatusGetBitDirection280 Method

Bulk status record Current Kogna 10 IO Bit directions for Bits 280-289(inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetBitDirection280(
    int index
)
Public Function GetBitDirection280 (
    index As Integer
) As Integer
public:
int GetBitDirection280(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value 0=input 1=output
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetBitState200 Method

KM_MainStatusGetBitState200 Method

Bulk status record Current Kogna 90 IO Bit states (Bits 200-289)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetBitState200(
    int index
)
Public Function GetBitState200 (
    index As Integer
) As Integer
public:
int GetBitState200(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetDAC Method

KM_MainStatusGetDAC Method

Bulk status record DAC values (Kanalog)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetDAC(
    int index
)
Public Function GetDAC (
    index As Integer
) As Integer
public:
int GetDAC(
    int index
)

Parameters

index Int32
channel number to get

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetDestination Method

KM_MainStatusGetDestination Method

Bulk status record Axis Commanded Destinations

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetDestination(
    int index
)
Public Function GetDestination (
    index As Integer
) As Double
public:
double GetDestination(
    int index
)

Parameters

index Int32
Axis Number

Return Value

Double
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetInputMode Method

KM_MainStatusGetInputMode Method

Bulk status record feedback selected 4-bit input mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetInputMode(
    int axischannel
)
Public Function GetInputMode (
    axischannel As Integer
) As Integer
public:
int GetInputMode(
    int axischannel
)

Parameters

axischannel Int32
Axis Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKanalogBitsStateInputs Method

KM_MainStatusGetKanalogBitsStateInputs Method

Bulk status record Current Kanalog Input Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKanalogBitsStateInputs(
    int index
)
Public Function GetKanalogBitsStateInputs (
    index As Integer
) As Integer
public:
int GetKanalogBitsStateInputs(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKanalogBitsStateOutputs Method

KM_MainStatusGetKanalogBitsStateOutputs Method

Bulk status record Current Kanalog Output Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKanalogBitsStateOutputs(
    int index
)
Public Function GetKanalogBitsStateOutputs (
    index As Integer
) As Integer
public:
int GetKanalogBitsStateOutputs(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKFlopBitDirection Method

KM_MainStatusGetKFlopBitDirection Method

Bulk status record Current KFLOP/Kogna 64 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKFlopBitDirection(
    int index
)
Public Function GetKFlopBitDirection (
    index As Integer
) As Integer
public:
int GetKFlopBitDirection(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value 0=input 1=output
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKFlopBitState Method

KM_MainStatusGetKFlopBitState Method

Bulk status record Current KFLOP/Kogna 64 IO Bit states

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKFlopBitState(
    int index
)
Public Function GetKFlopBitState (
    index As Integer
) As Integer
public:
int GetKFlopBitState(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKognaADC Method

KM_MainStatusGetKognaADC Method

Bulk status record Current Kogna ADC

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKognaADC(
    int index
)
Public Function GetKognaADC (
    index As Integer
) As Integer
public:
int GetKognaADC(
    int index
)

Parameters

index Int32
channel 0-3

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKognaDAC Method

KM_MainStatusGetKognaDAC Method

Bulk status record Current Kogna DAC

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKognaDAC(
    int index
)
Public Function GetKognaDAC (
    index As Integer
) As Integer
public:
int GetKognaDAC(
    int index
)

Parameters

index Int32
channel 0-7

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKognaHRPWM Method

KM_MainStatusGetKognaHRPWM Method

Bulk status record Current Kogna Hi-Res 12-bit PWM pulse setting

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKognaHRPWM(
    int index
)
Public Function GetKognaHRPWM (
    index As Integer
) As Integer
public:
int GetKognaHRPWM(
    int index
)

Parameters

index Int32
channel 0-3

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKognaPWM Method

KM_MainStatusGetKognaPWM Method

Bulk status record Current Kogna 8-bit PWM pulse setting

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKognaPWM(
    int index
)
Public Function GetKognaPWM (
    index As Integer
) As Integer
public:
int GetKognaPWM(
    int index
)

Parameters

index Int32
channel 0-7

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetKognaPWMEnables Method

KM_MainStatusGetKognaPWMEnables Method

Bulk status record Current Kogna 8-bit PWM Enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetKognaPWMEnables(
    int index
)
Public Function GetKognaPWMEnables (
    index As Integer
) As Integer
public:
int GetKognaPWMEnables(
    int index
)

Parameters

index Int32
channel 0-7

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetOutputChannel0 Method

KM_MainStatusGetOutputChannel0 Method

Bulk status record Axis First output channel specified

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetOutputChannel0(
    int index
)
Public Function GetOutputChannel0 (
    index As Integer
) As Double
public:
double GetOutputChannel0(
    int index
)

Parameters

index Int32
Axis Number

Return Value

Double
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetOutputMode Method

KM_MainStatusGetOutputMode Method

Bulk status record 4-bit output mode

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetOutputMode(
    int axischannel
)
Public Function GetOutputMode (
    axischannel As Integer
) As Integer
public:
int GetOutputMode(
    int axischannel
)

Parameters

axischannel Int32
Axis Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetPC_comm Method

KM_MainStatusGetPC_comm Method

Bulk status record Current PC-KFLOP Comm regs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetPC_comm(
    int index
)
Public Function GetPC_comm (
    index As Integer
) As Integer
public:
int GetPC_comm(
    int index
)

Parameters

index Int32
Comm Register Index

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetPinMuxModes Method

KM_MainStatusGetPinMuxModes Method

Bulk status record Current Kogna 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetPinMuxModes(
    int index
)
Public Function GetPinMuxModes (
    index As Integer
) As Integer
public:
int GetPinMuxModes(
    int index
)

Parameters

index Int32
device selector 0-9 (0-3 HRPWM, 4-9 SPI)

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetPosition Method

KM_MainStatusGetPosition Method

Bulk status record Axis Measured positions (Encoder or other sensing device)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double GetPosition(
    int index
)
Public Function GetPosition (
    index As Integer
) As Double
public:
double GetPosition(
    int index
)

Parameters

index Int32
Axis Number

Return Value

Double
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetPWM Method

KM_MainStatusGetPWM Method

Bulk status record PWM values (SnapAmp)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetPWM(
    int index
)
Public Function GetPWM (
    index As Integer
) As Integer
public:
int GetPWM(
    int index
)

Parameters

index Int32
channel number to get (8 obsolete + 2 x 4 SnapAmp)

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetRunOnStartUp Method

KM_MainStatusGetRunOnStartUp Method

Bulk status record Current Boot Thread Startup Enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetRunOnStartUp(
    int index
)
Public Function GetRunOnStartUp (
    index As Integer
) As Integer
public:
int GetRunOnStartUp(
    int index
)

Parameters

index Int32
Thread Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetSnapBitsDirection0 Method

KM_MainStatusGetSnapBitsDirection0 Method

Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetSnapBitsDirection0(
    int index
)
Public Function GetSnapBitsDirection0 (
    index As Integer
) As Integer
public:
int GetSnapBitsDirection0(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetSnapBitsDirection1 Method

KM_MainStatusGetSnapBitsDirection1 Method

Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetSnapBitsDirection1(
    int index
)
Public Function GetSnapBitsDirection1 (
    index As Integer
) As Integer
public:
int GetSnapBitsDirection1(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value 0=input 1=output
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetSnapBitsState0 Method

KM_MainStatusGetSnapBitsState0 Method

Bulk status record Current SnapAmp #0 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetSnapBitsState0(
    int index
)
Public Function GetSnapBitsState0 (
    index As Integer
) As Integer
public:
int GetSnapBitsState0(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetSnapBitsState1 Method

KM_MainStatusGetSnapBitsState1 Method

Bulk status record Current SnapAmp #1 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetSnapBitsState1(
    int index
)
Public Function GetSnapBitsState1 (
    index As Integer
) As Integer
public:
int GetSnapBitsState1(
    int index
)

Parameters

index Int32
IO Bit Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetThreadActive Method

KM_MainStatusGetThreadActive Method

Bulk status record Current Thread Execution State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetThreadActive(
    int index
)
Public Function GetThreadActive (
    index As Integer
) As Integer
public:
int GetThreadActive(
    int index
)

Parameters

index Int32
Thread Number

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetVirtualBits Method

KM_MainStatusGetVirtualBits Method

Bulk status record Current Virtual Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetVirtualBits(
    int index
)
Public Function GetVirtualBits (
    index As Integer
) As Integer
public:
int GetVirtualBits(
    int index
)

Parameters

index Int32
Bit Offset

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.GetVirtualBitsEx0 Method

KM_MainStatusGetVirtualBitsEx0 Method

Bulk status record Current Extended Virtual Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int GetVirtualBitsEx0(
    int index
)
Public Function GetVirtualBitsEx0 (
    index As Integer
) As Integer
public:
int GetVirtualBitsEx0(
    int index
)

Parameters

index Int32
Bit Offset 0-31 where 0 returns Virtual bit 1024

Return Value

Int32
value
See Also

Reference

KM_MainStatus Structure


KM_MainStatus Fields

The KM_MainStatus type exposes the following members.

Fields
 | Name | Description
Public field | _TicksAtUpdate | Time in milliseconds since Windows Started where Status record was last uploaded Note: rolls over every 49 days
Public field | MainStatus | This structure matches exactly the binary form as the Kogna/KFLOP MAIN_STATUS Structure so it can be uploaded as a binary image.
Top
See Also

Reference

KM_MainStatus Structure


KM_MainStatus._TicksAtUpdate Field

KM_MainStatus_TicksAtUpdate Field

Time in milliseconds since Windows Started where Status record was last uploaded Note: rolls over every 49 days

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int _TicksAtUpdate
Public _TicksAtUpdate As Integer
public:
int _TicksAtUpdate

Field Value

Int32
See Also

Reference

KM_MainStatus Structure


KM_MainStatus.MainStatus Field

KM_MainStatusMainStatus Field

This structure matches exactly the binary form as the Kogna/KFLOP MAIN_STATUS Structure so it can be uploaded as a binary image.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_MainStatusRaw MainStatus
Public MainStatus As KM_MainStatusRaw
public:
KM_MainStatusRaw MainStatus

Field Value

KM_MainStatusRaw
See Also

Reference

KM_MainStatus Structure


KM_MainStatusRaw Structure

This structure matches exactly the binary form as the Kogna/KFLOP MAIN_STATUS Structure so it can be uploaded as a binary image.
Inheritance Hierarchy
SystemObject
SystemValueType
KMotion_dotNetKM_MainStatusRaw

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public struct KM_MainStatusRaw
Public Structure KM_MainStatusRaw
public value class KM_MainStatusRaw

The KM_MainStatusRaw type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
Fields
 | Name | Description
Public field | ADC | Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)
Public field | AxisDone | Bulk status record Current axis completes
Public field | BitsDirection | Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)
Public field | BitsDirection200 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output
Public field | BitsDirection280 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output
Public field | BitsState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public field | BitsState200 | Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200
Public field | DAC | Bulk status record DAC values (8 Kanalog)
Public field | Destination | Bulk status record Axis Commanded Destinations
Public field | Enables | Bulk status record Current axis enables
Public field | HRPWM | Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths
Public field | HRPWMPeriod01 | Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)
Public field | HRPWMPeriod2 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)
Public field | HRPWMPeriod3 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)
Public field | InputModes | Bulk status record feedback selected input modes 4 bits for each axis (not sure why only using 16 of 32 bits) Axes 0-3
Public field | InputModes2 | Bulk status record feedback selected input modes #2 4 bits for each axis Axes 4-7
Public field | InputModes3 | Bulk status record feedback selected input modes #3 4 bits for each axis Axes 8-11
Public field | InputModes4 | Bulk status record feedback selected input modes #4 4 bits for each axis Axes 12-15
Public field | KanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public field | KanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public field | Kogna_ADC | Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)
Public field | Kogna_DAC | Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)
Public field | Kogna_PWM | Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs
Public field | Kogna_PWM_Enables | Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs
Public field | Kogna_PWM_Prescale | Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs
Public field | OutputChan0 | Bulk status record Axis First output channel specified
Public field | OutputModes | Bulk status record feedback selected output modes Axes 0-3
Public field | OutputModes2 | Bulk status record feedback selected output modes #2 Axes 4-7
Public field | OutputModes3 | Bulk status record feedback selected output modes #3 Axes 8-11
Public field | OutputModes4 | Bulk status record feedback selected output modes #4 Axes 11-15
Public field | PC_comm | Bulk status record KFLOP-PC 8 Communication variables 100-107
Public field | PinMuxModes | Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public field | Position | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public field | PWM | Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)
Public field | RunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public field | SnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public field | SnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public field | SnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public field | SnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public field | StopImmediateState | Bulk status record current StopImmediate (feedhold) state
Public field | ThreadActive | Bulk status record Current Thread Execution State
Public field | TimeStamp | Bulk status record Time Stamp in seconds of when status was acquired
Public field | VersionAndSize | Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words
Public field | VirtualBits | Bulk status record Virtual bits packed 16 per word 48-63
Public field | VirtualBitsEx0 | Bulk status record Extended Virtual bits packed 32 per word 1024-1055
Top
See Also

Reference

KMotion_dotNet Namespace


KM_MainStatusRaw Methods

The KM_MainStatusRaw type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw Fields

The KM_MainStatusRaw type exposes the following members.

Fields
 | Name | Description
Public field | ADC | Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)
Public field | AxisDone | Bulk status record Current axis completes
Public field | BitsDirection | Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)
Public field | BitsDirection200 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output
Public field | BitsDirection280 | Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output
Public field | BitsState | Bulk status record Current KFLOP/Kogna 64 IO Bit states
Public field | BitsState200 | Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200
Public field | DAC | Bulk status record DAC values (8 Kanalog)
Public field | Destination | Bulk status record Axis Commanded Destinations
Public field | Enables | Bulk status record Current axis enables
Public field | HRPWM | Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths
Public field | HRPWMPeriod01 | Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)
Public field | HRPWMPeriod2 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)
Public field | HRPWMPeriod3 | Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)
Public field | InputModes | Bulk status record feedback selected input modes 4 bits for each axis (not sure why only using 16 of 32 bits) Axes 0-3
Public field | InputModes2 | Bulk status record feedback selected input modes #2 4 bits for each axis Axes 4-7
Public field | InputModes3 | Bulk status record feedback selected input modes #3 4 bits for each axis Axes 8-11
Public field | InputModes4 | Bulk status record feedback selected input modes #4 4 bits for each axis Axes 12-15
Public field | KanalogBitsStateInputs | Bulk status record Current Kanalog Input Bit States
Public field | KanalogBitsStateOutputs | Bulk status record Current Kanalog Output Bit States
Public field | Kogna_ADC | Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)
Public field | Kogna_DAC | Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)
Public field | Kogna_PWM | Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs
Public field | Kogna_PWM_Enables | Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs
Public field | Kogna_PWM_Prescale | Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs
Public field | OutputChan0 | Bulk status record Axis First output channel specified
Public field | OutputModes | Bulk status record feedback selected output modes Axes 0-3
Public field | OutputModes2 | Bulk status record feedback selected output modes #2 Axes 4-7
Public field | OutputModes3 | Bulk status record feedback selected output modes #3 Axes 8-11
Public field | OutputModes4 | Bulk status record feedback selected output modes #4 Axes 11-15
Public field | PC_comm | Bulk status record KFLOP-PC 8 Communication variables 100-107
Public field | PinMuxModes | Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI
Public field | Position | Bulk status record Axis Measured positions (Encoder or other sensing device)
Public field | PWM | Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)
Public field | RunOnStartUp | Bulk status record Current Boot Thread Startup Enables
Public field | SnapBitsDirection0 | Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)
Public field | SnapBitsDirection1 | Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)
Public field | SnapBitsState0 | Bulk status record Current SnapAmp #0 IO Bit States
Public field | SnapBitsState1 | Bulk status record Current SnapAmp #1 IO Bit States
Public field | StopImmediateState | Bulk status record current StopImmediate (feedhold) state
Public field | ThreadActive | Bulk status record Current Thread Execution State
Public field | TimeStamp | Bulk status record Time Stamp in seconds of when status was acquired
Public field | VersionAndSize | Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words
Public field | VirtualBits | Bulk status record Virtual bits packed 16 per word 48-63
Public field | VirtualBitsEx0 | Bulk status record Extended Virtual bits packed 32 per word 1024-1055
Top
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.ADC Field

KM_MainStatusRawADC Field

Bulk status record ADC values (8 Kanalog + 2 x 8 SnapAmp)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] ADC
Public ADC As Integer()
public:
array<int>^ ADC

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.AxisDone Field

KM_MainStatusRawAxisDone Field

Bulk status record Current axis completes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int AxisDone
Public AxisDone As Integer
public:
int AxisDone

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.BitsDirection Field

KM_MainStatusRawBitsDirection Field

Bulk status record Current KFLOP 64 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsDirection
Public BitsDirection As Integer()
public:
array<int>^ BitsDirection

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.BitsDirection200 Field

KM_MainStatusRawBitsDirection200 Field

Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 24 bits 200-223 of I/O direction 1 = output

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BitsDirection200
Public BitsDirection200 As Integer
public:
int BitsDirection200

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.BitsDirection280 Field

KM_MainStatusRawBitsDirection280 Field

Bulk status record Current Kogna IO Bit directions (inputs vs outputs) Kogna - 10 bits 280-289 of I/O direction 1 = output

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int BitsDirection280
Public BitsDirection280 As Integer
public:
int BitsDirection280

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.BitsState Field

KM_MainStatusRawBitsState Field

Bulk status record Current KFLOP/Kogna 64 IO Bit states

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsState
Public BitsState As Integer()
public:
array<int>^ BitsState

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.BitsState200 Field

KM_MainStatusRawBitsState200 Field

Bulk status record Current KFLOP/Kogna 64 IO Bit states Kogna - 90 bits 200-289 of state lsb=I/O bit200

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] BitsState200
Public BitsState200 As Integer()
public:
array<int>^ BitsState200

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.DAC Field

KM_MainStatusRawDAC Field

Bulk status record DAC values (8 Kanalog)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] DAC
Public DAC As Integer()
public:
array<int>^ DAC

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Destination Field

KM_MainStatusRawDestination Field

Bulk status record Axis Commanded Destinations

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double[] Destination
Public Destination As Double()
public:
array<double>^ Destination

Field Value

Double
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Enables Field

KM_MainStatusRawEnables Field

Bulk status record Current axis enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int Enables
Public Enables As Integer
public:
int Enables

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.HRPWM Field

KM_MainStatusRawHRPWM Field

Bulk status record Kogna current Kogna Kogna 4 HRPWMs Pulse widths

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort[] HRPWM
Public HRPWM As UShort()
public:
array<unsigned short>^ HRPWM

Field Value

UInt16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.HRPWMPeriod01 Field

KM_MainStatusRawHRPWMPeriod01 Field

Bulk status record Kogna current Kogna HRPWMs Periods (common for HRPWM 0 and 1)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod01
Public HRPWMPeriod01 As UShort
public:
unsigned short HRPWMPeriod01

Field Value

UInt16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.HRPWMPeriod2 Field

KM_MainStatusRawHRPWMPeriod2 Field

Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 2)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod2
Public HRPWMPeriod2 As UShort
public:
unsigned short HRPWMPeriod2

Field Value

UInt16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.HRPWMPeriod3 Field

KM_MainStatusRawHRPWMPeriod3 Field

Bulk status record Kogna current Kogna HRPWM Periods (for HRPWM 3)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public ushort HRPWMPeriod3
Public HRPWMPeriod3 As UShort
public:
unsigned short HRPWMPeriod3

Field Value

UInt16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.InputModes Field

KM_MainStatusRawInputModes Field

Bulk status record feedback selected input modes 4 bits for each axis (not sure why only using 16 of 32 bits) Axes 0-3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes
Public InputModes As Integer
public:
int InputModes

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.InputModes2 Field

KM_MainStatusRawInputModes2 Field

Bulk status record feedback selected input modes #2 4 bits for each axis Axes 4-7

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes2
Public InputModes2 As Integer
public:
int InputModes2

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.InputModes3 Field

KM_MainStatusRawInputModes3 Field

Bulk status record feedback selected input modes #3 4 bits for each axis Axes 8-11

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes3
Public InputModes3 As Integer
public:
int InputModes3

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.InputModes4 Field

KM_MainStatusRawInputModes4 Field

Bulk status record feedback selected input modes #4 4 bits for each axis Axes 12-15

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int InputModes4
Public InputModes4 As Integer
public:
int InputModes4

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.KanalogBitsStateInputs Field

KM_MainStatusRawKanalogBitsStateInputs Field

Bulk status record Current Kanalog Input Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int KanalogBitsStateInputs
Public KanalogBitsStateInputs As Integer
public:
int KanalogBitsStateInputs

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.KanalogBitsStateOutputs Field

KM_MainStatusRawKanalogBitsStateOutputs Field

Bulk status record Current Kanalog Output Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int KanalogBitsStateOutputs
Public KanalogBitsStateOutputs As Integer
public:
int KanalogBitsStateOutputs

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Kogna_ADC Field

KM_MainStatusRawKogna_ADC Field

Bulk status record Kogna 4 ADCs format 12 bits data (signed extended to 16 bits)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public short[] Kogna_ADC
Public Kogna_ADC As Short()
public:
array<short>^ Kogna_ADC

Field Value

Int16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Kogna_DAC Field

KM_MainStatusRawKogna_DAC Field

Bulk status record Kogna 8 DACSs format 12 bits data (signed extended to 16 bits)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public short[] Kogna_DAC
Public Kogna_DAC As Short()
public:
array<short>^ Kogna_DAC

Field Value

Int16
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Kogna_PWM Field

KM_MainStatusRawKogna_PWM Field

Bulk status record Kogna current pulse settings of all 8 8-bit IO PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] Kogna_PWM
Public Kogna_PWM As Byte()
public:
array<unsigned char>^ Kogna_PWM

Field Value

Byte
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Kogna_PWM_Enables Field

KM_MainStatusRawKogna_PWM_Enables Field

Bulk status record Kogna current PWM Enables to control Pin of all 8 8-bit IO PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] Kogna_PWM_Enables
Public Kogna_PWM_Enables As Byte()
public:
array<unsigned char>^ Kogna_PWM_Enables

Field Value

Byte
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Kogna_PWM_Prescale Field

KM_MainStatusRawKogna_PWM_Prescale Field

Bulk status record Kogna Prescale sets frequency of all 8 8-bit PWMs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte Kogna_PWM_Prescale
Public Kogna_PWM_Prescale As Byte
public:
unsigned char Kogna_PWM_Prescale

Field Value

Byte
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.OutputChan0 Field

KM_MainStatusRawOutputChan0 Field

Bulk status record Axis First output channel specified

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public byte[] OutputChan0
Public OutputChan0 As Byte()
public:
array<unsigned char>^ OutputChan0

Field Value

Byte
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.OutputModes Field

KM_MainStatusRawOutputModes Field

Bulk status record feedback selected output modes Axes 0-3

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes
Public OutputModes As Integer
public:
int OutputModes

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.OutputModes2 Field

KM_MainStatusRawOutputModes2 Field

Bulk status record feedback selected output modes #2 Axes 4-7

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes2
Public OutputModes2 As Integer
public:
int OutputModes2

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.OutputModes3 Field

KM_MainStatusRawOutputModes3 Field

Bulk status record feedback selected output modes #3 Axes 8-11

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes3
Public OutputModes3 As Integer
public:
int OutputModes3

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.OutputModes4 Field

KM_MainStatusRawOutputModes4 Field

Bulk status record feedback selected output modes #4 Axes 11-15

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int OutputModes4
Public OutputModes4 As Integer
public:
int OutputModes4

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.PC_comm Field

KM_MainStatusRawPC_comm Field

Bulk status record KFLOP-PC 8 Communication variables 100-107

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] PC_comm
Public PC_comm As Integer()
public:
array<int>^ PC_comm

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.PinMuxModes Field

KM_MainStatusRawPinMuxModes Field

Bulk status record Kogna - 10 Pin function modes 2 bits per pin 4 HRPWM + 6 SPI

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int PinMuxModes
Public PinMuxModes As Integer
public:
int PinMuxModes

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.Position Field

KM_MainStatusRawPosition Field

Bulk status record Axis Measured positions (Encoder or other sensing device)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double[] Position
Public Position As Double()
public:
array<double>^ Position

Field Value

Double
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.PWM Field

KM_MainStatusRawPWM Field

Bulk status record PWM values (8 obsolete PWMS + 2 x 4 SnapAmp)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int[] PWM
Public PWM As Integer()
public:
array<int>^ PWM

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.RunOnStartUp Field

KM_MainStatusRawRunOnStartUp Field

Bulk status record Current Boot Thread Startup Enables

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int RunOnStartUp
Public RunOnStartUp As Integer
public:
int RunOnStartUp

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.SnapBitsDirection0 Field

KM_MainStatusRawSnapBitsDirection0 Field

Bulk status record Current SnapAmp #0 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsDirection0
Public SnapBitsDirection0 As Integer
public:
int SnapBitsDirection0

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.SnapBitsDirection1 Field

KM_MainStatusRawSnapBitsDirection1 Field

Bulk status record Current SnapAmp #1 IO Bit directions (inputs vs outputs)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsDirection1
Public SnapBitsDirection1 As Integer
public:
int SnapBitsDirection1

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.SnapBitsState0 Field

KM_MainStatusRawSnapBitsState0 Field

Bulk status record Current SnapAmp #0 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsState0
Public SnapBitsState0 As Integer
public:
int SnapBitsState0

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.SnapBitsState1 Field

KM_MainStatusRawSnapBitsState1 Field

Bulk status record Current SnapAmp #1 IO Bit States

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int SnapBitsState1
Public SnapBitsState1 As Integer
public:
int SnapBitsState1

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.StopImmediateState Field

KM_MainStatusRawStopImmediateState Field

Bulk status record current StopImmediate (feedhold) state

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int StopImmediateState
Public StopImmediateState As Integer
public:
int StopImmediateState

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.ThreadActive Field

KM_MainStatusRawThreadActive Field

Bulk status record Current Thread Execution State

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int ThreadActive
Public ThreadActive As Integer
public:
int ThreadActive

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.TimeStamp Field

KM_MainStatusRawTimeStamp Field

Bulk status record Time Stamp in seconds of when status was acquired

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TimeStamp
Public TimeStamp As Double
public:
double TimeStamp

Field Value

Double
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.VersionAndSize Field

KM_MainStatusRawVersionAndSize Field

Bulk status record packed version and size info bits 16-23 = version, bits 0-15 = size in words

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public int VersionAndSize
Public VersionAndSize As Integer
public:
int VersionAndSize

Field Value

Int32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.VirtualBits Field

KM_MainStatusRawVirtualBits Field

Bulk status record Virtual bits packed 16 per word 48-63

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public uint VirtualBits
Public VirtualBits As UInteger
public:
unsigned int VirtualBits

Field Value

UInt32
See Also

Reference

KM_MainStatusRaw Structure


KM_MainStatusRaw.VirtualBitsEx0 Field

KM_MainStatusRawVirtualBitsEx0 Field

Bulk status record Extended Virtual bits packed 32 per word 1024-1055

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public uint VirtualBitsEx0
Public VirtualBitsEx0 As UInteger
public:
unsigned int VirtualBitsEx0

Field Value

UInt32
See Also

Reference

KM_MainStatusRaw Structure


KM_MotionParams Class

Trajectory Planner Motion Parameter Settings
Inheritance Hierarchy
SystemObject
KMotion_dotNetKM_MotionParams

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class KM_MotionParams
Public Class KM_MotionParams
public ref class KM_MotionParams

The KM_MotionParams type exposes the following members.

Constructors
 | Name | Description
Public method | KM_MotionParams | Primary constructor for the KM_MotionParams object
Top
Properties
 | Name | Description
Public property | ArcsToSegs | Converts Arcs to linear segments (User Setting)
Public property | BreakAngle | Max angle before Trajectory Planner locks the segment list and optimizes next entities
Public property | CollinearTolerance | If the angle between consecutive linear segments is less than this value, they will be treated as the same segment
Public property | CornerTolerance | Maximum variance when smoothed cornering is applied
Public property | CountsPerInchA | Counts/Steps per Inch for the mapped "A" axis
Public property | CountsPerInchB | Counts/Steps per Inch for the mapped "B" axis
Public property | CountsPerInchC | Counts/Steps per Inch for the mapped "C" axis
Public property | CountsPerInchX | Counts/Steps per Inch for the mapped "X" axis
Public property | CountsPerInchY | Counts/Steps per Inch for the mapped "Y" axis
Public property | CountsPerInchZ | Counts/Steps per Inch for the mapped "Z" axis
Public property | DegreesA | Whether Axis A is in units of Degrees
Public property | DegreesB | Whether Axis B is in units of Degrees
Public property | DegreesC | Whether Axis C is in units of Degrees
Public property | DoRapidsAsFeeds | Property for DoRapidsAsFeeds (For non-linear Kinematics Rapids must be treated as feeds and subdivided)
Public property | FacetAngle | Max anglular deviation for arc segments
Public property | MaxAccelA | Maximum Acceleration for the mapped "A" axis
Public property | MaxAccelB | Maximum Acceleration for the mapped "B" axis
Public property | MaxAccelC | Maximum Acceleration for the mapped "C" axis
Public property | MaxAccelX | Maximum Acceleration for the mapped "X" axis
Public property | MaxAccelY | Maximum Acceleration for the mapped "Y" axis
Public property | MaxAccelZ | Maximum Acceleration for the mapped "Z" axis
Public property | MaxLinearLength | Longest allowable segment length before dividing into smaller segments
Public property | MaxVelA | Maximum Velocity for the mapped "A" axis
Public property | MaxVelB | Maximum Velocity for the mapped "B" axis
Public property | MaxVelC | Maximum Velocity for the mapped "C" axis
Public property | MaxVelX | Maximum Velocity for the mapped "X" axis
Public property | MaxVelY | Maximum Velocity for the mapped "Y" axis
Public property | MaxVelZ | Maximum Velocity for the mapped "Z" axis
Public property | RadiusA | Radius Associated with Axis A
Public property | RadiusB | Radius Associated with Axis B
Public property | RadiusC | Radius Associated with Axis C
Public property | TCP_Active | Whether RTCP (Kinematics) is Active or not.
Public property | TPLookahead | How many seconds can be previewed for Trajectory Planning optimization
Public property | UseOnlyLinearSegments | Converts Arcs to linear segments (Kinematic Setting)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetTPParams | Force the Trajectory Planner to update it's parameters
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KMotion_dotNet Namespace


KM_MotionParams Constructor

Primary constructor for the KM_MotionParams object

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public KM_MotionParams(
    IntPtr handle
)
Public Sub New (
    handle As IntPtr
)
public:
KM_MotionParams(
    IntPtr handle
)

Parameters

handle IntPtr
Pointer to the associated CoordMotion object
See Also

Reference

KM_MotionParams Class


KM_MotionParams Properties

The KM_MotionParams type exposes the following members.

Properties
 | Name | Description
Public property | ArcsToSegs | Converts Arcs to linear segments (User Setting)
Public property | BreakAngle | Max angle before Trajectory Planner locks the segment list and optimizes next entities
Public property | CollinearTolerance | If the angle between consecutive linear segments is less than this value, they will be treated as the same segment
Public property | CornerTolerance | Maximum variance when smoothed cornering is applied
Public property | CountsPerInchA | Counts/Steps per Inch for the mapped "A" axis
Public property | CountsPerInchB | Counts/Steps per Inch for the mapped "B" axis
Public property | CountsPerInchC | Counts/Steps per Inch for the mapped "C" axis
Public property | CountsPerInchX | Counts/Steps per Inch for the mapped "X" axis
Public property | CountsPerInchY | Counts/Steps per Inch for the mapped "Y" axis
Public property | CountsPerInchZ | Counts/Steps per Inch for the mapped "Z" axis
Public property | DegreesA | Whether Axis A is in units of Degrees
Public property | DegreesB | Whether Axis B is in units of Degrees
Public property | DegreesC | Whether Axis C is in units of Degrees
Public property | DoRapidsAsFeeds | Property for DoRapidsAsFeeds (For non-linear Kinematics Rapids must be treated as feeds and subdivided)
Public property | FacetAngle | Max anglular deviation for arc segments
Public property | MaxAccelA | Maximum Acceleration for the mapped "A" axis
Public property | MaxAccelB | Maximum Acceleration for the mapped "B" axis
Public property | MaxAccelC | Maximum Acceleration for the mapped "C" axis
Public property | MaxAccelX | Maximum Acceleration for the mapped "X" axis
Public property | MaxAccelY | Maximum Acceleration for the mapped "Y" axis
Public property | MaxAccelZ | Maximum Acceleration for the mapped "Z" axis
Public property | MaxLinearLength | Longest allowable segment length before dividing into smaller segments
Public property | MaxVelA | Maximum Velocity for the mapped "A" axis
Public property | MaxVelB | Maximum Velocity for the mapped "B" axis
Public property | MaxVelC | Maximum Velocity for the mapped "C" axis
Public property | MaxVelX | Maximum Velocity for the mapped "X" axis
Public property | MaxVelY | Maximum Velocity for the mapped "Y" axis
Public property | MaxVelZ | Maximum Velocity for the mapped "Z" axis
Public property | RadiusA | Radius Associated with Axis A
Public property | RadiusB | Radius Associated with Axis B
Public property | RadiusC | Radius Associated with Axis C
Public property | TCP_Active | Whether RTCP (Kinematics) is Active or not.
Public property | TPLookahead | How many seconds can be previewed for Trajectory Planning optimization
Public property | UseOnlyLinearSegments | Converts Arcs to linear segments (Kinematic Setting)
Top
See Also

Reference

KM_MotionParams Class


KM_MotionParams.ArcsToSegs Property

KM_MotionParamsArcsToSegs Property

Converts Arcs to linear segments (User Setting)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool ArcsToSegs { get; set; }
Public Property ArcsToSegs As Boolean
    Get
    Set
public:
property bool ArcsToSegs {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.BreakAngle Property

KM_MotionParamsBreakAngle Property

Max angle before Trajectory Planner locks the segment list and optimizes next entities

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double BreakAngle { get; set; }
Public Property BreakAngle As Double
    Get
    Set
public:
property double BreakAngle {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CollinearTolerance Property

KM_MotionParamsCollinearTolerance Property

If the angle between consecutive linear segments is less than this value, they will be treated as the same segment

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CollinearTolerance { get; set; }
Public Property CollinearTolerance As Double
    Get
    Set
public:
property double CollinearTolerance {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CornerTolerance Property

KM_MotionParamsCornerTolerance Property

Maximum variance when smoothed cornering is applied

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CornerTolerance { get; set; }
Public Property CornerTolerance As Double
    Get
    Set
public:
property double CornerTolerance {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchA Property

KM_MotionParamsCountsPerInchA Property

Counts/Steps per Inch for the mapped "A" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchA { get; set; }
Public Property CountsPerInchA As Double
    Get
    Set
public:
property double CountsPerInchA {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchB Property

KM_MotionParamsCountsPerInchB Property

Counts/Steps per Inch for the mapped "B" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchB { get; set; }
Public Property CountsPerInchB As Double
    Get
    Set
public:
property double CountsPerInchB {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchC Property

KM_MotionParamsCountsPerInchC Property

Counts/Steps per Inch for the mapped "C" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchC { get; set; }
Public Property CountsPerInchC As Double
    Get
    Set
public:
property double CountsPerInchC {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchX Property

KM_MotionParamsCountsPerInchX Property

Counts/Steps per Inch for the mapped "X" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchX { get; set; }
Public Property CountsPerInchX As Double
    Get
    Set
public:
property double CountsPerInchX {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchY Property

KM_MotionParamsCountsPerInchY Property

Counts/Steps per Inch for the mapped "Y" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchY { get; set; }
Public Property CountsPerInchY As Double
    Get
    Set
public:
property double CountsPerInchY {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.CountsPerInchZ Property

KM_MotionParamsCountsPerInchZ Property

Counts/Steps per Inch for the mapped "Z" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double CountsPerInchZ { get; set; }
Public Property CountsPerInchZ As Double
    Get
    Set
public:
property double CountsPerInchZ {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.DegreesA Property

KM_MotionParamsDegreesA Property

Whether Axis A is in units of Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool DegreesA { get; set; }
Public Property DegreesA As Boolean
    Get
    Set
public:
property bool DegreesA {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.DegreesB Property

KM_MotionParamsDegreesB Property

Whether Axis B is in units of Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool DegreesB { get; set; }
Public Property DegreesB As Boolean
    Get
    Set
public:
property bool DegreesB {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.DegreesC Property

KM_MotionParamsDegreesC Property

Whether Axis C is in units of Degrees

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool DegreesC { get; set; }
Public Property DegreesC As Boolean
    Get
    Set
public:
property bool DegreesC {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.DoRapidsAsFeeds Property

KM_MotionParamsDoRapidsAsFeeds Property

Property for DoRapidsAsFeeds (For non-linear Kinematics Rapids must be treated as feeds and subdivided)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool DoRapidsAsFeeds { get; set; }
Public Property DoRapidsAsFeeds As Boolean
    Get
    Set
public:
property bool DoRapidsAsFeeds {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.FacetAngle Property

KM_MotionParamsFacetAngle Property

Max anglular deviation for arc segments

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double FacetAngle { get; set; }
Public Property FacetAngle As Double
    Get
    Set
public:
property double FacetAngle {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelA Property

KM_MotionParamsMaxAccelA Property

Maximum Acceleration for the mapped "A" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelA { get; set; }
Public Property MaxAccelA As Double
    Get
    Set
public:
property double MaxAccelA {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelB Property

KM_MotionParamsMaxAccelB Property

Maximum Acceleration for the mapped "B" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelB { get; set; }
Public Property MaxAccelB As Double
    Get
    Set
public:
property double MaxAccelB {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelC Property

KM_MotionParamsMaxAccelC Property

Maximum Acceleration for the mapped "C" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelC { get; set; }
Public Property MaxAccelC As Double
    Get
    Set
public:
property double MaxAccelC {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelX Property

KM_MotionParamsMaxAccelX Property

Maximum Acceleration for the mapped "X" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelX { get; set; }
Public Property MaxAccelX As Double
    Get
    Set
public:
property double MaxAccelX {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelY Property

KM_MotionParamsMaxAccelY Property

Maximum Acceleration for the mapped "Y" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelY { get; set; }
Public Property MaxAccelY As Double
    Get
    Set
public:
property double MaxAccelY {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxAccelZ Property

KM_MotionParamsMaxAccelZ Property

Maximum Acceleration for the mapped "Z" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxAccelZ { get; set; }
Public Property MaxAccelZ As Double
    Get
    Set
public:
property double MaxAccelZ {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxLinearLength Property

KM_MotionParamsMaxLinearLength Property

Longest allowable segment length before dividing into smaller segments

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxLinearLength { get; set; }
Public Property MaxLinearLength As Double
    Get
    Set
public:
property double MaxLinearLength {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelA Property

KM_MotionParamsMaxVelA Property

Maximum Velocity for the mapped "A" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelA { get; set; }
Public Property MaxVelA As Double
    Get
    Set
public:
property double MaxVelA {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelB Property

KM_MotionParamsMaxVelB Property

Maximum Velocity for the mapped "B" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelB { get; set; }
Public Property MaxVelB As Double
    Get
    Set
public:
property double MaxVelB {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelC Property

KM_MotionParamsMaxVelC Property

Maximum Velocity for the mapped "C" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelC { get; set; }
Public Property MaxVelC As Double
    Get
    Set
public:
property double MaxVelC {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelX Property

KM_MotionParamsMaxVelX Property

Maximum Velocity for the mapped "X" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelX { get; set; }
Public Property MaxVelX As Double
    Get
    Set
public:
property double MaxVelX {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelY Property

KM_MotionParamsMaxVelY Property

Maximum Velocity for the mapped "Y" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelY { get; set; }
Public Property MaxVelY As Double
    Get
    Set
public:
property double MaxVelY {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.MaxVelZ Property

KM_MotionParamsMaxVelZ Property

Maximum Velocity for the mapped "Z" axis

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double MaxVelZ { get; set; }
Public Property MaxVelZ As Double
    Get
    Set
public:
property double MaxVelZ {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.RadiusA Property

KM_MotionParamsRadiusA Property

Radius Associated with Axis A

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double RadiusA { get; set; }
Public Property RadiusA As Double
    Get
    Set
public:
property double RadiusA {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.RadiusB Property

KM_MotionParamsRadiusB Property

Radius Associated with Axis B

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double RadiusB { get; set; }
Public Property RadiusB As Double
    Get
    Set
public:
property double RadiusB {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.RadiusC Property

KM_MotionParamsRadiusC Property

Radius Associated with Axis C

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double RadiusC { get; set; }
Public Property RadiusC As Double
    Get
    Set
public:
property double RadiusC {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.TCP_Active Property

KM_MotionParamsTCP_Active Property

Whether RTCP (Kinematics) is Active or not.

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool TCP_Active { get; set; }
Public Property TCP_Active As Boolean
    Get
    Set
public:
property bool TCP_Active {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams.TPLookahead Property

KM_MotionParamsTPLookahead Property

How many seconds can be previewed for Trajectory Planning optimization

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public double TPLookahead { get; set; }
Public Property TPLookahead As Double
    Get
    Set
public:
property double TPLookahead {
    double get ();
    void set (double value);
}

Property Value

Double
See Also

Reference

KM_MotionParams Class


KM_MotionParams.UseOnlyLinearSegments Property

KM_MotionParamsUseOnlyLinearSegments Property

Converts Arcs to linear segments (Kinematic Setting)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public bool UseOnlyLinearSegments { get; set; }
Public Property UseOnlyLinearSegments As Boolean
    Get
    Set
public:
property bool UseOnlyLinearSegments {
    bool get ();
    void set (bool value);
}

Property Value

Boolean
See Also

Reference

KM_MotionParams Class


KM_MotionParams Methods

The KM_MotionParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | SetTPParams | Force the Trajectory Planner to update it's parameters
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KM_MotionParams Class


KM_MotionParams.SetTPParams Method

KM_MotionParamsSetTPParams Method

Force the Trajectory Planner to update it's parameters

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public void SetTPParams()
Public Sub SetTPParams
public:
void SetTPParams()
See Also

Reference

KM_MotionParams Class


KMConsoleHandler Delegate

Callback delegate for KM_Controller returns

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate int KMConsoleHandler(
    string message
)
Public Delegate Function KMConsoleHandler (
    message As String
) As Integer
public delegate int KMConsoleHandler(
    String^ message
)

Parameters

message String
message from KM_Controller function

Return Value

Int32
See Also

Reference

KMotion_dotNet Namespace


KMErrorHandler Delegate

callback for low level KMotion error messages

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void KMErrorHandler(
    string message
)
Public Delegate Sub KMErrorHandler (
    message As String
)
public delegate void KMErrorHandler(
    String^ message
)

Parameters

message String
See Also

Reference

KMotion_dotNet Namespace


KMOTION_CHECK_READY Enumeration

KMotion CheckReady Return Codes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum KMOTION_CHECK_READY
Public Enumeration KMOTION_CHECK_READY
public enum class KMOTION_CHECK_READY
Members
Member name | Value | Description
OK | 0 | All OK but ready not received
TIMEOUT | 1 | if timed out waiting to receive Ready
READY | 2 | Ready has been successfully received
ERROR | 3 | if no board connected or other error
See Also

Reference

KMotion_dotNet Namespace


KMOTION_TOKEN Enumeration

KMotionLocked Return Codes

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum KMOTION_TOKEN
Public Enumeration KMOTION_TOKEN
public enum class KMOTION_TOKEN
Members
Member name | Value | Description
KMOTION_LOCKED | 0 | (token is locked) if KMotion is available for use
KMOTION_IN_USE | 1 | if already in use
KMOTION_NOT_CONNECTED | 2 | if no board connected
See Also

Reference

KMotion_dotNet Namespace


MCODE_TYPE Enumeration

Possible M Code Action Types

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum MCODE_TYPE
Public Enumeration MCODE_TYPE
public enum class MCODE_TYPE
Members
Member name | Value | Description
M_Action_None | 0 | do nothing
M_Action_Setbit | 1 | Set a bit high or low
M_Action_SetTwoBits | 2 | Set two bits either high or low
M_Action_DAC | 3 | output a value to a DAC
M_Action_Program | 4 | run a KMotion User C program
M_Action_Program_wait | 5 | run a KMotion User C program wait til finished
M_Action_Program_wait_sync | 6 | run a KMotion User C program wait til finished, resync positions
M_Action_Program_PC | 7 | run a Windows program wait til finished
M_Action_Callback | 8 | Callback to the User Application
M_Action_Waitbit | 9 | Wait/Hold until a bit is high or low
See Also

Reference

KMotion_dotNet Namespace


PREV_STOP_TYPE Enumeration

Possible Previously Stopping Types after an Interpreter Halt

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum PREV_STOP_TYPE
Public Enumeration PREV_STOP_TYPE
public enum class PREV_STOP_TYPE
Members
Member name | Value | Description
Prev_Stopped_None | 0 | Was not stopped or should attempt to resume
Prev_Stopped_Indep | 1 | Was Halted while doing an indpendent motion (Rapid)
Prev_Stopped_Coord | 2 | Was Halted while doing a coordinated motion
Prev_Stopped_Coord_Finished | 3 | Was Halted while doing a coordinated motion - but completely finished the motion
See Also

Reference

KMotion_dotNet Namespace


RETRACT_MODE Enumeration

Retract Mode
Remarks
Used for canned cycles

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public enum RETRACT_MODE
Public Enumeration RETRACT_MODE
public enum class RETRACT_MODE
Members
Member name | Value | Description
R_PLANE | 0 | R Plane Remarks Uses a supplied R value for retracting
OLD_Z | 1 | Previous Z Remarks Uses the previous Z value for retracting
See Also

Reference

KMotion_dotNet Namespace


StatusConsts Class

Defines form PC-DSP.h defining number of available devices
Inheritance Hierarchy
SystemObject
KMotion_dotNetStatusConsts

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public class StatusConsts
Public Class StatusConsts
public ref class StatusConsts

The StatusConsts type exposes the following members.

Constructors
 | Name | Description
Public method | StatusConsts | Initializes a new instance of the StatusConsts class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
N_ADCS | Number of Kanalog ADCs
N_ADCS_KOGNA | Number ADCs on KOGNA
N_ADCS_SNAP | Number ADCs on SnapAmp per SnapAmpA
N_CHANNELS_KOGNA | Number Axis Channels available for Kogna (KFLOP has only 8 fields for additional channels will be zero)
N_DACS | Number of Kanalog DACs
N_DACS_KOGNA | Number DACs on Kogna
N_ENCS | Number Encoder Inputs on KFLOP 0 - 7
N_ENCS_KOGNA | Number Encoder Inputs on Kogna 0 - 19
N_ENCS_SNAP | Number Encoder Inputs on SnapAmp 0 - 19
N_IO_PWMS | Number 8-bit PWMs for Kogna/KFLOP
N_KOGNA_HRPWM | Number 12-bit (High Resolution) HRPWMs for Kogna
N_PC_COMM_PERSIST | Number of Persist variable included in Status Upload
N_PWMS | Number 8-bit PWMS on IO Pins
N_PWMS_SNAP | Number PWMs on SnapAmp per SnapAmpA
Top
See Also

Reference

KMotion_dotNet Namespace


StatusConsts Constructor

Initializes a new instance of the StatusConsts class

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public StatusConsts()
Public Sub New
public:
StatusConsts()
See Also

Reference

StatusConsts Class


StatusConsts Methods

The StatusConsts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StatusConsts Class


StatusConsts Fields

The StatusConsts type exposes the following members.

Fields
Name | Description
N_ADCS | Number of Kanalog ADCs
N_ADCS_KOGNA | Number ADCs on KOGNA
N_ADCS_SNAP | Number ADCs on SnapAmp per SnapAmpA
N_CHANNELS_KOGNA | Number Axis Channels available for Kogna (KFLOP has only 8 fields for additional channels will be zero)
N_DACS | Number of Kanalog DACs
N_DACS_KOGNA | Number DACs on Kogna
N_ENCS | Number Encoder Inputs on KFLOP 0 - 7
N_ENCS_KOGNA | Number Encoder Inputs on Kogna 0 - 19
N_ENCS_SNAP | Number Encoder Inputs on SnapAmp 0 - 19
N_IO_PWMS | Number 8-bit PWMs for Kogna/KFLOP
N_KOGNA_HRPWM | Number 12-bit (High Resolution) HRPWMs for Kogna
N_PC_COMM_PERSIST | Number of Persist variable included in Status Upload
N_PWMS | Number 8-bit PWMS on IO Pins
N_PWMS_SNAP | Number PWMs on SnapAmp per SnapAmpA
Top
See Also

Reference

StatusConsts Class


StatusConsts.N_ADCS Field

StatusConstsN_ADCS Field

Number of Kanalog ADCs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ADCS = 8
Public Const N_ADCS As Integer = 8
public:
literal int N_ADCS = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_ADCS_KOGNA Field

StatusConstsN_ADCS_KOGNA Field

Number ADCs on KOGNA

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ADCS_KOGNA = 4
Public Const N_ADCS_KOGNA As Integer = 4
public:
literal int N_ADCS_KOGNA = 4

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_ADCS_SNAP Field

StatusConstsN_ADCS_SNAP Field

Number ADCs on SnapAmp per SnapAmpA

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ADCS_SNAP = 8
Public Const N_ADCS_SNAP As Integer = 8
public:
literal int N_ADCS_SNAP = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_CHANNELS_KOGNA Field

StatusConstsN_CHANNELS_KOGNA Field

Number Axis Channels available for Kogna (KFLOP has only 8 fields for additional channels will be zero)

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_CHANNELS_KOGNA = 16
Public Const N_CHANNELS_KOGNA As Integer = 16
public:
literal int N_CHANNELS_KOGNA = 16

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_DACS Field

StatusConstsN_DACS Field

Number of Kanalog DACs

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_DACS = 8
Public Const N_DACS As Integer = 8
public:
literal int N_DACS = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_DACS_KOGNA Field

StatusConstsN_DACS_KOGNA Field

Number DACs on Kogna

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_DACS_KOGNA = 8
Public Const N_DACS_KOGNA As Integer = 8
public:
literal int N_DACS_KOGNA = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_ENCS Field

StatusConstsN_ENCS Field

Number Encoder Inputs on KFLOP 0 - 7

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ENCS = 8
Public Const N_ENCS As Integer = 8
public:
literal int N_ENCS = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_ENCS_KOGNA Field

StatusConstsN_ENCS_KOGNA Field

Number Encoder Inputs on Kogna 0 - 19

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ENCS_KOGNA = 20
Public Const N_ENCS_KOGNA As Integer = 20
public:
literal int N_ENCS_KOGNA = 20

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_ENCS_SNAP Field

StatusConstsN_ENCS_SNAP Field

Number Encoder Inputs on SnapAmp 0 - 19

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_ENCS_SNAP = 4
Public Const N_ENCS_SNAP As Integer = 4
public:
literal int N_ENCS_SNAP = 4

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_IO_PWMS Field

StatusConstsN_IO_PWMS Field

Number 8-bit PWMs for Kogna/KFLOP

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_IO_PWMS = 8
Public Const N_IO_PWMS As Integer = 8
public:
literal int N_IO_PWMS = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_KOGNA_HRPWM Field

StatusConstsN_KOGNA_HRPWM Field

Number 12-bit (High Resolution) HRPWMs for Kogna

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_KOGNA_HRPWM = 4
Public Const N_KOGNA_HRPWM As Integer = 4
public:
literal int N_KOGNA_HRPWM = 4

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_PC_COMM_PERSIST Field

StatusConstsN_PC_COMM_PERSIST Field

Number of Persist variable included in Status Upload

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_PC_COMM_PERSIST = 8
Public Const N_PC_COMM_PERSIST As Integer = 8
public:
literal int N_PC_COMM_PERSIST = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_PWMS Field

StatusConstsN_PWMS Field

Number 8-bit PWMS on IO Pins

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_PWMS = 8
Public Const N_PWMS As Integer = 8
public:
literal int N_PWMS = 8

Field Value

Int32
See Also

Reference

StatusConsts Class


StatusConsts.N_PWMS_SNAP Field

StatusConstsN_PWMS_SNAP Field

Number PWMs on SnapAmp per SnapAmpA

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public const int N_PWMS_SNAP = 4
Public Const N_PWMS_SNAP As Integer = 4
public:
literal int N_PWMS_SNAP = 4

Field Value

Int32
See Also

Reference

StatusConsts Class


TraverseCompletedHandler Delegate

Delegate that gets fired off on an async Straight Traverse return call

Namespace: KMotion_dotNet
Assembly: KMotion_dotNet (in KMotion_dotNet.dll) Version: 1.0.1.0 (1.0.1.0)
Syntax
C#
VB
C++
Copy
public delegate void TraverseCompletedHandler(
    Object callback
)
Public Delegate Sub TraverseCompletedHandler (
    callback As Object
)
public delegate void TraverseCompletedHandler(
    Object^ callback
)

Parameters

callback Object
User supplied object that gets returned when complete. This can be used to keep track of several calls
See Also

Reference

KMotion_dotNet Namespace